Project with PeppyMeter/PeppySpectrum Screensaver Plugin for VOLUMIO

Thank you but it does not work , i have copied everything as you said. The others start without problems but not custom_7 map.

Is the folder even loading, as I encountered similar issues with custom_2, custom_3,…
So now I’ve dropped everything in Custom_1

1 Like

How do the others start? There is only 1 skin for testing.
Do you have such a folder?
custom_7 (1480x320)
And in folder 3 graphics and meters.txt ?

I have everything in the folder

I have tried uninstalling peppymeter , putting it in another folder as suggested , meters is edited to the one but it still doesn’t work. What can I do ? Thank you for your help

I got it started but it looks like this

edit: Installed everything from scratch twice .

what happens is when I add the custom_7 folder and the 3 pictures pluss the meters text , it wont start, and it hangs. Something is wrong with that config meter file i think.
If I dont do anything the default meter folders works fine. but has the wrong resolution all of them.

Hi Everyone, I installed Volumio 3.251 & used the video by Andy to install PepperMeter Plugin. It was working great until I installed the FusionDsp Plugin. After installing FusionDsp the sound on Spotify stopped working & the PeppyMeter Plugin also stopped working. I fixed the spotify sound using the info in the description of Andy’s install video. Now my problem is I have the PeppyMeter plugin installed & Enabled but it is no longer working. I’ve tried disabling & enabling the plugin and restarted, I’ve reinstalled the plug-in a few times & even did a fresh Volumio install but as soon as I install FusionDsp it stops working all over again. Are you able to help me out? I really want to get this working with FusionDsp & spotify for a project I’m doing. I’m using a Raspberry Pi3b+ & waveshare 5.5" touchscreen with the touchscreen plugin installed & enabled. I also have a X400 V3.0 Dac/amp. This is the video I used to install:

You probably bought it on Alliexp. Provide a link to this monitor - I will look
And try:
type in userconfig.txt
hdmi_cvt=1480 320 60 6 0 0 0

But first, replace the image files (2) and try
custom_7 (1480x320).zip (235.2 KB)

Hi @Gelo5 ,

I’ve searched for a tutorial on this options on userconfig.txt in volumio but couldn’t find much info (regarding HDMI for instance).
I understand that hdmi_cvt = 1480 320 60 might be resolution and refresh rate, but the 0s and the other settings you inserted I have no idea…

Is there any info regarding this options? One of the things I wish to try is to do, for instance, is to fix a 1080P resolution on a 4K monitor.

Thanks in advance.

Thank you for your answers

By changing the config file in peppymeter folder as you see here

And restarting the peppymeter , it then shows up like this

We are a step closer to success

And the screen is original waveshare 11.9 bought from 11.9" IPS Kapasitiv Touchskjerm 320x1480, kompatibel med bl.a. RPi - Digital Impuls Oslo AS in Norway

Edit : after restarting screen width and info gets remowed and shows

And the screen goes back to


OK, try to overwrite everythingcustom_7 (1480x320).zip (243.7 KB)
Or delete the entry in config.txt

It is difficult to fix anything without a monitor

I think your monitor is 1680 not 1480

thank you for trying to help me, I appriciate it

My monitor is this one

So after a clean install of everyting
I copy custom_7 folder to peppymeter

Try to start it

Everything hangs for some time. and nothing happens it does not start

i delete plugin, instlal plugin back again ,and start random folder thats allread installed , and then it works without problem

Something is wrong somewhere and I dont know what it can be the problem

for example if i add the custom_7 files to Wide folder , and edit the meters.txt , it starts but with wrong resolution, by editing config.txt widht and height to correct, it then shows correct .

One more thing. Set the data in userconfig.txt not in config.txt. Maybe it will work?

Write to @2aCD, he will surely help.

And my last (emergency) advice:
Copy to 1920x480 folder (closest to your resolution)

That worked !
I copied it to the 1920x480 folder and now it shows correct.

Now i just have to learn how to make my own meters. I would love to have some of the blue mcintosh dials

Thank you for your help


the McIntosh dails are already given by default


Try: (524.7 KB)

1 Like

Can i use this plugin on Raspberry Pi 2 Model B?

These look good on 1280x800. Thanks Gelo5.

Corrected txt (3.0 KB)
Corrected txt for Advence (meters) - again
add to (641 Bytes)

Hi Gelo5 - All looks good now with the ‘Advance’ skin…much appreciated.

1 Like

If Volumio works, it probably does.
Most have RPi3 and RPi4.

1 Like