The plugin installs a miniDLNA (aka ReadyMedia) server.

Through Volumio’s UI the plugin provides access to all configuration options of the miniDLNA server (except “user to run as” which is set to “volumio”). Currently the options of miniDLNA version 1.1.2 (on Volumio 2) and version 1.2.1 (on Volumio 3) are supported.

The plugin also features a rescan button that allows to force a rescan of all media directories for new media files.

1 Like

Thank you very much for this plugin. I am using it since some months, but now I have a question. Is it possible to set more than one media folder for videos (or music or images)? I have some videos on an attached USB drive and some on the internal SD card. So I would like to define two folders containing video files. In the settings there is only one line for each media format.

1 Like

Currently it is not possible to define more than one path for each media type (audio, videos and pictures) from the plugin’s config page.

Edit: The “Wide links” options mentioned below is not available in the minidlna version that gets installed on Jessie based Volumio 2, but only on the upcoming Volumio 3!

Maybe you can circumvent this limitation as follows:
If possible create a symlink pointing to the second location (e.g. the USB drive) in the path you specified on the config page (e.g. the internal SD card). Then enable the “Wide links” option on the plugin’s config page. I have to say that I never tested if the “Wide links” option works, but it might be worth a try.

Edit 2: I will do a new version of the plugin that will allow to specify multiple locations for the files of each media type from the plugin’s config page.

Thank you again for your quick answer. I will wait for your new version to specify all locations of my media files. I found out that it is possible to define different locations in the miniDLNA config file, but this would be a dirty solution. I cannot find a “Wide links” option on the plugin’s config page.

Will have a new version ready soon.

Yes, as I wrote above this option is not available on Jessie based Volumio versions, i.e. 2.x :wink: This is because the minidlna version for Jessie is too old.

Version 1.1.7 of the plugin has just been merged (thanks again to @balbuze) and should already be available from Volumio’s plugin manager.

This version allows to specify multiple paths to the files of each media type. Important: Multiple paths in the input fields for audio, videos and pictures have to be separated by " // " (without the quotation marks), i.e. space slash slash space. Paths have to be absolute.

E.g. for audio files: /mnt/USB/usbdrive/music // /home/volumio/music

1 Like

i can install it gvolt but to set it up… that’s what i’m missing …
trying to test something new but missing the basics…
i linked it to my usb drive but what could i do now…

1 Like

For a basic setup of the miniDLNA server there is not much more to do than specifying the path(s) to your media files on the plugin’s config page.

but how do i access it and how does it work…
i have it now on both pi’s…
music is this path : /media/Extreme_Pro_1/Music

Oh well, that’s too much for me to write down now… But in short:

The miniDLNA server runs independently from Volumio and serves media files it finds in the path(s) you specify to DLNA/Upnp clients. Volumio itself can use a DLNA server like miniDLNA as a source as well as many TVs or audio systems can.

my tv has it but how do i cast it to it? i see no button any where cast to …

1 Like

On the TV you should be able to choose a DLNA server somewhere. The miniDLNA on Volumio should appear as “VolumioDLNA”, if you didn’t change the “friendly name” on the plugin’s config page.

After selecting the DLNA server you can browse the media files.

1 Like

oke i will try i see the server already on tv

i see the folders but no music on the tv… folders are empty…
changed it back to /mnt for the music folder

You can check if miniDLNA has discovered your music files in browser opening


e.g. “”

If file count for audio files should be 0 try to use the “Rescan” option at the bottom of the plugin’s config page.

Other reasons why you don’t see files could be that your TV has limitations what file format can be played. Sometimes embedded pictures are a problem because the TV can only a certain picture resolution and/or picture file size…

files are 4604 connections 0

|0|Sony Bravia|192.168.1.xx <<<< TV
|1|Generic UPnP 1.0|192.168.1.xx
|3|Unknown|192.168.1.xx /rpi

1 Like

Do you see your TV in the list of connected clients (look for the IP and / or hardware address of your TV).

ip of tv is present checked on tv if it could connect all ok
if i try to connect from tv to rpi connection refused
rebooted the pi didn’t help…

Sounds like a network issue. Router settings OK? I could imagine some routers block UPnP traffic.

1 Like

upnp is enabled… i see all folders but not the files in it.