[Plugin] GPIO Buttons: Control Volumio 2/ Volumio 3 with buttons

Push-buttons connected to GPIOs can work without pull-up or pull-down resistors.
The input configuration and the internal pull-up can be enabled in /boot/userconfig.txt

You can find a lot of push buttons on Aliexpress (already tested, they are good)

Some sellers offer button customization (not tested) :

Has anyone tested the response time to the button pushes? I am thinking of using a micro to control a rotary (yes I know volumio can do this, but I need other stuff done). I would like to know how quickly I can send volume pulses to Volumio.

1 Like

did you find a solution for this?

Is this still active? Where can I download the plugin?

Sadly the plug-in file gpio-buttons.zip is not available anymore. :frowning: Is here somebody who had it and can share it with me?

I had some issues with my old setup and wanted to install a fresh copy.

sudo apt-get update
sudo apt-get -y install build-essential
cd ~
wget http://plugins.volumio.org/plugins/volumio/armhf/system_controller/gpio-buttons/gpio-buttons.zip
mkdir ./gpio-buttons
miniunzip gpio-buttons.zip -d ./gpio-buttons
cd gpio-buttons
npm install --save onoff@6.0.0
volumio plugin install
cd .. && rm -R ./gpio-buttons && rm -R ./gpio-buttons.zip
1 Like

Just tried, and installed succesfully. :grinning_face_with_smiling_eyes:

i just retry several times and everything seems ok until the plugin failed to be active when i push the “on/off” button of the plugin screen…

Please provide more details, as I can’t understand what the exact issue is.

in fact i installed button plugin by following your instructions, it work so i can see the plugin in volumio but i can’t make it start, when i try it say : the plugin failled to start, please update it or contact the plugin developer…

Strange,
that are the exact steps I did to make it work.
try via SSH:
cd /data/plugins/system_controller/gpio-buttons
npm install --save onoff@6.0.0

Thank you but doesn’t work, i’ll try on a fresh install !

Would you share some system logs please?

The exact error might point to what happened in your case.

BTW, perfect example for the push towards proper vetted plugins in the plugin store :slight_smile: Users should just be able to click click and go, and not mess with commands that they might get wrong…

thanks you, i tried on a fresh install and it worked great, now i’m ok with that !

Any word on when this plugin will be available in the Volumio 3 plugin store?

While streaming through Spotify Connect, when I push the Play/Pause button, it pauses correctly, but then when I push the Play/Pause button again, it starts to play the last track I played off my local NAS.

Is there a way to change this behavior?

Hello to all of you,
New here, I don’t know if I’m posting in the right place, please excuse me…
Moreover English is not my language, I write thanks to Deepl…
I installed VOLUMIO 3 (3.396 and 3.423) on Paspberry pi 3B and 3B+, until now, all is well.
But when I install the GPIO Buttons Plugin (0.8.3) proposed by the download interface, it is impossible for me to turn off the system, whether I choose to connect my pushbutton between the chosen GPIO and the ground or the +3.3, could someone help me,
thank you in advance for your lights…

Many thanks for the tutorial! :+1:

all that remains is to wire and test :wink:

The tutorial?

That’s obsolete. The GPIO Buttons are in the plugin store. No need to perform al kind of tricks anymore :slight_smile: