Official 7" touch screen can display but cannot input

Raspberry Pi 4B + Volumio 2.917

Touch screen worked prefectly for 1.5years and found cannot input this morning. Followed the internet information to “apt upgrade” which killed Volumio. Installed the latest version of Volumio 3 but same problem (by the way, UPNP problem seems still not fixed in Volumio 3). Back to Volumio 2.917, got error when install touch screen plugin (don’t have this error with Volumio 3), the error is cpp version not met. Follow the log information to “apt -f install” which fixed the plugin install problem but still same cannot input. Tried “cat /proc/bus/input/devices | grep FT5406 -B 1 -A 8” and below information showed up. Anything else I can check?

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name=“FT5406 memory based driver”
P: Phys=
S: Sysfs=/devices/virtual/input/input0
U: Uniq=
H: Handlers=mouse0 event0
B: EV=b
B: KEY=400 0 0 0 0 0 0 0 0 0 0
B: ABS=2608000 3

If it worked before, I assume it could be a hardware defect. You may have a look at this thread and check cables and connections.

From within Volumio can check if touch events are detected as described in my post over there. To do so you need to SSH into Volumio first.

Thanks a lot for your suggestion! I tried “cat /dev/input/event*”, nothing show up in the terminal when I touch the screen. Does it means the touch function of my screen is dead?

Possibly, but first please double-check the DSI cable is properly seated, especially that it is not tilted in the connectors and that it is seated all the way into the connectors. If re-seating the DSI cable should not help and you have a second one exchange them to rule out a defective DSI cable.

Also try to inspect (and re-seat) the thin yellowish cables between the display and its PCB and the connectors. To have a better idea you may have an additional look here.

In case you have the dedictated cables for SDA and SCL connected between display and Pi remove them so only the DSI cable and the connections for +5V and Ground remain.

If nothing helps you could test the touch function using another OS (e.g. Raspberry Pi OS).

Truns out it is the small cable loosed (red cricle in the attached image). Reconnect and it back to work again. Thanks a lot for your suggestion!