My 7" touch screen has lost its touch functionality

Hi, since upgrading to Volumio 3, I’ve lost the “touch” functionality of my raspberry pi 7" screen (official). Otherwise, the display is fine - it is just no longer touch sensitive. I haven’t used this in the last couple of months, and it doesn’t seem to be a discussed issue, so it might not even be a Volumio 3 issue. Maybe the screen has gone bad? I’m just wondering if anyone has come across this and might have a suggestion to fix it.

I’ve reformatted the SD card a few times, reinstalled Volumio a few times and uninstalled and reinstalled the touchscreen plug-in a few times. Initially after updating to Volumio 3, when enabling the touchscreen plug-in I was met with a black screen (though text appeared on start up and when the plug-in was disabled), but I’ve since got the screen to display properly. It is just the “touch” aspect that is an issue.

I’m a virtuoso subscriber, but I understand that I should still be able to use the plug-ins?

Any suggestions will be appreciated.

I’m using a Raspberry Pi 3B.

I suggest to reseat the DSI cable. If you have a spare one try that, too.

If that does not help, please connect to Volumio via SSH and post the output of

ls -al /dev/input

I will suggest you try and see if the touch connector is loose on the screen pcb.

@Panos70 Yes, that’s worth a look, too.

@DanHillier That is the yellowish cable connected to J4 on the display’s PCB you can see in this picture.

Thanks for the suggestions. I’ve just tried tried re-inserting the cables, with no luck (though, a cable could still be faulty).

The output of ls -al /dev/input is:

drwxr-xr-x 3 root root 120 Feb 22 14:36 .
drwxr-xr-x 16 root root 3740 Feb 22 14:36 …
drwxr-xr-x 2 root root 60 Feb 22 14:36 by-path
crw-rw---- 1 root input 13, 64 Feb 22 14:36 event0
crw-rw---- 1 root input 13, 63 Feb 22 14:36 mice
crw-rw---- 1 root input 13, 32 Feb 22 14:36 mouse0

The content of “/dev/input” shows that an input device has been detected. If you have no other mouse or an IR receiver connected this would probably be the touchscreen.

Please run

cat /dev/input/event*

and touch the screen. When ready press Ctrl+c.

Do you see weird signs in your terminal?

1 Like

I tried that a few times and it didn’t do anything.

There is no mouse or IR receiver connected.

I’m going to call it quits for tonight. I haven’t tested the touch screen with another program, so I’ll do that tomorrow, and at least that will give me a clue as to whether it is a screen problem or not.

I’ve had two of the official 7" screens lose touch functionality after a couple of years use. I changed the DSI cables and tried them on a different Pi and different power supplies, no luck. Nothing to do with Volumio in my case, same on RPi OS.
Display still wirks fine on both though.