No sound through Schiit Modi 3

Hi all. Brand new to streaming, and I thought I’d start with Volumio and a Modi 3. My stuff:

Schiit Vali 2 headphone amp
Schiit Modi 3 DAC
Raspberry Pi Zero W

I have installed the latest version of Volumio and inserted the SD card into the Pi. Went through the initial startup fine, except that:

  1. My only choices for music output were HDMI with I2S off, or a list of DACs with I2S on but the Modi was not found there.

  2. No option for selecting musical input, but I also don’t have a server. I’m not a computer guy, don’t want to go into all that. I was intending on using the Volumio to stream internet radio easily.

Anyway. Got it set up, selected a radio station through the Volumio UI, and a lotta nothing.

Changed cables. Checked internet connection (65Mbps down.) Volumio tells me my internet radio to streaming to me at 48 Kbps, but what’s weird is the “timer” on the bottom of the UI doesn’t advance in real time. It stays at one or two, until I move on to tinker with something else in the UI. I go back to the radio, and the timer jumps forward. Still no sound.

I’ve tried most every I2S on the list. Nothing. HDMI doesn’t work, and that’s the only choice I get for non-I2S output. Dunno what’s going on, I’d appreciate guidance. Thank you!

Probably the power output of PI Zero W is not enough to power on your Schiit Modi DAC. And this is why it does not get recognized.

I would suggest one of the 2:

  • Use a powered USB hub to connect the Modi to the PI
  • Get a PI4 (suggested)

Let us know

Hi! Thanks for the response, I’ve always had the Modi on a separate power supply.

How are you connecting your Pi to the Modi 3? Are you using the HDMI or the Micro USB next to the USB power in?

If you can, I would suggest connecting the Pi to the Modi using the micro usb - then in Volumio settings :

l2s Off
Output - Headphones
set volume to maximum

That might work :crossed_fingers:

Ignore my previous post :roll_eyes:

I have just found this:

Essentially there is no quick and easy way to get sound out of a Pi Zero W :grimacing:

If you Pi has the header pins it might be easier to fit a i2S digi hat - something like - DollaTek HIFI DiGi+ Digital Sound Card I2S SPDIF Optical Fiber RCA for Raspberry Pi

If you don’t have the header pins on your Pi Zero you might think about an upgrade to a PI 3 then you can use the USB out direct into your Modi - good luck.

he can better follow the instructions of volumio.

So… audio only comes out of the HDMI port without fiddling with the header? No, there are no pins there.

The MODI is a USB DAC…

Yep, so it’s supposed to take the data stream out of the USB-out on the Zero W and convert it to analog all on its own, right?

Yes, but if you don’t see it as an available choice (you see only HDMI) it means that the DAC is not properly recognized by Volumio, hence my 2 suggestions

The one suggestion I’ve done, the Modi is plugged in to its own power supply. The only other suggestion is to get a Raspberry Pi 4?

Can you send us a log so we see why its not discovered?

Just paste the log link here

Will do after work.

And here it is.

if you have 5ghz please switch to it, you don’t have a great connection and maybe a network / dns problem.

I have tried, it does not see my 5G connection. Newest log file:

WARNING!!! Some remote endpoints cannot be reached!
Failing endpoints:, 5725 ms, 5725 ms, 5725 ms, 5725 ms, 5725 ms, 5725 ms, 5725 ms, 5725 ms, 5725 ms, 5725 ms, 5725 ms, 5725 ms, 5725 ms

after trying to connect to internet it all crashes not reaching all end points.

The PI does not see anything connected to your usb ports.
How did you connect the DAC to the PI zero?
What kind of cable did you use?

Several issues have been reported with Schitt Modi,
Maybe adding dwc_otg.speed=1 to /boot/cmdline.txt does the trick.