New Volumio Spotify Plugin Open Beta-Testing

Yes, I’m glad to, it worked out that easy.

The first button doesn’t work as expected for me too.

This is what I get (yes, I listen to strange music - I’m old, allowed to be strange):

  1. ) Skips wild through the songs…

2.) Plays the next song, not the one it belongs to.

3.) Clicking the 3 dots and choose “Play” works fine! I will use that for now.

But only in Spotify … in my library all 3 buttons are working as expected.

Not judging your music taste :slight_smile:

If you start spotify, just click (and only click) on 2. Does this also skip to the next song?

Yes, it did skipping. I clicked on “Pisces”, but it went to “Teacher, Teacher!”.

I did the same test in Edge (no addon, vanilla browser installation), with the same result.

Something for on the todo list. Thanks for confirming.

You are welcome! I’m very happy, using a free raspberry pi and some old speakers with free software for music.

All the people working on volumio and the plugins are doing a great work!

1 Like

Hello :wave:

I was wondering if there is a way not to change Spotify volume when I change it on Volumio?

As you can see in this video , when I change volume from Volumio (hardware), it also changes it in Spotify (software), which is weird and not the same… (btw if I change the volume in Spotify, it doesn’t change Volumio’s volume)


spotify just randomly stops playing for the last few days but keeps going but no sound so had to reconnect to get sound.
new sdflash.
Peppy meter installed.

edit: still having issues spotify stops intermittently, new clearer log.

volumio version: 3.422
spotify: 3.0.7
raspberry pi 4b.
dac: philips 1543 nos dac.

Hi I am using the spotify plugin and I noticed that after I logout from the spotify account, I cannot login again. After some investigation on the log, I realised that in the config file volspotify,toml, the username and password are encapsulated in “” which causes it be incorrect. Upon removing the “”, everything becomes fine again.

So maybe the developer wants to make this small change in the next release.

Cheers guys

Thanks for letting us know!

Hello again!

Bad news… two days earlier, I wrote:

But it doesn’t stay that way… I have to logout and login again each day, even with only one spotify instance logged in.

I keep on watching. Maybe it’s because my internet reconnected last night and I got a new external IP?

1 Like

Not sure if there’s been any movement on this?
I get this problem a lot too, and a reboot is the only way to solve it.

info: Renewing Access Token via Daemon
Failed to refresh Token: Timeout

I’m running 3.396 on a Pi 3, running Spotify plugin 3.0.7

I have some issues with Spotify. When i start the first song after booting using Spotify App on android it plays fine but any other song i want to select, its being paused almost instantly. When i go to Volumio app it does the same thing until i select a different song and then it will play again, but also sometimes it will select a song i didnt pick. See log below:

I hope you can help me with these problems.

Please post your NAS problem in the correct topic. This topic is for the Spotify plugin.

i had the volume-resetting-after-each-song issue mentioned above: New Volumio Spotify Plugin Open Beta-Testing - #637 by heini88

downgrading 3.0.7 to 3.0.4 fixed the issue to me also. hopefully this helps isolate the issue with current versions.

Same problem but I think the 3.0.4 version also have issues, right?

is this plugin about to get any love soon,? or do I need to look for alternatives :frowning:

1 Like

Spotify works perfectly well on my Volumio but only for a short time then it loses its log in credentials. If I log out and in again it will once again work but only for hours or a few days, never for weeks. It is so annoying that I’m under intense domestic pressure to ditch Volumio for something else - and I’d rather not. Any ideas?

My log posting can be found at


----------------------------- Delete here & above before posting below -----------------

Same volume-reseting-problems here on the latest version using spotify connect controlling the volume within Spotify. But for me the volume does not reset at the next song, but the moment the volume pop up disappears.

I’m facing the exactly same issue as direwolf08 has described. (on a Raspberry PI)
Aso the log locks the same - when it spotify stops playing is shows “[Vollibrespot] : SessionError: Connection reset by peer (os error 104)”.

It is the same error when I play via spotify connect or in the UI. And I tried it with wired connection too.
(But I don’t believe that it is because of the network - the youtube plugin works fine and has no connection issue.)
I’m on the Version 3.0.7 but tried it also with version 3.0.4 etc.
I very much like this approach to stream Spotify on a small device headless - but is is really disappointing each time when it stops. I also shared a log with the Volumio Support, but they pointed me to this forum as the plugin is 3rd party.
So any help is very much appreciated!



I am running version 3.423, with Spotify plugin 3.0.7. What I experience is the following: when I click on a song in a list in Spotify (e.g. in a list of search results), the plugin starts playing the NEXT song, and I can never start the very first. Any clue from anybody why this is happening? Otherwise seems working, with some inconveniences, like when I pause a song for a longer period, cannot continue it, have to start another one, but I can live with that.



1 Like