New Volumio Spotify Plugin Open Beta-Testing

you can try to clear the cache of volumio android app and spotify app.
or remove the spotify plugin then reboot and reinstall and check if it helped.

what else did you enter for a value in settings/playback options/mixer type/default boot volume?

Thank you,
I already reinstalled the Plugin - no success.
Volumio App is only installed on my Phone… the problem exists also on the other phones that stream Spotify.
Value in the settings was first: disabled - I set it to 75 % - this didn’t change anything.

I can set the volume by Volumio App to 30% and then all songs will be played with 30%… When I set the volume louder in the Spotify App it switches back when the song changes to the Volume that is set in volumio (30%). This happens on all phones i use for playback…

so you use spotify in the volumio app, so it’s best to use spotify connect.

I use the original Spotify App and stream it to Volumio (Spotify Connect). The original Volumio App is only used for shutdown the system.
But this means with an older Version of the Plugin it should work as before and allow me to set the volume in Spotify App?

I never use the volume function and I just put it to the test and see what you mean and have the problem here too.


you can first uninstall and reinstall the spotify app, but then press the details button and choose a previous stable version.

Thank you very much! I deleted the Plugin and installed Version 3.0.4 - now it works as before! Fine :slightly_smiling_face: - great support!

Yes, I’m glad to, it worked out that easy.

The first button doesn’t work as expected for me too.

This is what I get (yes, I listen to strange music - I’m old, allowed to be strange):

  1. ) Skips wild through the songs…

2.) Plays the next song, not the one it belongs to.

3.) Clicking the 3 dots and choose “Play” works fine! I will use that for now.

But only in Spotify … in my library all 3 buttons are working as expected.

Not judging your music taste :slight_smile:

If you start spotify, just click (and only click) on 2. Does this also skip to the next song?

Yes, it did skipping. I clicked on “Pisces”, but it went to “Teacher, Teacher!”.

I did the same test in Edge (no addon, vanilla browser installation), with the same result.

Something for on the todo list. Thanks for confirming.

You are welcome! I’m very happy, using a free raspberry pi and some old speakers with free software for music.

All the people working on volumio and the plugins are doing a great work!

1 Like

Hello :wave:

I was wondering if there is a way not to change Spotify volume when I change it on Volumio?

As you can see in this video , when I change volume from Volumio (hardware), it also changes it in Spotify (software), which is weird and not the same… (btw if I change the volume in Spotify, it doesn’t change Volumio’s volume)


spotify just randomly stops playing for the last few days but keeps going but no sound so had to reconnect to get sound.
new sdflash.
Peppy meter installed.

edit: still having issues spotify stops intermittently, new clearer log.

volumio version: 3.422
spotify: 3.0.7
raspberry pi 4b.
dac: philips 1543 nos dac.

Hi I am using the spotify plugin and I noticed that after I logout from the spotify account, I cannot login again. After some investigation on the log, I realised that in the config file volspotify,toml, the username and password are encapsulated in “” which causes it be incorrect. Upon removing the “”, everything becomes fine again.

So maybe the developer wants to make this small change in the next release.

Cheers guys

Thanks for letting us know!

Hello again!

Bad news… two days earlier, I wrote:

But it doesn’t stay that way… I have to logout and login again each day, even with only one spotify instance logged in.

I keep on watching. Maybe it’s because my internet reconnected last night and I got a new external IP?

1 Like

Not sure if there’s been any movement on this?
I get this problem a lot too, and a reboot is the only way to solve it.

info: Renewing Access Token via Daemon
Failed to refresh Token: Timeout

I’m running 3.396 on a Pi 3, running Spotify plugin 3.0.7

I have some issues with Spotify. When i start the first song after booting using Spotify App on android it plays fine but any other song i want to select, its being paused almost instantly. When i go to Volumio app it does the same thing until i select a different song and then it will play again, but also sometimes it will select a song i didnt pick. See log below:

I hope you can help me with these problems.

Please post your NAS problem in the correct topic. This topic is for the Spotify plugin.

i had the volume-resetting-after-each-song issue mentioned above: New Volumio Spotify Plugin Open Beta-Testing - #637 by heini88

downgrading 3.0.7 to 3.0.4 fixed the issue to me also. hopefully this helps isolate the issue with current versions.