New Volumio Spotify Plugin Open Beta-Testing

Doesn’t help much.

The interface doesn’t refresh, or refresh super slowly (the timer progress for a few seconds then stop, then jumps a few seconds (to catch up on what it missed), if I refresh the page the time seems right but doesn’t progress.

Also, the state doesn’t change (doesn’t change to “play”), which I need for my home automation to work properly (the amp is turned on when the state goes to play.

Actually, it looks like it’s the other way around: the state is not set to play (even if the media is playing) therefore the UI timing is not refreshed/progressed.

Are these glitches only when you’re trying to listen to Spotify or generally with Volumio?

Mostly Spotify.
Used airplay and played some random web radio without any issues.

The timer UI doesn’t run with web radio either. But the “state” is correct (playing). It updates at random intervals (but the value after each update seems correct).

EDIT 2 :
It seems that all issues are linked to the timer. If I scrub near the end of the track using the IU, it will play the end of the song than start the next one (most of the time).
If I let it play to the end of the song without scrubbing it won’t play the next one.

Also once it’s in a bad state (stoped playing) it’s kinda crashed. Some part of the UI doesn’t work (scrubbing, play/pause, etc.) while the rest works (system, volume, …)

Sometimes while scrubbing a ‘spotify API unavailable’ (not sure of the wording) appears.

And I got it in a completely crashed state by scrubbing (needed a reboot) with a song playing and no way to stop it but reboot the device (using the UI).

I find this workaround only works when going from NAS based playlist to Spotify.
If I’ve already got a Spotifyplaylist, and then start another one (or the same one from a different point by tapping on a different song), the skipping starts happening again.

Same feeling here, Volumio is considered to be the best hifi streaming software, it should provide the possibility to exclude software related volume control to prevent sound degradation also on Spotify plugin.


I’m not able to start any song in Spotify now. I can browse my playlists. But when I click on “play” nothing happens at all.

In the log, I see following error:

info: CorePlayQueue::getTrack 0
info: [1674401260927] ControllerSpotify::clearAddPlayTrack
info: Setting this device active
error: Failed to Set Device Active: Error: Not Found Device ID: cd7a6bb56af0baba0b98cfd30e75d2a73def4e10
info: CoreCommandRouter::volumioGetState

I’m using “Spotify 3.0.7” of the plugin.

This is my system:

OS info

    Version of Volumio: 3.396
    Hostname: musicliving
    Kernel: 5.10.92-v7l+
    Governor: performance
    Uptime: 0 days, 0 Hrs, 6 Minutes, 23 Seconds

Audio info

    Hw audio configured: Headphones
    Mixer type: Hardware
    Number of channels: 8
    Supported sample rate: 44100 48000 88200 96000 176400 192000

Board info

    Manufacturer: Raspberry Pi Foundation
    Model: Raspberry Pi 4 Model B Rev 1.4
    Version: d03114
    Firmware Version: Jan 20 2022 13:56:48 - bd88f66f8952d34e4e0613a85c7a6d3da49e13e2

What do I do wrong?

Try to set mixer type to Software.


Thank you! I did, I even rebooted Volumio after changing the setting, but I stiill can’t start Spotify playlists or songs. :frowning:

I get still the same error in the log:

info: CoreStateMachine::play index undefined
info: CoreStateMachine::setConsumeUpdateService undefined
info: CorePlayQueue::getTrack 0
info: CoreStateMachine::startPlaybackTimer
info: CorePlayQueue::getTrack 0
info: [1674410256197] ControllerSpotify::clearAddPlayTrack
info: Setting this device active
error: Failed to Set Device Active: Error: Not Found Device ID: cd7a6bb56af0baba0b98cfd30e75d2a73def4e10

Playing webradio, mp3s from a smb-share and podcasts works still fine.

Hi @tiggr, did the Spotify plugin work for you before, or is this the first time you tried it?

Try uninstalling the plugin, rebooting and then reinstalling.

1 Like

Hi @SimonE!

to be honest, I’m not shure about that! Yes, sometimes ago, it worked for shure. But I don’t know when or which version worked!

Hi have to Volumion installations.

One old in my “man cave”, I’ve not used it for some month.

Today I set up a new one, I decided, I need some music in my livingroom too. :slight_smile:

I downloaded the last image for raspberry pi, flashed the card and installed the plugin. All worked fine, but the spotify-plugin.

Then I tried it on my old Volumio (another raspberry pi) and … spotify didn’t work. I don’t know, with which version it worked the last time. But both volumio installations don’t work at the moment.

I did as you want me to… it’s all strange…

I uninstalled the plugin.
I did a reboot.
I installed the plugin and tried to login in… it allways returned to an empty password field …
I rebootet the device
I started with me loged in… strange
I klick on play, nothing happens in the gui. but I get the same error in the log.

The next strange thing:If I disable “Multi-User Device”, It does not stay disabled!

There is something very strange with this plugin on my devices…

Or… I have an “Premium Individual” at spotify, maybe this is wrong?

That’s odd. Premium individual works fine by the way. Hopefully someone else here can help out.

you can only be logged in on 1 device, you’re sure you’re not logged in an any other device?

You can be logged in with multiple devices at same time, only listen with one at a time thought, the latest device with playback started will always take presence and other device will stop playback.

That would be fine for me, because I use spotify on two volumio devices and on my smartphone. But never two of them at the same time.

Later, I will try to logout on all devices but one volumio and give that a try.

OK, this is fun! :smiley:

I logged out from spotify on all devices and loged in only on one Volumio device.

Result: Spotify works now!

I logged in on the other devices again, and it still works!

But sometimes it jumps around like crazy between songs. And it allways dosen’t play the song I choose from the playlist, but the next one! :smiley: It doesn’t matter, if I use the web interface or the app on my smartphone - it plays the next song from the one i did choose.

I will do some more testing, but I’m happy it works now, even I have to choose a song previous to the song I want to play. Must have been a problem with multiple spotify logins.

I reply to myself… but this is interessting:

If I start a song with a click on the song or using the play symbol in front of the song, it plays the next song.

But if I go on the “3 points” on the right side and choose “Play”, it plays the right song!

If tested this in Chrome, Firefox and Edge under Linux.

That offset is prob. caused by clicking on the top play button. If you juswt click on the first track of a list it should be OK.

Good to hear that logging off did the trick. As I saw an error in your log which I expected was related to your problem.

error: Failed to Set Device Active: Error: Not Found Device ID: cd7a6bb56af0baba0b98cfd30e75d2a73def4e10

Hello :wave:

I was wondering if there is a way to not change Spotify volume when I change it on Volumio?

As you can see in this video, when I change volume from Volumio (hardware), it also changes it in Spotify (software), which is weird and not the same… but if I change the volume in Spotify, it doesn’t change Volumio volume.


I hope this topic doesn’t already exist - I couldn’t find it.

After the update to Volumio 3.324 I noticed the following problem.

Volume set in Volumino APP: 70%
Spotify APP (Plugin Version 3.0.6): Volume can be set by phone (higher / lower) but only for 1 song - if the next song starts to play volume automatically switches back to 70%.

Before the update I was able to set the volume (one time) and it was saved for the whole session - this was as it should.

I don’t know if it’s a problem of volumio or the plugin?

Any ideas how to fix it?

Thank you in advance.

Best regards…

you can try to clear the cache of volumio android app and spotify app.
or remove the spotify plugin then reboot and reinstall and check if it helped.

what else did you enter for a value in settings/playback options/mixer type/default boot volume?