New to Volumio. No sound yet! Failed to open"alsa"[alsa]; Failed to open ALSA device "hw:2,0"; No such file or directory

My first time here. I’m new to Pi’s and Volumio but not to audio engineering (30 years in it so far) and have some Linux and network knowledge.
I have built a Pi 4 (2G RAM) with a Hifi Berry DAC2 PRO (which I am now starting to regret) in to the hifi berry case and with a good 3A PSU. I down loaded and burnt a version 2.882 to a 32G SD card. Connecting the Pi to my home network worked fine, my laptop found the web UI offered by the Pi and it evetually (after some fiddling with folder permissions) found my music on my Synology NAS. Great…No sound though. I am now getting the message “Failed to open"alsa”[alsa]; Failed to open ALSA device “hw:2,0”; No such file or directory" and according to the received wisdom of the forums it would appear I have bought an incompatible DAC. Is this a fault with Hifi-Berry or Volumio’s driver.
I have read that some people have had success with getting audio from this set up. Are there plans from the volumio team to produce a fix for this DAC, or do I need to start again? Not impressed so far with Hifi Berry (have had compatibility problems with their digi I-O and Pi 3 with a work project). I also appreciate I’m quite inexperienced with Pis and may be been overly harsh on both the DAC and the SW, but there does seem to be a long history, which I know I should have looked for. Any help gratefully received.

did you switch I2C Dac option to on and did you select your dac?
if you have problems with that version try the beta 3.xx

Hello DVO
Yes I switched on I2S and then couldn’t find my DAC in the available list. So selected Hifi Berry pro and I have tried a couple of other selections. Thanks for the V3 beta suggestion, will investigate that if I get no further with 2.882

1 Like

what i see it that you have to pick: hifiberry-dacplus
Linux kernel to at least version 4.18.12

This is a typical, if not all that clear of a message you got. Basically, wrong dac selected in the list or a not supported dac and there is nothing for alsa to output to.

A possible solution from another thread here:

I think there are 2 different issues that are easy to confuse:

1- the headphones jack cannot work in Volumio, SOLUTION: buy a 4€ RCA to jack adapter on Amazon, end of the story.

2- the DAC2Pro with Volumio after reboot doesn’t work anymore with “Alsa HW 2.0” error, SOLUTION: after the first configuration with everything working fine, switch off the pi, edit config.txt and insert command.

force_eeprom_read=0 restart the pi3.

I have a pi3 with DAC2Pro and in that condition finally everything works fine: jingle at boot, the led on the DCA2Pro turn on when playback, volyme control works, now it’s perfect!

Hi Fingle I recently got a Pi4 and HiFiBerry Digi2Pro HAT. Could not get this to work with Volumio. If you look on the HiFiBerry website it has a list of approved OS Volumio isn’t one unfortunately but the others listed work.

The hifi support write there, you have to select dac+ pro driver :

Maybe you should check that too

Hope this help

Hi thanks for all the help everyone. This is probably one of the most responsive forums I have been on. Really impressed with all the help. Thanks.
I’ll give that a go tomorrow.

Further to all these responses. It has started working. As suggested else where in the forum I selected the generic HiFiBerry DAC and not I2S. Having previously tried to get audio from the Pi via HDMI 1 to a TV (which allowed me to also watch the very fast boot routine),
I then saw a green LED light up on the DAC board (which had not lit before). There was still no sound but Volumio was not reporting any HW or ALSA errors. I then tried HiFiBerry DAC and not I2S, the LED on the DAC board went out and when I played a track I got audio! Hurrahhh!!!
All in all, quite random and not straight forward, I was all ready to dive in to the config.txt and start altering EEPROM requests. I’m not sure how stable it will be over time, so I will keep an eye on it. The family are impressed with the GUI (a first for technology that Dad usually brings in to the house), and like the search functions.
I like the many radio options as well as the search features, which are a vast improvement on the Cambridge audio app this set up replaces.
Thanks again, hope it stays stable.