New setup v3.611, sound oke, after reboot no sound, i2s signal gone

a new setup v 3.611 (raspberry pi 4b) after going through the setup, dac (hifiberry dac+ pro) FusionDSP installed, everything plays normally (LEDs “clock” indicate this on an Ian Canada FifoPi MA reclocker) no sound after a reboot (LEDs “clock” indicate this on an ian canada FifoPi MA reclocker)
After a power down, only 1 LED turns on “play” on the reclocker, The i2s LEDs no longer turn on.

Even if I do a factory reset from the interface, I can’t get it right anymore.

Tried version 3.546, everything okay, no problem.

log for the reboot.

log after the reboot.

I also see a difference in config file, dtoverlay “slave” vs old no “slave”

new config

old config

also saw this one passing by
Scherm­afbeelding 2024-02-04 om 14.59.45

first of all, do not edit the config.txt file, please add your custom settings to userconfig.txt

I added a warning at the beginning of the file, but apparently it’s still not enough, people keep editing it

secondly, the “slave” parameter was added to fix the problem with I2S DACs worning in master mode on the Pi5

if you want you can try to add the string without the “slave” parameter on userconfig.txt, it will override the one with “slave” parameter in config.txt

I will flash a new image tonight and use the userconfig.txt.

okay flashed a new v3.611.
removed slave dtoverlay=hifiberry-dacplus and put it in userconfig was the solution.

problem solved and thanks for the quick response :smiley:

1 Like