Ian Canada FifoPiMa with ProtoDAC no sound

hai and welkom.

the LED of XO1 or XO2 lights up when you play something.
have you tried in mixer control on non or software.
which clocks do you use 45/49 mhz or 22/24 mhz.

which raspberry pi are you using?

If the LED of XO1 or XO2 clock does not light up after a reboot or shutdown, you could try this.

Hi Michel

Thank you for your quick response!
I am using the Raspberry Pi 4B.

From FifoPiMa guide - Two user replaceable socket mounted clocks (XOs or OCXOs, with/without OE pin) support frequencies 22.5792/24.5760 and 45.1584/49.1520 MHz for both 44.1KHz and 48KHz family di gital music. FifoPiMa also works with SinePi to use external high quality sine clocks.

The lights that are on (in the Fifo) are:
-D2 power of course
-D3 I2S format input

  • D8 I2S format output
  • D1 Lit to indicate FifoPiMa is playing music Off when music is stopped or mute

By the way, I don’t know codeing, so hope the solutions don’t require that. Certainly with some help I will.

Pics of Volumio setup -

I have tried many iterations of the Volume without success.

Thank you!

Pic of my setup.

Okay then at least you have an input signal.
but I mean is one of the LEDs XO1 or XO2 on while playing?
Have you tried audio resampling, for example 16 bit/96 khz etc etc
Scherm­afbeelding 2024-02-08 om 13.40.59

No, neither of those lights are on.

I just tried it with Moode and one light did turn on. Is only one supposed to turn on at a time, or are they both supposed to turn on?

then you have the same problem as I had, this is due to the update software for the raspberry pi 5
{secondly, the “slave” parameter was added to fix the problem with I2S DACs worning in master mode on the Pi5}

then there is no other option than to change the parameter dtoverlay=hifiberry-dacplus,slave to dtoverlay=hifiberry-dacplus

I have never edited code. Can you guide me? Seems simple. But how do I get to the editor?

and also, are both clock lights supposed to be on or just one?

Just one at playing.

I am currently working on other things, but you can also adjust that line by inserting the SD card into the PC and adjusting (text file editor) the userconfig.txt file there.

Is this it?

@jnovo yes it’s pretty simple, just connect the SD-card yo your PC and edit the file userconfig.txt

one remark, please do not use notepad for changing the file, it will change the format from linux to windows, and you might have problems.
please use notepad++, you can download it for free from this link

open the file userconfig.txt with notepad++, remove all the content and add this line only:


then save and close the program

if you already changed the file with notepad, you need an additional step, to restore the linux format:

Edit → EOL Conversion → Unix (LF)

then press save and close the program


After putting back the SD in your RPi, you should be good to go

is indeed the simplest way, notepad++.
you can also remote via ssh.
first enable ssh

open a terminal or use putty and log in ssh volumio@ipadres-your-pi, password is volumio.
you can use fing to find out the IP address of the raspberry pi.

Scherm­afbeelding 2024-02-08 om 20.08.32

then type sudo nano /boot/userconfig.txt and you will then go to the same folder to adjust everything there.
Scherm­afbeelding 2024-02-08 om 20.08.45

Scherm­afbeelding 2024-02-08 om 20.09.04

type Ctrl x and Y yes to save and then type sudo reboot, your volumio device will restart with the correct data .

I had edited the file in windows notepad, so I went back and followed the procedures Darmur suggested. No luck. I then re-flashed the card. When I set it all up, I got sound! I proceeded to install plugins and when I returned to listen, nothing. I then factory reset and reconfigured without plugins. Nothing.
I then followed Darmu’s suggestion using notepad ++. Nothing

could you please post a screenshot of the content of userconfig.txt and config.txt?

@Darmur once things have gone wrong a factory reset doesn’t help, i have tried this.

I did this, flashed a new image, setup the dac in the interface, ssh into volumio and adjusted the userconfig.txt file and rebooted.

It is important whether the LED XO1 or XO2 turns on during playback.

note! During the first boot (setup) everything works normally (no changes in the userconfig.txt) but after a reboot or shutdown there is no sound anymore.
you think everything works fine until you reboot or shutdown.

please try to remove what is in the red rectangle, save and try again

success of sorts. I now get sound. I rebooted several times, no problem. However, one channel is not working. Could that be related to what we did in the config?
I will set up Moode to see if I have the 2nd channel issue.