New 2023 Spotify Plugin

No, working fine for me.

Raspberry Pi4 b 2gb ram
St400 Dac hat (pcm5122)
Latest prototype volumio image
Waveshare 7 inch from https://www.waveshare.com/wiki/7inch_HDMI_LCD_(B) and use parameters.

Initial tests:
After install spotify plugin, restart then enable spotify plugin and log in account.
After, browse a song from spotify after clicking it seems not loading a content on a screen please see the video : touch display .mp4 - Google Drive

please read carefully what I wrote.

posting a video is USELESS to understand your problem

please post a system log

Replying to my own thread here. I sent in a log but here’s the error I’m getting when trying to load playlists:

info: CoreCommandRouter::executeOnPlugin: spop , handleBrowseUri
info: In handleBrowseUri, curUri=spotify/playlists
(node:910) UnhandledPromiseRejectionWarning: TypeError: Cannot read property ‘length’ of null
at ControllerSpotify._getAlbumArt (/data/plugins/music_service/spop/index.js:1078:54)
at /data/plugins/music_service/spop/index.js:1411:44
at runMicrotasks ()
at processTicksAndRejections (internal/process/task_queues.js:93:5)
(node:910) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag --unhandled-rejections=strict (see Command-line API | Node.js v21.7.2 Documentation). (rejection id: 5)

Rpi 4
HiFiBerry DAC+ light
system version 3.631

Hi everyone, I set up a volumio a couple of years ago with a cheap jaycar DAC. It was completely unusable, I worked my way through all DACs in the list at least four times. there was a couple of DAC selections that would work every 15 or so reboots, needless to say I gave it up as a bad joke. Thoough Spotify at the time worked really well.

I have got my self a HiFiBerry DAC now as the one in my car works great. anyway it is actually working! I have a question about SPOTIFY Plugin, it seems this new version wants your phone to login and push music from the phone to the rasberry pi. Am I understanding this correctly?

There are 2 ways to control Spotify:

  • From the Spotify app on your phone (or other device) using Spotify connect (built into the Spotify Plugin). Choose the output device from the Spotify App
  • OR from Volumio you can browse Spotify from the main browse page (http://volumio/browse)

It is a little unstable yet as they are working on a new daemon. I have to start with the app and then browse sometimes.

HTH

Is there any update on the updated daemon version? Do you need beta testers?

Hi, are there any news to the queue issue?

thanks Glenn, Ill give it a try

Yes just came here to see if anyone else is having this issue. Spotify plugin 4.04 , volumio 3.6.37 very similar hardware to asktheightball.

Exactly the same error log.

Hi,

I’ll ask again, I do not fully understand how the plugin is built in order to see whether i could contribute. I’ve found the spotify plugin repo I believe at volumio-plugins-sources/spotify at master · volumio/volumio-plugins-sources · GitHub

However most of this seems to use vollibrepot or something? Where’s that located? Is there some manual to get started?

The plugin has been quite annoying for half a year now. There’s no sign of proper fixes. I know I can’t complain too much, but not seeing improvements is frustrating. Especially since Balbuzes original plugin was awesome, this really is a step back. Personally, I do not understand why you’re focusing so much on the interface anyway. As Spotify does that already for us. We only really need a proper Spotify connect implementation…

2 Likes

Hi Folks,

I´d like the volumio player on my raspi very much and mostly I listen to Spotify.
Last time I`ve got much problems playing album, because the playback stops after one song.
If I klick the next song in my phone, volumio is not connected anymore and I have to reconnect.
I’ve got another raspi with raspotify which plays all album without any problem.

What could be the problem?

1 Like

Please use this thread for all things Spotify.

Many thanks for the information.
That fix my problem :grinning:

But only for one day! Three day later I try to connect, but wasn`t working. Spotify shows volumio and waiting for connection. So I need to switch back to my raspotify. :slightly_frowning_face:

Could be your wifi. Can you connect your Pi to wired ethernet?

That was the first I tested with webradio. Courious after I listen over my raspotfiy, I can also listen with the volumio again! :thinking:

There is an issue, described above, that if you play a track via Spotify (Connect) and then, when it’s still playing, select a source via the Volumio UI (for example web radio, or local storage), it will become non-responsive. The way around it is to first press pause before switching. This works 100% of the time for me.

Or vice versa

Just updated to the new Volumio version 3.649 in the hope that something might make this plug-in behave. Stupid move. Now it doesn’t connect at all from mobile/PC. Losing patience with Volumio as a solution.

Log: http://logs.volumio.org/volumio/DcDpSCv.html