Networking issues

I started using Volumio yesterday. Right at the start i ran into some weird networking issues. The issues i am experiencing are very similar to this topic:

However that issue was automagically solved by itself.

At very first boot volumio did not get a IP (it seemed) despite being plugged in to a ethernet switch. I did see the hotspot so i connected to that and went through first initial setup. I then connected to WLAN but ethernet was still not working.

Later on when i started using it i noticed in my router the DHCP server leased 2 IP’s to volumio. So at that point ethernet was somehow working.

Since then i had to reboot (replace RCA cables and moved the pi) and the same thing happened again. But now i have WLAN completely switched off and the pi is not getting a IP despite a IP being reserved for it in the DHCP server.

The solution at the moment is to connect a screen and keyboard login and manually refresh the eth0 interface using ifup/down commands etc.

This works after i do this i can ping other machines on the network.

I’d still like to dig deeper as to what is causing this. My laptop (arch linux manjaro) gets a IP without a issue when plugged into the same ethernet port on the switch.

My network is a bit a typical but i’ll try to describe it:
Edge router 4
VLAN 20 for IoT—>DHCP server for VLAN 20
Distributed over 2 switches. The Pi 4 is plugged into the second switch.

Normal equipment runs on another vlan and firewall rules prevent vlan 20 from talking to the “trusted vlan” if it’s not initiated by the trusted vlan. But DHCP is not an issues for any other device.

Pointers in the right direction would be much appreciated.