Lost Music locations

I have just updated Volumio to 2.452 using the soft switch in Volumio and it now no longer ‘sees’ the NAS drives that contain my mp3s and flacs. It reports them as unmounted and trying to reconnect them brings up an error, too briefly to read, and they stay unmounted.
I have now deleted them and tried re-scanning, but V’ finds no network drives ??

I am using Win10 and using PIs IP address in a browser to set it up. Connection to it this way is not a problem.

It seems that my PI/Volumio setup has lost its knowledge of the network it is in, but everything on the network page is as before and correct so I don’t know how to put it right, can someone help please?

Can’t you manually add them?

Thanks for the reply.
How do you mean ‘manually’. I am using the Scan switch in Volumio and it does not find anything.


OK, still no progress despite several checks for correct network connection etc.
I have tried a manually setting but still the same result. Please see the attachment.

All this is very puzzling as until the update everything connected fine!

Are the previous versions of Volumio available to download? I think I will try winding back.

I wonder if there has been an update of your NAS software?

  1. Double check that the actual path to the files is /MP3s
  2. Check that you have enabled access of your NAS to the IP address/range of your RPi.
  3. If you can ssh into your RPi, would you mind checking the export list of your NAS?
sudo showmount -e

P.S. You don’t need username and password when using NFS mounts (you enable access by a device on the NAS itself). What was the last stable version of Volumio that you used?

The NAS always seems to be updating its software, usually for security reasons. It is a Synology DS218+
The Path I typed was just MP3s, the / was added by V’ ??
I not aware of a IP range limit setting in my NAS. I have had a look around it but not found anything.
Not very practised at the code level for RPi but using PuTTY I tried your command and it errored as below.

I didn’t think I needed user and pwd but I have been trying everything !

Firstly, my Synology NAS share name is not immediately obvious … it is shown as “Music” in the shared folder, but is actually “/Volume1/Music” … which is why I asked for the double-check.

Secondly, for NFS permissions look under ‘Control Panel’, ‘Shared Folder’, click on the Edit tab and “NFS Permissions” … see screen shot below.
So in my case, I am allowing all devices on 192.168.2.* to access the NFS share … yours would be 192.168.0.* or the exact RPi adress if you have it fixed.

Thirdly, would you mind running ‘sudo systemctl status rpcbind’ on your RPi, and posting the result here.

Thanks for your continuing help.
My Music folder name is just the same, so I will try /Volume1/Music.
Following your post I have added PI’s specific IP in the NFS permissions section.

Tried manually adding again, no change, failed. I wish the error popup stayed longer for me to read it!

Hope that means something to you!

There’s something really odd here. Please try ‘rpcinfo -p’


Managed to screen capture the error popup, does this help at all ?

The response to the rpcinfo command was:

That message confirms that the share is not mounted … we don’t know yet the reason why.

Have you set the NFS permissions as suggested? You say that on your NAS the shared folder is the same as mine …“Music” … so where did the “MP3s” come from? Did it also fail to mount “/volume1/Music”? (Your error message shown is with the “MP3s” name").

You can try to manually mount the drive from ssh, which may give more information.

sudo mount -v -t nfs /mnt/NAS/MP3s

P.S. Remove the “vers=1.0” from the options in the UI.

Edit: something really silly occurs to me … you have got NFS file sharing enabled haven’t you

A little more information: I have two NASs on my network they have identical copies of my music files, as MP3s and some Flacs. I have confused the two in my answers to you.
So to recap.
Both were mounted before updating Volumio.
Both became unmounted after. I Scanned when I saw this and V’ did find them and allowed selection but still did not mount them. It has failed to find anything on subsequent scans.
I then deleted them and tried manually mounting them and that is where I am today.
NAS 1 is Buffalo Linkstation LS-WVLE25 on with folders MP3s and Flacs
NAS 2 is my Synology NAS on with folder Music and 2 subfolders MP3s and Flacs

Yes I did set NFS as you suggested.
I tried sudo rpcinfo and it returned this list.

for the LS on 0.250 the response was negative.

Thanks again for your help, I am sorry I have confused the situation.

OK, one at a time. Since the Synology at is running an NFS server (as shown by rpcinfo), please run ‘sudo showmount -e’ and post the result.

Note that if the path to the share is indeed ‘/volume1/Music/MP3s’, you should be using a lowercase ‘v’ Also, you are suddenly using cifs and not nfs. Can you please spell out EXACTLY what you are trying to add to the UI, and be consistent.

Do you mean you added the correct permissions, or you enabled NFS sharing, or both? Remember, just the Synology NAS for now to avoid confusion.

Thanks for bearing with this and me! OK just the Synology NAS for now.

So lower case v reported. Tried altering to Capital V, different error but still not mounted.
showmount still reports it as lower case v ??

Volumio sets cfs as default and if tried once and then altering to nfs and saving, it still errors but the UI goes back to showing default cfs. I am trying to use nfs.
Deleting the mount setting and starting again with nfs retains that in the UI, but still not mounting, see screenshot.

And getting there finally :slight_smile: Your share path is ‘/volume1/Music’… this is what showmount is showing you. So simply set the correct path (with lowercase ‘v’) and you should be good to go on at least that NAS.

For the other NAS, I’m not convinced that a NFS server is running. Can you look at it’s on line documentation as to how to set it up? If you can ssh into the NAS, you could look at the contents of ‘/etc/exports’ which should show the same kind of information as ‘showmount -e’ did on the Synology ie. what shares are being made available.

YES !!!
Mounted both the MP3 and Flac subfolders successfully. It is strange that the previous version of V’ mounted them without the ‘volume1’.

Tried the showmount command with and came up with the error.

Could that be a permissions. It doesn’t seem to have such complicated settings.

I can’t see any mention of NFS there … are you sure that it supports it? Do you have a link to an online manual?

If it doesn’t then you’ll have to use cifs.