IQaudiO Pi Digi+

Amusing fiddling find…

The AlloDigiOne driver gives optical audio (its a Coax S/PDIF board)

However the timing is different. The audio is approximatly 1.5times faster. Everything I play sounds like some enthusiastic, but talented chipmunks are giving it ago! :joy: :rofl:

Still not made an real progress though.

I am curious how this will sound in your case:


This is screen from older version. AMP type is different no work.

credit to those that have assisted in this thread above. Thank you! I’ve basically just worked my way through a few options and tried to remember my was around Linux

Ah HA!
I have a work around, which is surprisingly simple, yet slightly different to what I have tried before. My last attempt stopped the Playback options page from loading, it was just blank. No idea how I did that.

So From my umpteenth fresh install I have…

1)Enable SSH via volumio.local/dev
Im assuming you know how to SSH into your Pi.

2)edit dacs.json

Location /volumio/app/plugins/system_controller/i2s_dacs/dacs.json

Use nano to edit the file.
Find the line for iqaudio-digiplus and add this like the other IQaudiO lines.


The modified lineshould look like this.

{“id”:“iqaudio-digiplus”,“name”:“IQaudIO Pi-Digi+”,“overlay”:“iqaudio-digi-wm8804-audio”,“alsanum”:“2”,“alsacard”:“IQaudIODAC”,“mixer”:"",“modules”:"",“script”:"",“needsreboot”:“yes”},

open /boot/config.txt and make the following change:

from: dtparam=audio=on
to: #dtparam=audio=on

Hash out your existing dtoverlay and add the correct one for the Digi+ with the wm8804

hash: #dtoverlay=iqaudio-dacplus
add: dtoverlay=iqaudio-digi-wm8804-audio

  1. Execute the following commands:

sudo reboot

My Pi 2 then failed to reboot. So I had to pull the plug .



Mine looks like this.

volumio@pifi:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: IQAudIODigi [IQAudIODigi], device 0: IQAudIO Digi HiFi wm8804-spdif-0 [IQAudIO Digi HiFi wm8804-spdif-0]
Subdevices: 0/1
Subdevice #0: subdevice #0

IQaudio Digi is now listed as a device! Woo! :grinning:

Downside is from the web interface, when selected from the dropdown list it still fails to play :pensive:

However, I tried to go back to the headphone output, and the only option listed now is the IQaudio Digi+

Which plays! Hooray! :smiley:

So. for now Im a happy chap. Full digital to my Amp with then does the hard part. Fab :+1: And its only ever so slightly different from all the combinations I have tried before. Typical!

Hopefully, this will ring some alarm bells for the Devs, as it feels to me like an easy fix/minor glitch in the code.

So for now, I hope this is a temporary fix for others.

Pity you did not read the whole thread, I posted this here: IQaudiO Pi Digi+ - #10 by gkkpch

I did thank you. That’s how I knew what to put!

But that alone has only made it appear in the drop down list. It still fails to play at that point. With the “no such player” error. Which I think I have posted afterwards in the thread :wink:

Hi All,
me too had problems with non-working Iqaudio card. Well, as of the latest update, this is resolved. I just updated from latest V2 to V3, it recognized card automagically, and everything works.

1 Like


I’m on a fresh install of 3.233
Unfortunatly for myself, I don’t have success.

On first boot, the card is not visible in the list. So as suggested above, I have modified the dacs.json which gets it to appear. And then modified the config.txt

Selecting it in the I2s list it still fails to play.
Selecting it where the headphones would be, and it works a treat.

Still baffled, as I guess there are two small problems.
1st the dacs.json
2nd a typo somewhere.

Whats the difference between it being called in the dropdown list, vs being called instead of the headphones output?

@brm9999 Are you on this version with the IQaudio Pi Digi+ ? It didn’t show in my dropdown list. :confused:

Ok, for me it was actually much simpler. I made a fresh Volumio install with last V2 version. Then I made all audio setting, NAS settings etc. Checked if everything worked, and then just upgraded to the latest 3.233 version, without any other modification. Since that, everything works fine.

1 Like

Thanks @brm9999

I have got a working V3.251 now

Volumio 3.251

Bit weird though, as the IQAudio Digi+ is appearing like this, rather than as an i2s DAC. Im guessing the Devs have done a temporary work around? As it looks similar to the workaround (above), except this time I haven’t been fiddling.

For the record…
-Formatted another Card
-Installed V2.348
-Tested working System
-Upgraded to V3.251
-Tested System
-Played Music :smiley:

Anyway, It got it working without me fiddling in terminal, which is great :slight_smile:

See how the next update goes…

1 Like

It work…
Thank U

Hi, Does anyone have an updated/current solution for this issue. I have updated my Volumio installation today by burning the latest version onto an SD card. Like others, my IQAudio Pi-Digi+ is no longer listed and I then get the alsa error message. All worked fine previously connecting Volumio via TosLink into my audio system. Any help would really be appreciated. Thanks, Martin

IQAudio Digi+ is not in the list because the alsacard parameter is missing in the dacs.json file

I will fix this, but it will be included in the next stable release.

As a temporary solution, you can select Hifiberry Digi+, it should work without problems

Hi, Thanks for the reply but sadly neither of those Hifiberry options works for some reason. Should I attempt a modification of the dacs.json file via ssh? I do have some familiarity with modifying files on a Pi. Regards, Martin

I have successfully modified the dacs.json file and things seem to be back to normal. Thanks to you gentlemen for your help. It is appreciated. Martin

1 Like

Just in case it helps someone, my solution after a bit of faffing.

Trying to go from a working v2.x with the ALSA audio working with the IQAudio Digi+ and upgrading OTA by resizing the boot partiiton, I ran in to the same issue resizing the FAT32 partition as I was using GParted on Mint.

I tried a GParted Live USB on YUMI too, it gave the same error.

So, Booted Volumio and configured it, selecting the IQAudio Digi+.

Then resized the EXT4 partitions using GParted on Mint, and moved to the right.

Put the SD Card in a windows PC and used an open source partition manager to resize the FAT32 partition to fill the unallocated space.

All working with IQAudio Digi+ on v3 now.

Thank you!

Having ignored a few updates to my system, I have finally got around to a fresh install.

3.611 Installed and playing, out of the box.

(or fresh off the Card :slight_smile: )

1 Like