IQaudiO Pi Digi+


my soundcard IQaudiO Pi Digi+ missing in I2C card list.
Is it only temporally problem or you do not want to put this soundcard to this list. I don want to buy another brand.
BTW : similar Hifiberry Digi2 pro is there.
Thank you for your answers

1 Like

It is present in my 3.x installation.

Thank you

Hi, still missing

Where do you miss it? It should be present in Volumio 3.x after a clean install on your Pi. If you miss it in a Raspbian distro you might want to refer to the IQ Audio manual


I also have the problem of Missing IQAudio Digi+ Card on Volumio 3

I have been trying to fix this problem myself with so far no success.
I have found the dacs.json file in the file system and to my eyes it looks the same as in the Documentation/ other forum post about testing DACs for inclusion. (Small typo/ missng peramiter?)

So from my simple view it looks like it should work but is missing from the I2s dropdown list.

There ae several versions online for the Digi+ manual
Version 30 Includes the Digi+ Later versions do not.
I have followed the instructions, but I have either Bricked the system, or failed to work. Not entirely sure why.

I note that a HifiBerry Digi card also with the wm8804 chipset is also causing problems. Maybe the two are linked?



PS I couldnt find this post searching easily for iqaudio or IQaudio or IQaudiO. Baffled.

Very strange, it is present in my V3 drop-down list. Dropbox - IMG_6237.jpg - Simplify your life

There should be 3 IQaudio items in the drop down list. According to the dacs.json file
One of which is the Digi+ which uses a different chipset to the other two. It provides a Toslink (which I use) and Coax output.

I seem to have bricked my system & corrupted my SD card now with my fiddling :confused:

I had a fresh look just before it failed between th system dacs.json the Documentation & V3 beta test help Post. I may have spotted a difference. And then It went wrong…

Fresh head needed!

Fresh system take 4.


Two IQaudio dacs shown, neither of which are for the PI-Digi+

Checked the dacs.json file in the system & documentation

System File

 {"id":"iqaudio-dacplus","name":"IQaudIO DAC Plus","overlay":"iqaudio-dacplus,unmute_amp ","alsanum":"2","alsacard":"IQaudIODAC","mixer":"Digital","modules":"","script":"$
 {"id":"iqaudio-digiplus","name":"IQaudIO Pi-Digi+","overlay":"iqaudio-digi-wm8804-audio","alsanum":"2","mixer":"","modules":"","script":"","needsreboot":"yes"},
 {"id":"iqaudio-amp","name":"IQaudIO Pi-DigiAMP+","overlay":"iqaudio-dacplus,unmute_amp ","alsanum":"2","alsacard":"IQaudIODAC","mixer":"Digital","modules":"","script":""$

{"id":"iqaudio-dacplus","name":"IQaudIO DAC Plus","overlay":"iqaudio-dacplus,unmute_amp ","alsanum":"2","mixer":"Digital","modules":"","script":"","i2c_address":"4c","needsreboot":"no"},
{"id":"iqaudio-digiplus","name":"IQaudIO Pi-Digi+","overlay":"iqaudio-digi-wm8804-audio","alsanum":"2","mixer":"","modules":"","script":"","needsreboot":"yes"},
{"id":"iqaudio-amp","name":"IQaudIO Pi-DigiAMP+","overlay":"iqaudio-dacplus,unmute_amp ","alsanum":"2","mixer":"Digital","modules":"","script":"","needsreboot":"yes"},

Both of which clearly show the IQaudio Pi-Digi+ as well as the other two. Baffled. And the differences I spotted last night were for the other two DACs, which are showing in the system. More baffled. I was hoping to spot a silly typo etc.

I think I have run out of ability/understanding to progress further. I guess I should fire up a volume 2 install and have a look there next.

Help & suggestions welcome please!

The “iqaudio-digi-wm8804-audio” is missing the “alsacard” setting, that is why it will not be listed.
The alsacard value should be “IQaudIODAC”, identical to the other two.
Like this:

{"id":"iqaudio-digiplus","name":"IQaudIO Pi-Digi+","overlay":"iqaudio-digi-wm8804-audio","alsanum":"2","alsacard":"IQaudIODAC","mixer":"","modules":"","script":"","needsreboot":"yes"},

That won’t help you much :wink:
With V3 all card entries in dacs.json must have an “alsacard” setting.

Thanks gkkpch.

I now have the IQaudio Pi-Digi+ shown in the drop down menu. :+1:

Sadly, it still doesnt work. :face_with_raised_eyebrow: I now get an error

ALSA failed to open “volumio”; no such device.

More to investigate.

Whilst fiddling I noticed that the ST400 DAC Also calls the IQAudio Digi+ Information, so I tried that, and sadly that also fails with the same error (which may be expected but I thought I would try)

And I had just finished writing V2 SD card when I read this. Great timing :slight_smile:

Did you reboot?


I made the changes.
Reboot system.
Selected IQaudio Pi Digi+
System Reboots
Tried & failed
Checked my changes & rebooted again
Still fail
Select headphones audio works
Reselect Iqaudio
Still fail
Reboot again
Still fail

It has just occurred to me that my system also has a Pico UPS HAT on it. It hasn’t caused problems with V2. But I have not tried to physically remove it yet either, in case there is a conflict of some kind in V 3

I have a similar problem and would love a proper solution.

But I found that selecting R-PI DAC at least seemed to allow ALSA to playback audio - but not sure if this is the best option.


After a interlude with far too much food, I’m back to fiddling.

Happy new year folks!

I have disconnected the UPS board, so I now just have a Pi & IQaudiO Digi+ board.
Sadly the same ALSA No Volumio device fault.
Log file >

Quite a few errors in the log file. I can spot some of the symptoms, but not sure about much of the causes, as I don’t understand enough. Ill carry on digging though.

Any hints very welcome!


just some thoughts:
open /boot/config.txt and make the following change:

from: dtparam=audio=on 
to:   #dtparam=audio=on

if the line dtoverlay exist in /boot/config.txt, disable it:

from: dtoverlay=iqaudio-digi-wm8804-audio
to:   #dtoverlay=iqaudio-digi-wm8804-audio

open /boot/userconfig.txt
add: dtoverlay=iqaudio-digi-wm8804-audio

Execute the following commands:

sudo reboot

after reboot type the following in the terminal (don’t configure anything in Volumio yet)
aplay -l

Is the soundcard listed?

Yes. I don’t think it has been in the past.

**** List of PLAYBACK Hardware Devices ****
card 0: IQAudIODigi [IQAudIODigi], device 0: IQAudIO Digi HiFi wm8804-spdif-0 [I QAudIO Digi HiFi wm8804-spdif-0]
Subdevices: 1/1
Subdevice #0: subdevice #0

I have tried similar to your suggestions previously, but that was before I modified the dacs.json file & bricked the system again. I want keeping good enough track of the trial and error clearly.

Unfortunalty still having the failed to open alsa no such device error still. :frowning:

Sorry to hear. Since I don’t have this hardware I have no other suggestions.