iOS app - does not find any devices

The iOS application after the latest release does not find any devices. The spinner is spinning infinitely and the message “Looking for devices” is shown. The button “Configure a new device” allows me to choose “WiFi” or “Wired” but when I choose “WiFi” (as my device is connected to WiFi) then I got the message “We could not find a wireless device”.
I tried a few times, even reinstalled the app - with no success. This release make the application unusable for me.

Hi @maga ,

Is your phone in the same network subnet as the volumio devices? Or did you make any other changes on your router, for example did you disable mDNS? Please let me know so we can look for a solution.

1 Like

Signed up just to add to the list. I’m having the same issue as well. Works fine from my laptop but my IOS app doesn’t work after the update. Hopefully this gets resolved soon.

and just to add. It’s not that the phone is on a different IP subnet. I’m able to access Volumio using a browser but it’s not usable whatsoever using a mobile browser. The app is the issue.

FWIW, I am using the latest version (1.4.1) without experiencing this issue. There may still be a bug in the app but if so it may only be apparent under specific circumstances. It would probably help to provide us with more information.

p.s. I don’t remember ever being asked whether a device was wired or wireless

That could very well be the case but my app worked fine for years but is now broken after the update. Same issue as the others in this thread reported. I even see reviews in the app store stating the same problem. What information do you need? I’m running IOS version 15.5 on an iPhone 8 plus. I’m glad it’s working for you.

I’ll try updating my IOS to 15.6.1 and see if it helps.

update: upgrade to iOS 15.6.1 did not resolve the issue. mDNS is working, otherwise devices (iPhone incuded) on my network would not be able to resolve *.local without issue.

Could you tell us which version of Volumio OS you are using and which version of the iOS app?

1 Like

I’m running Volumio for iOS v1.4.1, iOS 15.6.1 (previously running 15.5). I can resolve volumio.local from safari on my iPhone without issues.

My Volumio device is running v2.587

1 Like

So i took a leap of faith and updated my device to Volumio 3 using OTA. Surprisingly, the update worked with the exception of losing all my setting which thankfully is pretty bare bones. I did use the backup plugin to backup my playlists but i dont see the plugin available in the list of plugins. Is there a way to manually restore my playlists using scp or something of the sort?

Oh, i forgot. This fixed the problem with the iOS app ‘searching for device’.

edit: all good. Got my playlists copied over using scp

1 Like

It seems that the new app has some compatability issues with volumio 2. We are investigating the issue.

Hi, I’d like to add that problem is the same with Android. Also, when the android volumio app is looking for device without success with the spinner spinning endlessly, if at the same time a web browser is opened on a PC to access Volumio, then all of a sudden the Android app shows the device. Hope it helps.


Exactly the same here (android)

This issue has persisted on Android for quite some time. I have a Primo device with Volumio latest build. Official app for android version 1.2. Device not found on the network repeatedly. The unofficial app for android works without any problems. Entering the IP address in the browser also works without problems. I’ve created a link to my desktop and they connect to Primo this way. At least this works.

It would be good if someone with volumio could comment on this.

Thank you.


The problem is still there. Here is more details that could help sorting it:

If the last used music source on the Volumio device was anything save a radio, the Volumio android app find the Volumio device just fine.

If the last used music source on the Volumio device was a radio, the Volumio android app doesn’t find the Volumio device.

Hope it helps

I have this issue as well. It would sure be nice if, after the “Looking for devices” spins for some period of time we could just enter some ip addresses manually or something.

MDNS is operational on the subnet I am using and the iOS app was given access to search the local network at initial launch. I have rebooted the Volumio device and still cannot locate its MDNS service using my computer’s network scanner. The scanner does locate multiple other client instances associated with the airplay service. And yet somehow the iOS device can airplay to it even while the Volumio app on the same device never finds any devices.

After changing the volumio device’s system name a couple of times, eventually a service did show up in my mdns browser under _Volumeio._tcp. at voluio.local.

But the iOS app still spins the Looking for devices screen forever.

We identified the issue and an update is on its way.

I bought my miniDSP streaming DAC yesterday. I tried to connect to WLAN with an Ethernet cable. I had exactly same screen like your case, attempted to connect by WIFI , no chance to. After testing all cables, etc I reslize by reading on the platform that I am not the only one, facing difficulty or impossibility to connect my system to internet.
Is it related with IPhone, new IOs version, ?
Is the problem still persists?
Thank you in advance

Both iOS and Android apps have been released with the fix for this issue.

Please let us know if that’s not the case with you


unfortunately the latest version doesn’t fix the issue for me on iOS 16.1.1 with iPhone 13. I am also on the latest Volumio RPi version - just updated it. I’ve enabled the App privacy logs in iOS and can see that the app scans the whole range, but not the which is my network. Volumio is accessible from the browser on volumio-wz.local and by IP from every device on the home network. I saw someone mentioning permissions for scanning the network, but can’t find any privacy settings for Volumio app.