Intel Apollo Lake / Braswell chipset for Volumio x86

Hi everyone,

I have a nice mini-ITX case, so-dimm ram, SSD etc, so I would buy an ITX Celeron motherboard to fit in and run Volumio x86.
Can you tell me if I will have problems with Asrock motherboards based on Intel Apollo Lake or older Braswell?
I mean, kernel compatibility and so on.
Thanks in advance

Inviato dal mio HTC One utilizzando Tapatalk

Hi guys,

anyone knows if these two architectures are compatible with Volumio x86 (with Debian kernel used by Volumio) ?
They run with Intel Celeron processors (J3710, J3355, J3455…), Apollo Lake is newer, Braswell is a little older but not
so much. These Celeron on little ITX motherboards are passively cooled, so fanless and silent (J3710 TDP is 6.5W).

I only need motherboard, I have everything else, but I’m not sure if Volumio can have problems with these relatively
new platforms.

I also have a brand new Intel NUC (NUC7i3BNH) and Volumio (the Debian kernel) does not recognize the ethernet
chipset and so it is unusable for me, unfortunately.

Thanks in advance, regards,

Hi guys,
Ok it’s summertime… :slight_smile:
But I can’t believe nobody knows if these architectures are compatible with Volumio! I would really like to enjoy the x86 version. Michelangelo? Debian kernel of Volumio works with these platforms?

Thanks in advance

Inviato dal mio HTC One utilizzando Tapatalk

Hi Michele79,

i just get the board and i can tell you tomorrow more :wink:

Wow! A direct experience is the best! Thank you very much Judydudi, really appreciated, waiting for your response :slight_smile:


Inviato dal mio HTC One utilizzando Tapatalk

Hi Michele,

i can say volumio run’s out of the box :wink:
preparing a flash medium with actual volumio image - plug at USB
(F11 for boot menu. Boot from USB)
volumio starts. Than select USB:audio
that’s it.
(just fresh, no long time experience)


additional info:
power consumption of my system with USB wlan dongle, 8GB, 120 SSD, USB Flash Card, USB Stick, USB Dac and ipurifier2 is now 16 Watt…

Really nice little PC! What is the total cost of your configuration?? (made me wanna try it :smiley: )

110€ the mainboard with a j3710 intel 6,5W TDP, SPDIF, ELNA Audio Caps etc.
70€ Aluminium Case incl. 60Watt PSU … :2764.html
60€ 2x4GB Kingston KVR16LS11/4 SO-DDR 3L RAM
8€ Wlan Dongle
= 248€ (+USB Stick or SSD HD)

Hi guys,

thanks judydudi for the fast reply and confermation! Really appreciated!
So…Volumio x86 runs ok upon a Braswell platform (Q1 2016 TDP 6,5W).
I wonder now if it can run also on the newer Apollo Lake…but I think I’ll buy the same
motherboard as you, and be happy with that!
Michelangelo, can you tell me please the MPD version that runs on Volumio? I know
that’s a custom version, but the one on which it is based?

judydudi, take a look on the attached picture, we have the same mini-ITX case! :smiley:


It’s mpd 0.20.6-1

Hi GĂ©,
Thanks, really appreciated.
Now, I have for sure a problem related to a bug in this version of MPD. Should I start a new thread? Better right? :slight_smile:

Inviato dal mio HTC One utilizzando Tapatalk

Yes please, even better open an issue on github

Thanks Michelangelo, done!

Inviato dal mio HTC One utilizzando Tapatalk

I have a J4205-ITX board, base on Apollo Lake, HD graphics 505, and have probleme to run Volumio. Boot is very slow. USB key is working well on other PC, but not on J4205. I have also sometime issue with Daphile for exemple, slow boot but finally works on USB key or HD. But not Volumio. I try to use unetbootin, USBwriter, Rufus… , to boot in UEFI or standard, still with no succes. I have one previous version that was finally working (I do’nt remember which one), but no more with 2.201 or 2.164.
Current version of Ubuntu works well on J4205.
Driver issue? Graphic?

Are you getting anything at all, like the grub menu?

I have found that bios update was available on Asrock site. I update my J4205-ITX with 1.30 bios. I check again to boot with Volumio 2.201. This time, after waiting long time, Volumio was almost running. But UI was still very slow. It was better to use html interface on another PC or use MPD client. And many interruption during audio playback. I reboot this system and issue is coming back. Boot start but, after displaying VOLUMIO, I get some more trace messages, but stop on a line refering to tty…

could you perhaps make a picture of the screen and post it?

@judydudi and @Michele79 i have the same case myself :laughing: :laughing:
and the same concept in mind… It really does look good and fits nicely with the rest of the audio gear

Maybe the new offer from volumio
is the perfect solution for x86, as it should work right out of the box

@AudioMGR i also have the same board as you. Got it to as a small desktop and to test things like this. I am now checking if i can run volumio on it.
Though I am away from my main setup and can’t test everything. But i will report back my experience. Running v1.3 of the bios for J4205

Alright so Volumio 2.201 was installed on the following system:
AsRock j4205 with 8GB of Ram (overkill i know) and its running on a 64GB Sandisk extreme usb3.0 drive.

The system is painfully slow and sluggish to respond. Tried to play some FLAC files from another usb stick i had lying around (as mentioned away from my main system so can’t really test mounting NAS drives). Listening through on-board audio device (recognized as Intel in the menu). The music would have so many stops and hiccups it was not possible to listen to. Played some mp3’s as well just to test if file size was an issue. Nothing changed.
Overall the whole experience is extremely slow, even more sluggish than on an rpi3 with a 10K library loaded

Tried a restart to see what gives. I got to see the progress bar of “Started load kernel modules”, it was loading that slow. Even the startup sound was played with a gap. After reboot the system seems to be even slower than the first boot after install.
I am sure the hardware is fast enough, so this must be a software issue.
Any ideas?