I want install peppy meter on 55 4k tv - I will pay for help in payapl

I know linux
I need good guide

Peppymeter or VOLUMIO with PeppyMeter Screen plug? There is no great philosophy here. You install VOLUMIO, add Peppymeter Screen plugin. You set the resolution to 1920x1080. Done.


I download the plugin
but when I run volume plugin install
he say me :no packet found

1 Like

Write specifically:
What are you installing on - RPi, TBS or something else?
What is “volume plugin”?

The full description of the installation is on page 7:

Download as Plugin

I install and see this:
Processing triggers for systemd (241-7~deb10u8+rpi1) …

Processing triggers for libc-bin (2.28-10+rpt2+rpi1+deb10u1) …

Modify PeppyMeter config for Volumio

~/Install_peppy ~

but I can’t see it in volume plugin

I wrote above:
1.Download as a plugin
2.Unzip on your computer
3. Connect via FTP and create a folder eg Peppy Screen in the \home\volumio folder

  1. Move the contents from your computer to the \home\volumi\PeppyScreen folder
    5.Now connect to volumio via Putty
  2. Go to \home\volumio\PeppyScreen
    volumio plugin install
    Done. Restart volumio

Last step: click on my Avatar and…

I do all steps and get this error

Compressing the plugin
Plugin succesfully compressed
Progress: 10
Status :Downloading plugin
nloading plugin at
Progress: 30
Status :Plugin stopped
var lastMessage = data.advancedLog.substring(data.advancedLog.lastIndexOf(’
’) + 4);

TypeError: Cannot read property ‘substring’ of undefined
at Socket. (/volumio/pluginhelper.js:782:56)
at Socket.Emitter.emit (/volumio/node_modules/socket.io-client/node_modules/component-emitter/index.js:133:20)
at Socket.onevent (/volumio/node_modules/socket.io-client/lib/socket.js:270:10)
at Socket.onpacket (/volumio/node_modules/socket.io-client/lib/socket.js:228:12)
at Manager. (/volumio/node_modules/component-bind/index.js:21:15)
at Manager.Emitter.emit (/volumio/node_modules/socket.io-client/node_modules/component-emitter/index.js:133:20)
at Manager.ondecoded (/volumio/node_modules/socket.io-client/lib/manager.js:332:8)
at Decoder. (/volumio/node_modules/component-bind/index.js:21:15)
at Decoder.Emitter.emit (/volumio/node_modules/component-emitter/index.js:134:20)
at Decoder.add (/volumio/node_modules/socket.io-parser/index.js:246:12)

show what you have in the folder / home / VOLUMIO / PeppyScreen?

total 84
-rw-r–r-- 1 volumio volumio 545 Nov 19 14:05 createConf.js
-rw-r–r-- 1 volumio volumio 369 Nov 19 14:05 README.md
-rw-r–r-- 1 volumio volumio 404 Nov 19 14:05 restoreAsound.js
-rw-r–r-- 1 volumio volumio 8615 Nov 19 14:05 UIConfig.json
-rw-r–r-- 1 volumio volumio 888 Nov 19 14:05 uninstall.sh
-rw-r–r-- 1 volumio volumio 3 Nov 19 14:05 requiredConf.json
-rw-r–r-- 1 volumio volumio 712 Nov 19 14:05 package.json
-rw-r–r-- 1 volumio volumio 13188 Nov 19 14:05 package-lock.json
-rw-r–r-- 1 volumio volumio 7163 Nov 19 14:05 install.sh
-rw-r–r-- 1 volumio volumio 40746 Nov 19 14:05 index.js
-rw-r–r-- 1 volumio volumio 390 Nov 19 14:05 config.json
-rw-r–r-- 1 volumio volumio 1566 Nov 19 14:05 asound.conf.tmpl
-rw-r–r-- 1 volumio volumio 1043 Nov 19 14:05 Peppyalsa.postPeppyalsa.5.conf.tmpl
drwxr-xr-x 2 volumio volumio 1024 Nov 19 14:07 i18n
drwxr-xr-x 2 volumio volumio 1024 Nov 19 14:07 asound
drwxr-xr-x 53 volumio volumio 1024 Nov 19 14:07 node_modules
drwxr-xr-x 9 volumio volumio 1024 Nov 19 14:07 volumio_peppymeter

I run it again
and its stuck on this long time

This command will install the plugin on your device

================================ WARNING ====================================

This plugin is not verified by Volumio. Installing it is UNSAFE and can make your system UNSTABLE!

You are STRONGLY advised not to install plugins manually, better wait they are officially available.


? Do you want to install this plugin anyway? Yes

Compressing the plugin

Plugin succesfully compressed

Progress: 10

Status :Downloading plugin

nloading plugin at


Do you want to install this plugin anyway?

CA: 10 min

what’s mean ca?
wait 10 min?

Yes, circa about ~10-16 min to install all components (Peppy alsa, plugin etc.)

its still in this situation
I am still wait

No, it can’t go on that long. You’re doing something wrong. If I were you, I would reinstall VOLUMIO. Then he uploaded the plug as I wrote above.

ok . I install from scratch
now seem work to install plugin
after its finish I need also touch display plugin?

No, no need, unless your 4k is touchscreen. Once installed, nothing will happen either.

seem its install
I set screen saver for 2 sec
now for test , before connect to tv
can I see it in my pc computer?
I play and didn’t see any vu meter screen

No, monitor only.

ok, I mean I can see because I have iMac . its without montior out
I will check it later
plz give me your PayPal mail