How to run Volumio in a virtual box

As this question keeps popping up some very basic instructions, with very limited support.
If you decide to run Volumio in a VM, you agree to deal with some issues or not fully operational behavior.
This topic is just to show that it is possible.

  • Boot VM with the life CD

  • Select 11 - Shell

  • type lsblk to validate that the basic disc is pointing to /dev/sda

  • type ipconfig to reveal the IP-Address

  • type nc -l -p 1234 > /dev/sda

  • on the computer with linux type: nc -w 3 <ip-address> 1234 < Volumio-3.396-2022-12-04-x86_amd64.img

  • there is no progress bar, so wait until it is finished (you can see disk and network activity on the VM)

  • When finished, shutdown the VM

  • On Virtual box change, General => basic => Type = Linux, Version = Debian 10 Buster (64-bit)

  • Change the network adapter, if you haven’t done it yet. (Settings => Network)

  • Eject the Knoppix live CD

  • Start the VM and configure Volumio.


and exposing usb audio…

I am using the internal soundcard from my laptop, which seem to work fine.
It’s up to the community to play with it :smile:

Would be great if someone shared the vdi file :kissing_smiling_eyes:
I tried following your steps but im still in trouble with the bridged network…
and the install fails on NAT network

A vdi file will not solve your problem, you still need to configure it for your hardware.
Experiment with NAT/Bridge, Network cards, Adapters.
You will find one that works for you.
The hard part you have done.

1 Like

I managed to get the bridged network working.
Install is succesfull but now the vm won’t boot.

It freezes at the :
Booting Volumio Audiophile Music Player, please wait…

Any suggestions ?

Thanks in advance !

Unable to tell, did you fully complete the copy:
nc -w 3 <ip-address> 1234 < Volumio-3.396-2022-12-04-x86_amd64.img

Mmh yeah,
Installed it twice on 2 VMs.
Updated to the latest version of Virtualbox 7
Installed the pack again…
Currently i downgraded VB again to 6.3 with no succes.

1 Like

At least you didn’t follow the instructions. Your image is set to debian, instead of debian 10 buster.

And change your dispaly settings to:

Tought about that so i upgraded to version 7 with the same result.
Ill update to the 7 again for testing.
Installation was made with Linux Mint VM.
Could it be because im running the Volumio VM on a win11 laptop that its jamming ?

1 Like

Please just follow the instructions as given.
I’m running Win11, so that is not a problem.
Not sure if VM to VM will do the trick. You just can boot your laptop with the Knoppix live CD, or
what I did, I used one of the Volumio boxes to do it.
Settings like the wrong distro and Video card is.

1 Like

It finally worked. Thanks for the help !
Turns out my wifi was the problem, connected server and client to eth cable en did all the steps again and no issues…

hello to all. i have succeed to use volumio 3 on VM on ubuntu pc, also on this pc i’m running via VM FreeNAS. everything seems to be ok but sometimes i have a problem with Volumio software
During playing music i loose the music library from Volumio, i have discovered that My Music library from Sources it is empty. I can confirm that isn’t a problem from the NAS serve, because the access from my win10 laptop to this it is ok (alive). which can be the problem ?

Seems that MPD stopped, if not, I can’t give support for this.

sudo systemctl restart mpd
1 Like

ok, this is a moment solution not a long term fix. it is annoying to do this every day.

If it happens daily, add it as a start script.
As shown Volumio can run in a VM, but not supported.

1 Like

I just downloaded and installed Volumio on VirtualBox and when running a netstat I can see there is no webserver running or listening. I cannot access the WebGUI at all?

Any ideas?


Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0 *:ssh                   *:*                     LISTEN
tcp        0    272      ESTABLISHED
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN
tcp6       0      0 [::]:6600               [::]:*                  LISTEN
udp        0      0 *:bootpc                *:*
udp        0      0       *:*
udp        0      0 localhost:ntp           *:*
udp        0      0 *:ntp                   *:*
udp        0      0 *:28572                 *:*
udp6       0      0 fe80::a00:27ff:fe88:ntp [::]:*
udp6       0      0 localhost:ntp           [::]:*
udp6       0      0 [::]:ntp                [::]:*
udp6       0      0 [::]:2871               [::]:*

Seems you network configuration is wrong.

1 Like

Instructions seems to be still valid for the latest Volumio Image.