Hifiberry Digi+ on Volumio 2


today i installed Volumio 2 on my Raspberry Pi 2.
I use Volumio 1 for about more then a year without any problems.

Volumio 2 seems to be a great job.

But my Hifiberry Digi+ with SPIF output doesn’t work with Volumio 2.

How can i get i to work ?



No one who could help me?

I’m running a Digi + on a RPI3 no problem beyond known bugs.

So ist seems i have to stay on volumio 1. :cry:

… But i realy like to use volumio 2

No ideas how i Fan i get it to work?

It works in rasp 2, with my DAC connected spdif sometimes it s a problem to have the connection, I suggest to switch from another source ( USB …) and then to spdif again

Is it that the volume is too low? I assume that was my problem. I couldn’t hear anything until I changed the “Mixer Type” from “Software” to “None”. I probably could have just turned the volume up in the software.

1 Like

is anything wrong with this? I can’t get it to work.
Volumio 2 playback options.tiff (305 KB)

Hi Jürgen and all,

As you can probably see from my somewhat parallel post https://volumio.org/forum/volumio-and-hifiberry-digi-basic-setup-t4828.html I am also trying to get my Digi+ to work with Volumio 2, the only difference is that I didn’t manage to get it to work with Volumio 1 either.

On the HiFIBerry website there is a guide to ‘Configuring Linux 4.X Or Higher’ https://support.hifiberry.com/hc/en-us/articles/205377651-Configuring-Linux-4-x-or-higher. Is it necessary to do these steps or should the Digi+ theoretically work with Volumio 2 ‘out of the box’ without any tweaks?

Also am I right in assuming that if the audio is being correctly sent to the Digi+ that it should be possible to see the red light in the optical out?

Many thanks,


Same problem here…

1 Like

Guys, did you try to enable i2s dacs and then selecting hifiberry digi+, then click save and reboot. Does it work?

1 Like

I now have it working on an older Pi with a HiFiBerry Digi. When I’m back home in a couple of days I’ll put the SD card in the newer Pi with HiFiBerry Digi+. I’ll report back.

Any tips on how you got it to work?

I have the I2S DAC turned On and I have selected DAC Model: Hifiberry DIGI (I don’t think there is one specifically for the DIGI+). That part is fine after a restart.

If next to Output Device I then choose Hifiberry DAC and click save I get the message “The configuration has been updated succesfully”. I click play etc. but after a while the GUI hangs in the web browser and refreshing leaves me with spinning dots and a “Waiting for volumi.local…” message. I can leave it that way for a while and nothing will happen. Eventually I log in via ssh and restart the raspberry pi using ‘shutdown -r now’.

When I then go back to Playback Options the I2S DAC will still be on, Hifiberry DIGI selected, but the Output Device will not have changed to Hifiberry DAC.

Hope that helps,


I’ll have to check when I’m home. I’ve certainly had problems with the UI hanging, but these are mostly sorted by refreshing the webpage. I don’t remember having to resort to ssh. On occasions I have found it hasn’t saved the settings, but on repeating I have got them saved.

NickJB, mine is definitely set as you describe. See the screenshot in my earlier post.

I’m home and have moved the SD card from the old Pi to the newest Pi and it is working just fine.

I can’t get my RPI B+ with Hifiberry digi+ to work with Volumio 2.001. Worked fine with 1.55. There seems to be no output to the external dac. Normale the dac makes a clicking sound when an active source is selected. Now it remains silent.

Tried several complete reinstalls, selected hifiberry digi / hifiberry dac, looked at volume etc. No succes.

Any ideas? I really want to get Volumio 2 working.


Hello all,

I have just done a fresh install of Volumio 2.001, setting up wifi and installing the spotify plugin.

All goes well until I turn on I2S, select the ‘Hifiberry DIGI’ DAC, and click Save. I get a notification telling me it is restarting and the Web GUI stops working.

I don’t know if it actually does restart but I can still see the RaspberryPi on my network and can SSH to it but the web interface won’t come up (refresh just leaves the browser waiting). It’s been like this for about half an hour so I don’t think it’s impatience on my part.

After shutting down via ssh and powering the Pi off and on again the web interface comes back and the HifiBerry DAC appears as the Output Device.

I can start playing something from Spotify, but I don’t see any red light in the TOSLINK connection.



RaspberryPi B+
HifiBerry Digi+, attached with green LED on
Volumio 2.001, fresh install

1 Like

Sorry to hear you guys are having problems.
What I can suggest.

  • After rebooting, go to playback settings, and hit save again (in the first section). Does it work?
  • If it does not, disable volume control by setting it to none.

Let me know

I have had some problems refreshing the UI, but I’ve found a solution. Maybe it’ll work for you.

If I try to refresh e.g this < xx.x.x.xxx >