Hifiberry Digi+ on Volumio 2

Hi all, thanks for your suggestions. I also just want to say that I really appreciate all of the work that has gone into Volumio - it’s a great piece of software, really like it, just want to get the DIGI+ to work with it!

The problem I now have is that I can’t select the Hifiberry DAC as the Output Device.

Any of the others works fine but selecting the Hifiberry DAC and saving doesn’t give me the ‘Configuration Update’ message and after about a minute I get spinning white dots and a hung interface. Using just the IP address instead of volumio.local doesn’t help.

After about 5 minutes I restart via ssh and the Output Device is not changed i.e. still not Hifiberry DAC.


Do this,
disable the i2s dac. save. reboot.
enable i2s dac, select hifiberry digi, save then reboot
if you don’t get any sound, click save again in the playback options

Thanks! I’ll give it a try and will let you know.

Can’t wait using Volumio 2 with my Hifiberry :slight_smile:

But as previous people say, it seems that the optical output doesn’t work.
I tried your last reply without any success.

If you need any help, my Putty is ready :wink:

Yes, this works. :smiley: Now the Spdif port of the Hifiberry digi is active.

I have to say I’m not getting on very well with this.


In the meantime I flashed an SD Card with Raspbian, edited /boot/config.txt

commenting out:

created /etc/asound.conf containing:

pcm.!default {
type hw card 0
ctl.!default {
type hw card 0

Rebooted and used mplayer to play two mp3s through the hifiberry digi+ so I am certain my Digi+ is okay. I’ve seen the TOSLINK light when it’s working and the connection to the speakers is good.


Back to Volumio and I’ve flashed the SD Card again, enabled I2S, selected HifiBerry Digi, rebooted tried to play the same mp3s, disabled I2S rebooted etc. all without any joy. While I had the monitor connected I got a couple of error messages:

bcm2835-i2s 20203000.i2s: I2S SYNC error!
bcm2835-dma 20007000.dma: DMA transfer could not be terminated

If I knew which config files needed adjusting I’d happily do it myself via ssh but I don’t think it’s the same as Raspbian is it?



RaspberryPi B+
HifiBerry Digi+
Volumio 2.001

Tried saving and rebooting on my RPI B+. Only effect was that Output Device now said 'Hifiberry Digi; instead of Hifiberry Dac.
But then I tried a new RPI 3 B and it works! Both rca and Toslink.

Same here “Hifiberry Digi” as output device after restart.
I’m on RPI2.

I have a slight variation to my experience compared to others I’ve read on this thread so far. I am posting here in case it may be helpful in some way to have more data.

My setup:
Raspberry Pi 2
Hifiberry DIGI+ transformer version
Using s/pdif connection (not optical)
Classe CP-800 pre-amp as DAC

My experience:

  1. Hit Play
  2. Wait 1 to 3 seconds, music plays with volume ramp-up effect
  3. Music plays for to 1 to 5 seconds, then
    4a) Music drops out, go to step 2
    4b) Music gets “scratchy” noises, ultimately drops out, go to step 2
    … and repeat until I get frustrated and pull the power connection.


I’ve read about needing to blacklist LIRC when using the Digi+ with a Raspberry Pi B+. How / where can I do that in Volumio? There is no /etc/modprobe.d/raspi-blacklist.conf

I’ve also been playing around with /etc/modules and in one configuration the TOSLINK connection did light up during the boot process which is something that I noticed in Raspbian as well. Is there a specific list of modules that needs to be in /etc/modules or is this somehow taken care of by dtoverlay=hifiberry-digi?



Hi Michelangelo,

I’ve started from scratch at least four times now and it just doesn’t seem to work. Is this specifically a problem with the B+?

When I turn I2S ‘On’, select the ‘Hifiberry DIGI’ DAC and click ‘Restart’ the GUI hangs and dmesg adds 5 new lines:

[ 225.023095] snd-hifiberry-digi soc:sound: ASoC: CODEC DAI wm8804-spdif not registered
[ 225.031209] snd-hifiberry-digi soc:sound: snd_soc_register_card() failed: -517
[ 225.087908] wm8804 1-003b: revision E
[ 225.163570] snd-hifiberry-digi soc:sound: wm8804-spdif <-> 20203000.i2s mapping ok
[ 228.267917] bcm2835-i2s 20203000.i2s: I2S SYNC error!

And then after a restart adding:

[ 162.593759] bcm2835-dma 20007000.dma: DMA transfer could not be terminated

Turning I2S ‘Off’ again, restarting, turning it ‘On’ again, restarting, clicking ‘Save’ again doesn’t seem to make any difference.

Daniel on the HifiBerry forum has suggested that some modules might be missing from the kernel (https://support.hifiberry.com/hc/en-us/community/posts/209443465-I2s-sync-error-in-volumio). Is that possible?

Many thanks,


I can confirm that the Pi3 with Hifiberry Digi+ (transformer version) does work with volumio 2. You may want to consider just upgrading to the Pi3 and get the added performance of the new Pi?

Hi all,

Just to say that is what I did in the end (upgrade to a Pi3).

The HifiBerry Digi+, Raspberry Pi3 and Volumio 2.001 worked first time and play perfectly through the coax SPDIF link to my digital speakers. The Pi3 provides a much more responsive Web Interface as well which is something I hadn’t really thought about.

It does mean I have one more Pi to add to my collection (which I was trying to avoid) but another positive is that I have set one up in another room using the analogue out and so I now get to benefit from Volumio’s multi-room capabilities as well.

Thanks to everyone for their suggestions and to the Volumio team for making such a nice piece of software.


1 Like

I’m not so lucky.

Tried on a Raspberry PI 3 but nothing on the TOSLINK.
I just see red light when Volumio start then nothing.

I get a Hifiberry Digi-B+ HW1.0 (which was working fine on Volumio 1).

EDIT : I just try with the toslink connected to my ampli and i can hear the Volumio startup sound but then nothing on Spotify.

Damn, webradios work too !
Look like there is a problem with Spotify … and just Spotify !

Did anyone here got Volumio 2 to work on Raspberry 1 Model B with Hifiberry Digi+ ?



I have some problems, blanks, with flac 192khz ( less compressed) on long songs.
May be a problem of buffer, althougth I put 40% and 12Mb.
I do not have this problem with other music players…
I have a Raspberry 2 with DIGI+.
Thanks in advance for your help.

Some news here?

Anybody solved this problem?

For anyone still interested in getting their Hifiberry Digi+ working on Volumio, I believe I have found the issue. I was running into the same problem described here. I tried reflashing, resetting, everything, multiple times; tried every I2S/DAC combination, and couldn’t get any sound out of my HiFiBerry Digi+ Standard HAT.
Found out in another thread that it’s because these Digi+ Standard DAC boards were shipped with Digi+ Pro drivers on the EEPROM. When software like Volummio trys to use the HAT it sees the drivers and tries to use them, causing this error.

On my Volumio 2 system, this is what fixed it:
Run the Setup wizard and select I2S on and HiFiBerry DIGI (not Pro or anything else).
After setup, my my Config.txt looks like this; not sure why it has the duplicate entry, but I just did the standard Volumio 2 Setup Wizard; and the HAT board does NOT work yet with this:

initramfs volumio.initrd

Volumio i2s setting below: do not alter



include userconfig.txt

Volumio i2s setting below: do not alter


Now, the important part is in the root of your Volumio install, Edit the UserConfig.txt file, and add this EEPROM line so that it looks like this:

Add your custom config.txt options to this file, which will be preserved during updates


Now reboot your system, and try it out. Keep in mind with Optical out you’ll want to make sure whatever your plugged in to has the volume up at least a bit. I hope this helps someone! I was so frustrated with this. It’s also confusing that there is NO DIGI+ standard option in the dropdown. I wonder if Volumio could an add an option for that, and have doing so ALSO add this force_EEPROM line to the UserConfig; just a thought, don’t know if that’s possible. Good luck!

It took me a bit to realize you were referring to files located in /boot, but I did eventually figure it out and make the same changes. I have what I think is the identical setup and still no sound. I am attempting to use the rca digital out instead of the optical, so perhaps that is the issue.

Correction, I do get sound, but only at 48k. Anything higher doesn’t play. Manually setting the max at 48k does work, but I was expecting to gut the full resolution.

Update - I finally figured it out. My pre-amp DAC is limited to 48k. It was a very high-end device when made, but is essentially an antique now, so I shouldn’t be too surprised. No issue processing 24 bit, but I will never get 192k. Perhaps I will start shopping for a new DAC.

Hello, if it can help someone : I ran into the same issue with Volumio 3 and solved it by removing force_eeprom_read=0 from config.txt

Hope it will work with other ppl who will run into this issue !

1 Like