FusionDsp : the complete Dsp center for Volumio3!

Your Camilla.yml seems to be wrong…
Can you share it?
How do you created it?

Yeah, but i started with a fresh system. And got this failures. The log is full of erros with a fresh system and just FusionDSP in v.1.0.53: http://logs.volumio.org/volumio/JwAdAdJ.html

I think it is something with the RPi5:

Oct 20 15:45:04 volumio kernel: brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.raspberrypi,5-model-b.bin failed with error -2

Yes, the first step is having a running system.
I don’t own a rpi5…

This is the unchanged camilladsp.yml after fresh install:

  samplerate: 48000
  chunksize: 4800
  silence_threshold: -60
  silence_timeout: 3.0
  queuelimit: 1
  target_level: 1024
  adjust_period: 10
  enable_rate_adjust: true

    type: File
    channels: 2
    format: S32LE
    filename: "/tmp/fusiondspfifo"
    extra_samples: 4096
    type: Alsa
    channels: 2
    device: "postDsp"
    format: S32LE

    type: Conv
    type: Biquad
      type: Lowshelf
      freq: 185
      q: 0.82
      gain: 0

    type: Biquad
      type: Peaking
      freq: 1300
      q: 0.4
      gain: 0

    type: Biquad
      type: Highshelf
      freq: 5500
      q: 0.82
      gain: 0

      in: 2
      out: 2
      - dest: 0
          - channel: 0
            gain: -0.05
            inverted: false
            mute: false
      - dest: 1
          - channel: 1
            gain: -0.05
            inverted: false
            mute: false

  - type: Mixer
    name: stereo
  - type: Filter
    channel: 0
      - eq1
      - eq2
      - eq3

  - type: Filter
    channel: 1
      - eq1
      - eq2
      - eq3

When i try to load it into the GUI i get this:

It runs and it plays normaly music without and even with FusionDSP. Only with Pure Camilla DSP it dont work.

You didn’t tell me if it works with other mode?
And place your file in

 Can't check the exact path now...)

Hi @balbuze ,

I’m getting some glitches (more like “instantaneous” moments of no sound) and in CamillaDSP in the “show log file” I get this kind of messages after it happens:
"v2024-01-28 11:52:37.407813 WARN [src/alsadevice.rs:157] Prepare playback after buffer underrun
2024-01-28 11:53:00.859138 WARN [src/alsadevice.rs:157] Prepare playback after buffer underrun
2024-01-28 11:53:46.409185 WARN [src/alsadevice.rs:196] Playback device failed while waiting for available buffer space, error: ALSA function ‘snd_pcm_wait’ failed with error ‘EPIPE: Broken pipe’
2024-01-28 11:53:46.409912 ERROR [src/bin.rs:344] Playback error: ALSA function ‘snd_pcm_wait’ failed with error ‘EPIPE: Broken pipe’
2024-01-28 11:53:46.474221 WARN [src/alsadevice.rs:157] Prepare playback after buffer underrun

And here’s Volumio log:

Any idea?


I see you are using Peppymeter…
Sorry but I can’t assure you FusionDsp will work…
And IMHO, Peppymeter allsa contribution should be after FusionDsp in asound.conf…

Thanks @balbuze,

Sorry for my ignorance but when you say “Peppymeter allsa contribution should be after FusionDsp in asound.conf” is that something user configurable, or is something that would have to be implemented in Peppymeter plugin development?

By the way, FusionDSP is fundamental to me (nowadays), thus I’ve temporarily disabled Peppymeter (which I love but… sound is sound).



I think that you need to put that question in Peppymeter Screensaver Plugin thread.

Best Regards/ C

Thanks @ClaesM

Hi @balbuze, do you mind if I pose the question with your suggestion in the Peppymeter thread?


I’m not saying it will fix the compatibility between both plugins. But for me audio data sent to peppymeter should be after the Dsp to reflect the sound and more important, the delay introduced by the DSP (about 800ms)


Even only for the delay makes sense to me :wink:

Is it possible to use CamillaDSP Loudness on Volumio ?
I see that Volume control is not using CamillaDSP volume control so it can’t properly apply loudness filter.

I also checked Loudness option from FusionDSP and I saw that it’s implemented by changing CamillaDSP filters after volume change.

Is there solution for that or am I forced to use FusionDSP Loudness ?

FusionDsp provides a very advanced loudness adjusted with volume levels. See online help FusionDsp How-to
If you want to use only CamillaDsp effect, use pure Camilla gui mode. But you won’t be able to use Camilla volume control from volumio.

Can just Volumio/FusionDSP notify CamillaDSP about volume level ?
There is SetFaderExternalVolume command for that.
Reference: https://github.com/HEnquist/camilladsp/blob/master/websocket.md

I will answer myself.
SetFaderExternalVolume was added in CamillaDSP version 2.0.0.
Volumio is using 1.0.2 :frowning:

To use CamillaDSP 2.0.0 you need pyCamillaDSP 2.0.0 which needs Python 3.8 which needs upgrade of buster to newer raspbian. Sound like huge work.

This is on my plan…
But why do you so want to use CamillaDsp loudness against the one in FusionDsp?

1 Like

I tested FusionDsp loudness.
It has IMHO too much bass and it’s less configurable. (no option to specify gain for bass/treble)


Hi balbuze, I have a request…
It should be possible to “expand” the graphic eq in Fusion dsp up to 32 band?
It will be very useful for a more aimed and precise adjustment.
Thank you so much in advance!