FusionDsp : the complete Dsp center for Volumio3!

Hello,

yes the warning works. I use RPI 3B+ and Volumio App on IPhone.
That is really great and usefull.
Thanks

Every second I get this warning on Rpi and Primo:

“EXPERIMENTAL FEATURE! Clipping detected in FusionDsp! Check attenuation! Press pause/play to reset message”

Press pause/play works for some minutes. I did check the attenuation, but can’t find the issue.

Does anyone have a solution?

If you amplitude is at max (digital 0dB) and you have one of the octaves to +3 dB clipping will occur. Please lower the pre gain (in this example to -3 dB) so the max amplitude doesn’t exceed 0dB.
see:

I’ll try this. Thanks.

Hi. @Wheaten is correct. Enable automatic pre amp. If still a warning, click on more settings and add attenuation for both channels.
But as noted, this is experimental… In some cases, it reports false warning… I made a new version that should be better. But as there is a lot of internal changes, I need time to check and test . And maybe I will désactivé it until CamillaDsp v2.0 is out…

Increasing the volume of the amplifier(s) was the solution.
For me it’s strange that this warning started after an update on both systems, without changing the volume on both amplifiers.

This is the first version with the warning.
What is the mode you use? (Eq3,eq15,peq or conv)
Is auto pre amp enabled?
If PEq what filter do you use?

It is cause the feature is new.
Maybe you had Clipping bevor but did not know. If you Open Camilla DSP, you could see Clipping on the left side.

The Clipping is not ever the same.
As example, i hear to three different Radiostations, and every has another Gain Output.
So, could be you use -3db Gain, and after switch to another Station, the Massage can come again.

1 Like

@Flames same question, what mode do you use. Is auto pre amp enabled?
If the settings.is correct, you don’t need to change when source changes

I have auto preamp off.
We talk about for a while.
I use a Low Cut Filter.
I can try with auto pre on, But i am happy with my choice this time :innocent:

Ok. No problem. It is to better understand and improve the plugin :wink:

2 Likes

I am using one Raspberry Pi 3B and need to set up output (jack 3.5) to be mono instead of stereo, since it will be connect to a home media system that only accepts one audio channel.
How can I change it to mono ?

Thanks in advance

You can use the plugin FusionDSP.

1 Like

Hi,

Thanks
I have already try Fusion. The problem is that the Raspberry Pi 3B, when plugin is enabled will be slowly and sometime stops working.
Any other suggestion ?

in a very rough way, please note te resistors to avoid shortages:

source:

Hi,
I use FusionDsp on a Rpi3 without issue.
Can you give

  • version of FusionDsp
  • mode used and type of filter
  • if you have other plugin
    Any information to help :relaxed:

Hi,

  • FusionDSP version 1.0.47 (just updated)
  • Volumio version (latest)
  • Other plugins (autostart / backup)
  • I am using 15 band equalizer and mono setting

Please check my settings:

When I activate the DSP the sound is distorted, and impossible to hear

You have to enable auto pre amp to avoid clipping…

Hi Balbuze,

Regarding auto preamp adjustment to avoid clipping, I have noticed that the auto adjusted setting is somehow depending on the song paused in the list, i.e calm song will result un somewhat lower adjustment than rock, loud songs.

Anyhow, using the same convolution IQ provides different auto adjusted levels (from simple to double the value) depending on the time I perform the auto adjustment.

Any feedback on this behaviour?

Cheers,

Benoit

1 Like

Hi,
No, preamp is not dependent on what is played!
It use the max gain in filter plus an offset to set the value.
But I can assure you that nothing else is considered in Peq. /geq
In convolution, a pink noise at 0dB is played to determine the level. In earlier version of FusionDsp, if detection was done while something is played, result was bad. Now it pause the play before probing.
Let me know what is your case