FusionDsp : the complete Dsp center for Volumio3!

I have an up to date installation of Volumio3. One day I switched on and got no sound which led me to do a factory reset. I then installed the Fusion DSP plugin which seemed to go OK. Then, so I could ssh to Volumio I brought up the /dev/ page if the interface. I enabled the Live Log and started seeing error messages related to FusionDSP.

Started FusionDsp Daemon.
Traceback (most recent call last):

  • File “/data/plugins/audio_interface/fusiondsp/cgui/main.py”, line 1, in *
  • from aiohttp import web*
    ModuleNotFoundError: No module named ‘aiohttp’
    fusiondsp.service: Main process exited, code=exited, status=1/FAILURE
    fusiondsp.service: Failed with result ‘exit-code’.
    fusiondsp.service: Service RestartSec=2s expired, scheduling restart.
    fusiondsp.service: Scheduled restart job, restart counter is at 363.
    Stopped FusionDsp Daemon.
    Started FusionDsp Daemon.

Then from the command line I did
pip install aiohttp

That said there was no module called pip.

Via a web search I then downloaded a file called get-pip.py and ran
volumio@pi2aes:~$ sudo python get-pip.py
[sudo] password for volumio:
ERROR: This script does not work on Python 2.7 The minimum supported Python version is 3.7. Please use https://bootstrap.pypa.io/pip/2.7/get-pip.py instead.
so I downloaded that file and tried again

volumio@pi2aes:~$ sudo python get-pip.py
which ended
Successfully installed pip-20.3.4 setuptools-44.1.1 wheel-0.37.1

I then reran pip install aiohttp which gave

volumio@pi2aes:~$ pip install aiohttp
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at Release process - pip documentation v23.0.dev0 pip 21.0 will remove support for this functionality.
Defaulting to user installation because normal site-packages is not writeable
Collecting aiohttp

  • Downloading aiohttp-2.3.1.tar.gz (1.1 MB)*
  • |################################| 1.1 MB 772 kB/s*
  • Installing build dependencies … done*
  • Getting requirements to build wheel … done*
  • Preparing wheel metadata … done*
    ERROR: Package u’aiohttp’ requires a different Python: 2.7.16 not in ‘>=3.4.2’

So it seems that aiohttp requires python3 instead of python 2 which Volumio and FusionDSP uses.
Any suggestions for stopping the FusionDSP error messages?

Using v1.0.30 should fix this problem.
What version do you use?

Thanks Wheaten.

You made a fair comment about the number of things changing which makes a direct comparison problematic.

When in doubt, seek more data.

I did a comparison between the filter curve in FusionDSP (by doing a CSV download in CamillaDSP and the plotting in Excel) and Equalizer APO (Analysis Panel) for the same set of Parametric EQ filters.

This is shown in “Filter curve (CamillaDSP vs EqualizerAPO).png”.

They are equivalent so any differences I’m perceiving are not from an obvious difference in the overall filter curves.

I know there’s a lots of variables still in play but the overall filter curves in FusionDSP and Equalizer APO does not appear to be the issue.

I don’t know what my next step is but “just sit back and enjoy the music via Volumio on the Raspberry Pi” might be the simplest approach. :grinning:


yes, keep in mind that Volumio is fully designed to deliver the best output.
So enjoy the quality. If you still want to do some more testing you might look into programs like:

I have run some test with it and there is some small improvements, if I can hear 60-90 euro differences, I didn’t.

I have installed the lastest version of FusionDps. When i load and use setting such as (bass, voice, soundtrack,… exclude “flat”), the output volume reduces very much. Could you advise me how to fix this problem.

There is no problem and nothing to fix…
let me explain…
A max level in digital domain is 0dB
When you set a positive value in the EQ (ex 3dB) for a frequency, it means increase the signal here. As it is not possible to go above 0dB, to get the same relative effect, everything is set 3dB lower exept the frequency you choose. If you don’t do that, signal will be clipped! With a very bad sound. FusionDsp auto adjust this level by default according to EQ settings. You can disable this in ‘more settings’ and ‘auto preamp’ off. But signal may be clipped. All software require a attenuation (pre-amp) to work properly.
This not a FusionDsp issue, but an easy way to enjoy music without bothering with complex settings.
Enjoy :wink:


Just a graphical representation of Balbuze explaination.
Every red area can/will result in clipping, as the signal passes the 0dB boundary:

With the pre-amp lowered, this behavior will not appear:


Hi Balbuze and Wheaten,

Thanks for your explanation. According your advice, when I use these setting, all I have to do is: turn volume up in amply?

Yes … :wink:

1 Like

Hi Balbuze,

Thank you so much.

What version do you use?

Version was 1.0.28.
Updated to 1.0.30 as you suggested and error messages have stopped.
Thank for your advice.

1 Like

Any progress on the Airplay issue?

1.0.30 did not fix the Airplay issue for me either.

1 Like

Have you tried to raise the volume on your Apple device AND Volumio with level > 50?

1 Like

Yes volumio is set to 100% and airplay to around 60+.

With FusionDsp disabled it works 100%.

Can you try the following:

  • Reboot the device
  • Make sure DSP is enbaled (if you change settings, turn DSP off and on again)
  • Open the application on your phone
  • Set the volume to > 50% (phone)
  • The start airplay

Is there a way to backup my custom EQ settings so I can then copy them to a new version of Volumio on another SD card. I don’t see my EQ settings in the Volumio shared folder Internal storage > FusionDSP.


The only to copy FusionDsp settings, is to SSH to your device, then copy


And paste in the same location on your other device.
If you are using peq, an other way would be to create a txt file from your computer with all Eq (using REW syntax or demo file in /peq folder).
This way, you can import the file in FusionDsp in a very easy way and use it on all your devices. See online help to import file.


Just updated to 1.0.31. What is new in this version?


FusionDsp v1.0.31 stable.

This version brings nothing new for ‘normal’ user.