Error creating folder: Error: ENOSPC: no space left on device, mkdir '/data/temp'

I still have the same problem. Can’t install any plugin. Is there a rescue or, as usual, the answer in the case of volumio is to re-flash sd cards? I am fed up with this, the software is so stable that I have to upload the sd once a week. Every time after a few days it fills up to 100 percent and won’t let you install anything and spotify connect stops working!

Volumio Version:2.906
Hardware: Rpi3b
DAC:X6 usb

Have you attempted to look at the logs and see why you are running out of space?

Would you share some system logs please?

Otherwise, expecting people to just guess why is a non-starter ;).

Your problems with stabiltiy are not the norm … I have a number of devices running 24/7 for months without needing attention.

1 Like

Hello chsims1 I’m having the same issue “An error occurred while installing the plugin Error: Error creating folder: Error: ENOSPC: no space left on device, mkdir ‘/data/temp’” I just sent system logs
volumio@lui-volumio:~$ df
Filesystem Size Used Avail Use% Mounted on
/dev/mmcblk0p2 2.6G 882M 1.6G 37% /imgpart
/dev/loop0 382M 382M 0 100% /static
overlay 138M 128M 0 100% /
devtmpfs 964M 0 964M 0% /dev
tmpfs 1.1G 0 1.1G 0% /dev/shm
tmpfs 1.1G 9.4M 996M 1% /run
tmpfs 5.3M 4.1k 5.3M 1% /run/lock
tmpfs 1.1G 0 1.1G 0% /sys/fs/cgroup
tmpfs 21M 37k 21M 1% /var/log
tmpfs 1.1G 41k 1.1G 1% /tmp
tmpfs 1.1G 0 1.1G 0% /var/spool/cups
tmpfs 1.1G 0 1.1G 0% /var/spool/cups/tmp
/dev/mmcblk0p1 96M 58M 39M 60% /boot

tmpfs 201M 0 201M 0% /run/user/1000

release 2023-01-24 does the same thing for me.
looks like bugs don’t get fixed, so it’s goodbye.
what little debugging I can get, it looks like it’s trying to use ram to be faster doing the install and runs out.
it ignores gigabytes of empyt space on the sd card… really makes it fast!

i think you didn’t let it expand? what system do you use it does expand after the first boot
and it takes some time but if you don’t wait you can do it manually.
there is a command to do so but i have to ask if i got the right one.

I gave it plenty of time, on 2 different SD cards. Later I looked at the cards on another computer with gparted, and all of the 16G and 64G cards were partitioned. They still had the same error afterwards.
Ssh into the running systems it looked like the system uses ram filesystem folders.

Forgot to mention this was a pi 3b+ with a geekworm hard disk for data.

pi3 will take more time 10-15min most of the time but the size will set the time.
i’m still waiting to give you a anwser but i have to check if this is the good one
ssh and putty should not be new for you.

sudo resize2fs /dev/<here the drive you want to expand>

but i don’t know if it should be on drive 1 or 3 i’m still asking that.
and i hear that your already good enough with linux to know what the drive should be.
most of the guys are still sleeping i was early it was 06.00 am
with what are you burning the image dd?
or do you use something else i use windows based system and use win32disk imager or pi imager.
but the guys of the community will help you to get it up and running.

@Wheaten can you help with this?

Difficult to help.
The only information we got from Mike, he’s using a rpi3 and bumping a 2 year old topic.
please post a log first.

a two year old topic about a problem that is still current. Best to forget the past?

waited 2 hours after a fresh install
it did an update to v3.429
tried a different plugin.
failed, but not the same

any other attempt to install a plugin gives something like this:

Downloading plugin at xxxx
Creating install location
An error occurred while installing the plugin Error: Error creating folder: Error: ENOSPC: no space left on device, mkdir ‘/data/temp’

(replaced the links with xxxx because I’m not allowed to post more than 2 links)

Nothing about forgetting the past, I just need to be sure your running V3 and we have the needed information. As we didn’t get any useful information with the opening post.
It seems you’re use a very small SD card, 4.096 GB?

Any idea what is happening here.
The log shows that the used SD card has plenty of storage, but at the end it keeps complaining about space. Seems that the overlay is not expanded. as it is at 100%

# df -h ---------------
Filesystem      Size  Used Avail Use% Mounted on
/dev/mmcblk0p2  2.5G  935M  1.4G  41% /imgpart
/dev/loop0      410M  410M     0 100% /static
overlay         132M  126M     0 100% /
devtmpfs        445M     0  445M   0% /dev
tmpfs           484M     0  484M   0% /dev/shm
tmpfs           484M  9.0M  475M   2% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           484M     0  484M   0% /sys/fs/cgroup
tmpfs           484M     0  484M   0% /var/spool/cups
tmpfs           484M  104K  484M   1% /tmp
tmpfs            20M  4.0M   17M  20% /var/log
tmpfs           484M     0  484M   0% /var/spool/cups/tmp
/dev/mmcblk0p1   92M   54M   38M  59% /boot
/dev/sda1       932G  364G  568G  40% /media/media
tmpfs            97M     0   97M   0% /run/user/1000
Feb 13 14:11:31 volumioserver volumio[779]: E: The package lists or status file could not be parsed or opened.
Feb 13 14:11:31 volumioserver volumio[779]: E: Write error - write (28: No space left on device)

I included the software release data as shown by the Raspberry Pi Flash tool in my first message because I couldn’t find a revision number.

I am using a 16G flash (also tried a 64G flash with same results)

I shut down and pulled the flash and examined it with gparted:

very little of the 16G is used.

yeah, something is wrong with SD image.
Do you have a windows machine available?

No. Linux only.

A bit concerned on the yellow exclamation mark, which means the partition can’t be read. As in your log file nowhere is the remaining partition size located. It should have been part of the overlay.
If I do the same with my SD (on linux) there is no yellow exclamation mark

I’m flashing a 64G card to try again.

This is a known issue!!!
It depends the tool being used for flashing.
You can see it from the size of overlay: 100% used with a size of only 410M, means the data partition has not been resized properly. As the overlay spans its initial squashfs size (sorry for the details) plus the size of the resized data partition is should be close to the size of the whole disk

With linux, flash like this

sudo umount /dev/sdX
sudo dd if=<your image file name> of=/dev/sdX bs=4M

Where X is the usb device letter you are using and <your image file name> the complete path of your unzipped download, including “.img” of course.

I’ve flashed with dd before, had some problems this time, but found an easier way:

flashed the SD with the Raspberry Pi Flasher on Linux
before ejecting the SD, opened gparted and resized the partition.
booted the Pi
Now I can install plugins

This seems much easier than using dd.

Thanks for the assistance.

as suggested here deleting volumio_data partition and then recreating it with gparted solved the problem.

idk why but something is wrong with this partition (that is created on the rest available space during the initial boot): used+unused!=size as shown here