Display doesn't work anymore since latest update

I just did the latest developer update. Since then the display doesn’t work. It is powered and plugged in but it just shows stripes. Volumio itself works fine (over web interface). Any suggestions?

Hhm. No one with the same problem? Will it be an option to wait for the next update? Or will I have to look for an older version of volumio?

What is your device?
What is your dac?
What is the version of volumio
Have you some plugin installed?

I am using a Pi3 with an IQAudioDac Plus. I attached a “Waveshare 7 Inch Capacitive Touch Screen LCD” to it which worked fine with the volumio Touchscreen plugin until I did the update to version 2.278 a few days ago.

Volumio itself works still fine and plays all the music. But the sreen is just showing stripes.

Have you reinstalled the plugin?

Yes, several times. Didn’t help.

I can’t look into this now, but I will do probably in 10 days. To me it seems that you need to increase the HDMI output power ( I remember there was a config.txt settings for it, but can’t recall which one it was)

Hello Michelangelo,

thanks for your response. In the meantime there was another update, which unfortunately didn’t fix the issue. Can you tell me, how to change the settings of the configs by myself?


I’m wondering if I’m having the same/similar problem? See touchscreen-plugin-fails-run-rpi3-volumio-t7686.html Rpi3, 2.246 install. No DAC, just the native audio out (it’s for a lo-fi kitchen player, also lets me control the headless Volumio on the main stereo without pulling out a phone or laptop). The screen works. It displays the Volumio splash screen on boot, but then a text login you’d expect without the plugin installed. Uninstalling the plugin and rebooting doesn’t work (tried repeatedly). Previously running a version from much earlier this year (before 2.224), and the touchscreen worked then. Had problems getting the system upgrade to install, so decided to start fresh. Ugh.

OK, I am out.

I bought a RPi-Dac-bundle over volumio.org. I attached a waveshare-display. Everything worked.

Now nothing doesnt’t work.

Meanwhile I got a new screen. No difference. New installation of volumio. No difference. I think I will change to a commercial solution. It’s a pity. The volumo-idea is very good and the design is fine.

Could you please flash the latest volumio from zero?
Then tell me the exact steps you do, I’ll try to help you

I loaded down latest volumio-version from here: volumio.org/get-started/

Then I installed it with Win32Diskmanager on the micro-sd which I put into the RPi. After that I started the RPI watching on stripes on the screen.

Over the web-ui I installed the Touch-Screen-Plug in and restarted volumio. I still get a screen with stripes:

Ok, I will test it today.

Thanks a lot. Every Hardware-issues I tested. Another cable, Another screen…

You can stop your efforts. I found the solution. During the update the config.txt in the root was set back. There were some lines for the Display added. After putting the lines back, it worked. Missing lines:

hdmi_cvt 1024 600 60 6 0 0 0

Thank you so much for this.
I wonder if it could be worth to add it directly to default Volumio

Hi Michelangelo,

I just did the latest update. Same problem, display doesn’t work anymore.
After editing config.txt (sudo nano /boot/config.txt) the display works again. Isn’t it possible to modify volumio to not change the file config.txt when updating?

What did you need to add to config.txt to make it work?

Hi Michelangelo,

the lines I already posted above.

Anyway in past updates no problems occurred, but now the config.txt is set back every time I do an update.

The bug ist still there. After updating, I have to edit the config.txt again. Isn’t there a possibility to leave the config.txt like it is, when updating? It is really annoying…