Disable Volumio login


I am setting up volumio on Raspberry Pi as a device just to use it on Airplay. I wish to leave it without screen and all rest things, so I was wondering if it is possible to disable login ? So that once raspberry receives power, it just loads Volumio and it starts working?

Thank you

This just the way volumio is working…

Bumping this one.
I have same problem. Volumio requires a login every time it restarts…so thanks for the unhelpful reply. Anyone else?

No need to login to use Volumio from an other device. Login is just if you want to access cmdline in local.

Don’t completely follow your issue - you don’t need any interaction to run Volumio - it’s headless and is meant to be accessed via a web browser.

If you want to turn of the display, then take a look at Set display off after boot - #4 by z0rk for some ideas that are being thrown around :slight_smile:

As written above. After using it fir some time it freezes and becomes inaccessible and I have to restart it. After the restart (as a headless device) it is inaccessible from a browser. Both volumio.local and eth/wifi ip addresses. I then have to hook it up to my TV via HDMI, attach a keyboard and log into it via the on screen menu. Volumio/volumio
Very annoying.

It shows up as a client in ip tables etc, but is unresponsive to ping via CLI

And logging in fixes things?

You could try running volumio logdump "Some description here would help" the next time to submit a log for troubleshooting

@trym I think your best bet may be a fresh installation. Download the image, checksum it, burn it to your card. You may even consider using a different card. Personally I wouldn’t spend my time troubleshooting unless you are interested in learning more about Debian and Volumio.
There’s a backup plug-in available so you could back up your settings and restore them to your new image and still keep the old/broken one around just in case. Just my two cents.
I’ve been using Volumio since version 1.x and I do recall similar behavior that you are describing with version 2.x. I believe it started to happen after an incremental upgrade in version 2.x, e.g. 2.1 to 2.2, so I nuked the image. Whenever I do a new install I use a different USB key (I use USB keys with x86). Then I test the old USB key with a Linux or Windows tool before I use it again if it passes the test.
In my case Volumio booted to the command line and it was inaccessible from a browser but I could SSH to it. Sounds like your problem?
Otherwise should you decide to continue troubleshooting make sure to provide logs so the knowledgeable folks around this forum can provide you with some useful feedback.
Search the forum for keywords on how to report bugs. This here is the pinned basics Tipps/Guidlines to get faster help.

Good luck!

1 Like