Dell Wyse 5070 + Waveshare 11.9 issue with Volumio 3

Hi everybody,
hope somebody could help me.
I just bought a 3rd hand Dell Wyse 5070 (with 2 DP display connectors) with the aim to connect to an ultra wide display (Waveshare 11.9 320x1480 HDMI). Testing DAC is the Musical Fidelity X-CanV8 Pre, my favourite headphone amp.
First of all: Volumio in an headless configuration works smooth: bitstream from an x86 machine is fantastic (I came from a RPi 3), never heard music in this way.
I added the Waveshare display: it shows the booting information (oriented 90degrees clockwise), then blank after boot ends. I moved to a 1920x1080 display and the interface is displayed perfectly.

Then I moved back again to the Waveshare display and I got the same issue: total blank after boot info. Ok, maybe it is something related to the particular ultrawide (and rotated) resolution. As suggested in this forum, I tried to use “sudo xrandr -d :0 -o left”… but display is still blank.

I attached a display to the secondary DP connector, booted again (note this!), repeated the “sudo xrandr -d :0 -o left” and it momentary displays the content; after a couple of attempts of rotation the touchscreen worked properly. But each time I restart the PC I need to restart with a secondary display attached to the secondary DP and replicate the xrandr command (with sudo).

2 questions:

  • is there a way to run Volumio with the Waveshare display connected? Does anybody successful did it? I’m a bit new with DP interfaces… for some uses I read that someone used a “dummy” DP connector to run some applications (some home automation or NASes) with particular hardware with this kind of interface: is the same for Volumio? Does anybody ran in the same issue?

  • is there a way to script the sudo xrandr command to rotate and automate the startup? Remember sudo is mandatory. In which script and how to do it?

Thank you so much for any help you may provide.

All the best!

Gianfranco, Florence


I tried Wyse 3040 with my 11.9"without result.

I use 7" Waveshare. 1024x600 is officialy not supported but works with Volumio.

1 Like