[Closed] Volumio 2.0 Final Release is near - Pre-test needed

Hi All,
we’ve been working a lot this summer to fix all open issues, and we’re really close to have a final, bug free Volumio 2.0.

Before releasing to everybody, it will be useful to do a pre-test, to spot the last bugs. You’ll also find new and amazing features (like grid view and library browsing…).

Please try it and report here your findings, only bugs please.

How to get the last version:

go to volumioip/dev

You’ll see a section called TEST MODE. Click on TRUE. From now on your volumio device will be able to receive test updates. If you want to revert this, click to false. Remember that test updates might brick your system.

Now, if you’ll go to system -> check updates, you’ll see a new update available. Update as usual.


EDIT: Updated image with last fixes

updates.volumio.org/pi/volumio/1 … pi.img.zip
updates.volumio.org/x86/volumio/ … 86.img.zip

PLEASE NOTE: If you want to use spotify, use this .zip file instead of the official one:

We expect to release next week, thanks for your help!


I think that Volumio hotspot should be protected by default. The obvious password should be of course volumio, but we need a password with at least 8 characters (volumio is 7). So:

  • Do you guys agree that we should secure the hotspot by default, or should we left it open (the UI has an easy way to secure it)
  • What would be the most easy password? Something like volumionetwork , audiophile, vivavolumio etc

let me know

Hi, just a quick one. I updated via the test mode and it worked fine. My Raspberry Pi 1 with a Hifiberry DAC came back and it still plays fine.

Here are some quick findings: (not sure whether you wanted feedback here directly?)

  • My Music
    . it does not show mounted network drives as my NAS which it is currently playing from
    . there is a little i (Info?) above “Add new drive” which does nothing, as in no mouse over etc.
  • Playback options
    . when clicking on mixer control (which was empty IIRC) now displays “no” but when clicked it completely disappears
  • Plugins
    . Search brings no plugins (probably correct as it’ a dev build)


Installed .991pi: There is no sound coming from my Meridian Explorer asynchroneous USB DAC via Airplay. All settings are fine, there is just no sound.

Great news! Thanks a lot for all your efforts.

I vote for:
Secured hotspot.
Pwd: Volumionetwork

Best regards

Just updated on my PI2 via test mode and wanted to share some thoughts on the new version. btw i love the new browser! i used mpdroid for a long time with volumio1 but with the new update i hardly miss it.


  • The Bug where many labels are shown incorrectly and the appearance options are broken is back (e.g. the tabs are labelled as COMMON.TAB_BROWSE …)


  • default startup volume is set to 50 but it starts up with 100 (mixer control=pcm, same problem in previous versions)


  • can`t connect via ssh (“the operation attempted to access data outside the valid range”,“end of io stream read”)
  • my static ip preferences are omitted by volumio for wireless network


  • i strongly recommend to secure the hotspot, preferred ssid and pw would be volumio2

which language do you use ? French I guess…In this case we saw the problem and should be solved soon…
For mpdroid it is due to the fact that mpd emulation is not finished yet.
Ssh access : do try to connect with volumio as user ? (ssh volumio@IP ) password volumio ?
Have you seen in network tab new options to secure the hotspot ?

Language is set to English, i just tried switching to german and french, then back to english. but the labeling bug stays.

i use “volumio” as user and password for ssh but i get no connection. tried different devices and clients also. even when connected to the volumio hotspot the problem occurs

After i deleted the user data, ssh works again. also the labeling bug is gone… but as soon as i change something in the appearence options (e.g. background color to black) and reload the page … the labeling is messed up again and the appearance page is broken - but ssh still works :slight_smile:

also static ip now seems to work just fine, but default startup volume is still not working

Hi all,

Firstly, thanks so much for all your hard work on Volumio, truly an excellent product.

Flashed clean image of .991 on a Raspberry Pi 1.

Didn’t detect my NAS during search whilst adding new drive in network drives, but able to add it manually without problem.

Wireless speed only shows as 1Mb/s using LB-LINK BL-WN151 USB adapter, correct speed displayed in Volumio 1 & up to beta .928.

Everything else I’ve tried so far works correctly on Windows/Android :slight_smile:

I’m experiencing the same issue as ekildog, after the update the ssh connection fails with “Connection reset by” or “Connection closed by”. This was reproducible with both my RPis. After deleting the user data I am able to log in via ssh as well.

I just set up Volumio with the 0.991 version and found the following bugs:
[Raspberry Pi 3 + IQaudIO Pi-DigiAmp+]

Network Settings
It is still tricky to get the wireless connection up and working.

  1. After connecting to my wi-fi there is no automatic update of the page.
    If I for example go to the Browse Tab and then back to Network Settings then the network information gets updated. That means that the Hotspot connection disappears and the Wireless shows up, sometimes it is only the Wireless connections that are shown despite the fact that the LAN cable is still connected. Most of the time I get both, the wireless and the wired connection are displayed.
  1. Disconnecting the LAN cable is not that straight forward
    After setting up the wireless it works with my iPhone. All well, but:
    i) If I just disconnect the LAN cable I loose the wireless connection.
    ii) If I turn off the system from Volumio by using power off and turn it on again I loose the wireless configuration I just set up. (performing a full reboot).
    iii) If I restart the system from Volumio then the wireless connection works afterwards. To me it seems like I have to restart the system in order to get the wireless connection working. (just a software restart)

Note: The LAN cable is still connected at this moment.

In order to disconnect the LAN cable I had to do the following:
iv) Power off the system from Volumio. Disconnect the cable.
v) Start up the system again.

Now it works, I have a wireless connection and no LAN cable is connected.

Playback Options
Changing the default startup volume does not work.

I would like to set the startup volume to less than 100 since I have an amplifier not a DAC. So I went to the Volume Options and set it to 25. But the volume is still at 100 after startup, i.e. after restart and power off and power on it always gets back to 100.

I really love the new feature with albums/artists/genres on the Browser tab.

Best Regards,

On my side it seems like I’ve lost ssh access…

OpenSSH_6.7p1 Debian-5+deb8u3, OpenSSL 1.0.1t 3 May 2016 debug1: Reading configuration data /etc/ssh/ssh_config debug1: /etc/ssh/ssh_config line 19: Applying options for * debug1: Connecting to [] port 22. debug1: Connection established. debug1: permanently_set_uid: 0/0 debug1: key_load_public: No such file or directory debug1: identity file /root/.ssh/id_rsa type -1 debug1: key_load_public: No such file or directory debug1: identity file /root/.ssh/id_rsa-cert type -1 debug1: key_load_public: No such file or directory debug1: identity file /root/.ssh/id_dsa type -1 debug1: key_load_public: No such file or directory debug1: identity file /root/.ssh/id_dsa-cert type -1 debug1: key_load_public: No such file or directory debug1: identity file /root/.ssh/id_ecdsa type -1 debug1: key_load_public: No such file or directory debug1: identity file /root/.ssh/id_ecdsa-cert type -1 debug1: key_load_public: No such file or directory debug1: identity file /root/.ssh/id_ed25519 type -1 debug1: key_load_public: No such file or directory debug1: identity file /root/.ssh/id_ed25519-cert type -1 debug1: Enabling compatibility mode for protocol 2.0 debug1: Local version string SSH-2.0-OpenSSH_6.7p1 Debian-5+deb8u3 debug1: Remote protocol version 2.0, remote software version OpenSSH_6.7p1 Raspbian-5+deb8u3 debug1: match: OpenSSH_6.7p1 Raspbian-5+deb8u3 pat OpenSSH* compat 0x04000000 debug1: SSH2_MSG_KEXINIT sent Read from socket failed: Connection reset by peer

I’ll need to wait until going home to find out what’s going on exactly. Reboot doesn’t fix it.

We made a change, where we renew the SSH keys at first boot… But clearly this goes wrong on update. We will fix it thanks for cooperating.

To solve this on your, you must launch dpkg-reconfigure openssh-server

thanks for reporting

Not sure if I should be testing this, but none of the webradio collections seems to open on my rPiB, will try to reflash using an rPi2B (and íf it gets delivered tomorrow the rPi3B).

Also, for the first time, my library wouldn’t load normally, I had to rescan to have it all indexed. But I will check if that occurs everytime, or if it was just a glitch. Furthermore the repeat doesn’t seem to work when I play just 1 album, it had stopped after it had finished.

Downloaded and installed the 0.991 version on raspberry pi 3 with hifiberry dacplus. Attaching the NAS and playing from it works fine. Great sound quality. Playing public Webradio stations however still does not work, while this is not a problem at all with version 0.861, the most stable version so far.

Same problem for me, for the first time my music library scanning stalled and i had to manually get it to rescan a few times for everything to get added.

After updating my resolve.conf is basicly empty. This happened on one of my two RPis (wired; eth0) after resetting the user data due to the ssh problem.

[code]volumio@volumio:~$ cat /etc/resolv.conf

Generated by dhcpcd

/etc/resolv.conf.head can replace this line

/etc/resolv.conf.tail can replace this line[/code]

I discovered this after the playback of webstreams failed with

journal gives this:

Sep 27 18:03:23 volumio mpd[598]: curl: curl failed: Could not resolve host: streams.radiobob.de Sep 27 18:03:23 volumio mpd[598]: player: played "http://streams.radiobob.de/bob-live/mp3-192/mediaplayer"

This is an issue I saw occasiionally… Any idea on how to fix it? This is related to the new dhcp client, dhcpcd…

One more thing for tonight. When my two instances are set to different languages I can’t switch between them in the multiroom section. e.g english and german.

Interesting, thanks for reporting…

Fixed NAS mount on boot
Fixed startup volume
Fixed persistence of data when removing power

The problem is indeed in networking settings. If Automatic IP is set to ‘off’ , Volumio elegantly updates resolv.conf and dhcpcd.conf. But it also changes /etc/network/interfaces . Manually editing /etc/network/interfaces with:

allow-hotplug eth0

iface eth0 inet manual

auto eth0
iface eth0 inet static
address 192.168.1.xxx
gateway 192.168.1.xxx
dns-nameservers 192.168.1.xxx

solves the problem! Public radio stations are working fine now.