[Closed] Volumio 2.0 Final Release is near - Pre-test needed

So, on static IP you can’t play webradios ? (aka no internet connection?)

@michelangelo I don’t think he tried to play webradio without an internet connection. What wim refered to was usign static instead of dynamic IP for the Raspberry Pi which only affects how it gets its IP address.

Sorry I did not explain that properly:
so you can’t connect to internet (the resolv.conf issue) on dhcp, but if you set to static IP you can?

The question is probably targeted at wim but I didn’t try static IP as DHCP did work except for the resolv.conf. Editing the resolv.conf manually fixes the problem until the next reboot when it gets overwritten by dhcpcd, which is expected. The question is why doesn’t dhcpcd set up resolv.conf correctly. I am still investigating, but so far I don’t have a clue what’s going wrong.

Ok, yes this is what I’m interested in understand. I saw this behaviour occasionally. Sure its dhcpcd 's fault, if you could help me fix that it would be fantastic

A fix could be adding the file /etc/resolv.conf.head with google’s DNS . This way we’re at least sure that we can connect to internet. The issue here is it won’t resolve addresses in local network (so won’t be able to resolve Windows nas domain names…)

As I’m at work I can’t check myself, but does Volumio use resolvconf to manage resolv.conf or only dhcpcd?

Resolv.conf is used by volumio, and dhcpcd rewrites it with the router settings. The issue is that sometimes it forgets to add proper router\dns informations.
I made the /etc/resolv.conf.head fix, I will prepare an image, so you can update and tell me if that works or not…


Did some quick testing, had some major issues :nerd: :

1.) When i play this webradio (streams.fluxfm.de/live/mp3-320/audio/), the play-button does not change to the stop button and playback also cant be stopped. 2.) When i change a webradio station, the station information on the screen still shows the information of the former station. Refresh of the site doesnt fix it.
3.) Airplay doesn`t work at all. The LED of the Hifiberry DAC+ even turns off when i try to use Airplay.

Raspberry Pi 2 Model B and Hifiberry DAC+

Hi, i have a raspberry pi with hifiberry dac that do a great job with Volumio 1.55 and other distribution.
I want to try this test version but when i activate the I2s and “Hifiberry DAC” and restart the system, this action broke the system to correctly start up.
When i connect to the hdmi port it will display:

what can i do? sorry for the poor english


Edit: volumio 2.0 0.976 works fine after deleted background images

How did you restart the system? By removing power?

absolutely not! restarted from the webui.
I have tried 3 times (reinstallation of sd card) and same issue.

Works fine with 0.976

In this one we changed the swap amount, probably its not enough.
Thanks for reporting

Raspberry Pi 0.991-2016-09-24 Version

Problem with playing one big .flac file with .cue index. In the album folder Volumio dispays .flac file, .cue file and all the songs as it described in .cue file. For exmple:

  • whole file name.flac
  • whole file name.cue
  • song 1 name (whole file name.cue)
  • song 2 name (whole file name.cue)
  • song 3 name (whole file name.cue)
  1. For first two positions (“whole file name.flac” and “whole file name.cue”) all options are available (“Play”, “Add to queue”, “Clear and play” and so on). Separate songs have only two options (“Play”, “Clear and play”), where second option does not work (nothing happens when I select it).

  2. When I play “whole file name.cue” all the songs are added into queue and all of them can be played by clicking on it or by navigating with Back/Forward buttons, but:
    2.1. when one song is finished and next song starts to play, new track information does not appear on the “Playback” tab, It continues to display an info (Name, Length, …) for first track played. You may listen all the album but the first track info will be shown on the “Playback” tab.
    2.2. navigating through the track (seek bar) works incorrectly. I click on some time position and It starts to play from absolutely uncertain position (in most cases another track will be selected and played).

P.S. Sorry for my english, I’m not a native speaker.

What can i do? Waiting a new test version?

Inviato dal mio iPad utilizzando Tapatalk

Running on rpi1 model B.

volumio-0.994-2016-09-29: Fresh flash: Boots, it’s almost impossible to connect to webserver. In the best case you get to see the grey/black background, most of the time it times out. It is possible to SSH in, I see a CPU load of 4+, mainly caused by node. After a few minutes SSH becomes unresponsive (but I can still ping the host) and I have to reboot. Also no swap configured?

volumio-0.993-2016-09-28: Fresh flash: same issues as wit 0.994, even higher CPU load 8+.

volumio-0.992-2016-09-28: Fresh flash: same as 0.993 and 4

volumio-0.991-2016-09-24: Fresh flash: Swap present. Starts with high CPU load, but after a few minutes it calms down to <0.2. Everything works.

[code]top - 11:20:35 up 4 min, 1 user, load average: 8.60, 4.25, 1.72
Tasks: 110 total, 1 running, 109 sleeping, 0 stopped, 0 zombie
%Cpu(s): 57.4 us, 38.6 sy, 0.0 ni, 0.0 id, 0.0 wa, 0.0 hi, 4.1 si, 0.0 st
KiB Mem: 493844 total, 489292 used, 4552 free, 2120 buffers
KiB Swap: 0 total, 0 used, 0 free. 13696 cached Mem

560 volumio 20 0 509268 354396 3040 S 44.6 71.8 1:11.09 node
1331 root 20 0 7720 5652 2840 S 19.0 1.1 0:01.94 addgroup
70 root 20 0 0 0 0 S 7.2 0.0 0:08.79 mmcqd/0
1348 root 20 0 3296 1996 1816 D 3.3 0.4 0:00.11 groupadd
19 root 20 0 0 0 0 S 2.7 0.0 0:02.27 kswapd0
140 root 20 0 0 0 0 D 2.7 0.0 0:02.66 jbd2/mmcblk0p3-
561 root 20 0 1760 364 296 D 2.4 0.1 0:02.42 dd
109 root 0 -20 0 0 0 S 1.8 0.0 0:02.24 loop0
722 volumio 20 0 3584 1292 768 R 1.8 0.3 0:03.31 top
3 root 20 0 0 0 0 S 0.9 0.0 0:01.38 ksoftirqd/0
715 volumio 20 0 12112 1236 536 S 0.6 0.3 0:01.16 sshd
1103 volumio 20 0 88204 2552 1660 S 0.6 0.5 0:00.80 upmpdcli
609 ntp 20 0 5680 1036 620 S 0.3 0.2 0:00.32 ntpd
1058 root 20 0 0 0 0 S 0.3 0.0 0:00.12 kworker/0:3
1 root 20 0 5380 1716 500 S 0.0 0.3 0:14.25 systemd
2 root 20 0 0 0 0 S 0.0 0.0 0:00.00 kthreadd [/code]

Edit: Hardware volume control still not working. In previous versions the dropdown menu was empty. Now it says “Digital”. When I click on the dropdown menu, it completely disappears until I click it again. So I don’t know if there are other options to choose from. Happens on both Chromium and Firefox on Ubuntu 16.04.

I’m not sure if this is related, audio is playing fine though:

[ 11.500646] snd-hifiberry-dac soc:sound: ASoC: CPU DAI (null) not registered [ 11.509579] snd-hifiberry-dac soc:sound: snd_soc_register_card() failed: -517 [ 11.684496] snd-hifiberry-dac soc:sound: pcm5102a-hifi <-> 20203000.i2s mapping ok

Browsing webradio is all working, except “By genre (Shoutcast)”.

Edit2: I can successful upgrade to 0.994 through the webgui. Swap is present and load settles at <0.2. Other problems are still present.

Ok, it seems that swap updates are a regression. I will make another build removing this, I will post the new image link here


Here it is:
updates.volumio.org/pi/volumio/0 … pi.img.zip

Testing as we speak

I just flashed 0.995, swap is still not present:

volumio@volumio:~$ free
             total       used       free     shared    buffers     cached
Mem:        493844     484952       8892       4760      81472     277396
-/+ buffers/cache:     126084     367760
Swap:            0          0          0

.995: Ethernet socket gets lost at boot. When it is present, nothing appears in my browser.

I’m probably the only one with this shit.