Cannot find plugins

Volumio 3 Issues?

I’m stuck. I have installed Volumio with GNU bash version 5.0.3(1) on my new Raspberry Pi 5 with HiFiBerry Digi+ HAT. I’m using the pi5 over wifi. I’m trying to connect my QNAP NAS where my flac file repository is. However, I have a few issues.

  1. When I try to install plugins it says I need to log into My Volumio. However, I am logged in from my PC - using the free plan. When I look at my page, the list of devices to activate is empty - I suspect this is an issue. How can I find my davice here?
  2. When connecting to my NAS I’m uncertain what info to set in NAS IP and path, and whether to use cifs or nsf as file share type.

Any input reg. these issues would be greatly appreciated.

A few things:

  • Which verison of volumio are your running, don’t say the latest.
  • Enable SSH Open a terminal command and type date, make sure this is accurate
  • All all the endpoints reachable? type volumio endpointstest and paste the results here
  • Finally post a log

no need to do this, the endpoint test is included in the system log

Log file:
Volumio: version 3.0

I enabled SSH, access via terminal and do endpointstest:

volumio@cwvolumio:~$ volumio endpointstest
TESTING REMOTE ENDPOINTS, 1549 ms: OK, 348 ms: OK, 370 ms: OK, 715 ms: OK, 716 ms: OK, 1044 ms: OK, 1208 ms: OK, 1411 ms: OK, 1390 ms: OK, 1026 ms: OK, 1718 ms: OK, 1544 ms: OK, 1061 ms: OK

REMOTE ENDPOINTS TEST OK, all Endpoints are reachable

Funny thing is, on first attempt I managed to install one plugin “FusionDSP 1.0.53”, but since then it’s like it doesn’t recognize I’m in fact logged in to the Volumio free plan:

There are a lot of errors in your log.
Please do a factory reset first.
After initial setup, check if the system date is correct.
Log out from myvolumio and reboot and log in again.

Thanks for advise :slight_smile:
I did all that - checking date - it has Tue Feb 13 18:41:00 CET 2024 ! It’s 10 days behind reality!
Well, I’m a total Linux noob, but googling let me to set system daettime to current, and to also set hwclock to system datetime, so all should be fine now.
Rebooting now, Will get back in 5 mins

Because the date is off, you ran into issue.
Please have a look at my post here:

sudo nano /lib/systemd/system/setdatetime.service


Description=Set local time using time server

ExecStart=/bin/bash -c "sleep 30; /usr/bin/sudo /bin/date -s \"$(/usr/bin/curl -s --head | grep ^Date: | sed 's/Date: //g')\""


ctrl+o => enter => ctrl+x

sudo chmod 644 /lib/systemd/system/setdatetime.service && sudo systemctl daemon-reload && sudo systemctl enable setdatetime.service && sudo systemctl start setdatetime.service

I SSH into the pi now, updated software and am installing plugins - works like a breeze :slight_smile: I set the system datetime to current datetime, and the hwclock to equal system datetime - so will I need to run the script to synch to time server?

If you have a rPi with HW-clock (rPi5 or a external clock < rpi5), yes. Since your date is way off I doubt you have it.
You should follow my instructions above, so it will be updated on every boot.

Sorry, I don’t quite understand: I do have a Pi5, and when I type “hwclock” it now gives me the correct datetime. It’s my understand it has a small onboard battery to keep hwclock always alive.

So, do you maintain I need to run the script on every boot?

Btw: I have now installed quite a few plugins and added my NAS, which it now finds just like a charm. What a pleasure :slight_smile: And thank you for your great help!

1 Like

You missed too tell it’s a rPi5.
Then when the date and time is correct run the command:
sudo hwclock -w

And it should stick after reboot, as long as the battery is full.