BeagleBone+Botic (Miero) Update new VOLUMIO

Michelangelo, good afternoon!
I really want to use your new version of Volumio.
Please update the version for beaglebon + botic
Thank you very much

Hi guys! Try my work
This makes a completely working image for the BBB.
Also added: Access Point on RTL8188 and RTL8192 chipset, Small SPI display 320X480 and resistive touchpad, Lirc_BBB,
and more…

Dear Tigor888,
I’m just new to *nix. I have an old laptop and Ubuntu 16.04
Can you give a clear instruction on how to build an image for BBB, or give a link to the working image?

@tigor888: super job, care to check it in to our repo?
Please PM Michelangelo or me for details.

Hi Tigor888!
Can you upload a completely-build image for BeagleBone (Botic Miero) to test it :slight_smile: ?

Correct me if I’m wrong, but isn’t Volumio v2 already working on the BBB with the Botic driver? Or is this a newer release?

See this link

@Barrymore - I’m not sure if you’re aware of this thread on DIYaudio… … river.html
somewhere in the thread are images presented by Michelangelo…

and if you look here…

There’s a link back to the main Volumio page. Thus my confusion about this. What I’m saying is that the v2 version of Volumio has included the Botic driver for a while.

Ok looks like we’re way behind on the BBB…

Anyone know how to build this on Mac OSX?


Sorry for clogging up this thread… I ended up using a VM of Ubuntu to build this. The only thing that I was unsure of was the architecture - I chose armv7. I’ll test and see if it works within the next day or so.

Thanks @Tigor888!

MacOSX is not supported.
Advice: avoid Ubuntu for building an image.
There are issues with multistrap, but these can be resolved. See the prerequisites on the volumio build repo
Another problem can occur while building the initramfs for Volumio, no one has found a way yet to cure this.
In case you want to build reliably, use Debian jessie.

Please explain if it will be necessary to add two lines into mpd.conf Volumio BeagleBone+Botic? I don’t need DSD at all!

 priority        "FIFO:32"
 period_time     "1"

Why are you quoting my post for a question that has no relation?
Not answering thisI

Sorry for inconvenience, please clarify if it is a really hard question - priority “FIFO:32” and period_time “1” ?
And please clarify why isn’t any image for Beaglebone black on download webpage now ?
Thank you in advanсe for the answers!

@Barrymore See the explanation here

@Barrymore I think those questions are better directed at Miero on being that they are Botic settings vs. Volumio settings.

I tried building an image with both Ubuntu and Debian and neither worked. Must be doing something wrong here. I tried it with the Armv7 architecture. Maybe I need Armv8 instead?

Any help would be appreciated.

Yup. Used latest Debian - Stretch… didn’t work. I couldn’t get a hold of Jessie or didn’t know the right version for a VM using Parallels on Mac.

Images created with both Stretch and Ubuntu do the same thing… all 4 blue LEDs light up, then the first and last LED, and then they go off and that’s it. No heartbeat on 1st LED and solid 2nd LED.

I’m going to try and get a hold of the right version of Debian Jessie to see if that works…

Ok… finally got it to work. Maybe it’s my newbiness with Linux or my lack of following exactly gkkpch suggested… only using Debian Jessie worked. Not sure why Stretch wouldn’t work. My guess is the build process uses the host system - my VM - to do the build?

As for Ubuntu not working:

  • if on Ubuntu, you may need to remove $forceyes from line 989 of /usr/sbin/multistrap

When I looked on line 989 I didn’t see $forceyes in multistrap I didn’t find anything there. Maybe my version of Ubuntu has a new version? Either way Ubuntu 16.04.4 didn’t work.

Is there a way to find out what the latest version or current version of Volumio is so one can embed it into their build?

Ubuntu is not good for audio (poor sound quality). I don’t known why Moderator is still calm?

@Barrymore: if you have no clue what we are talking about, then better keep silent.
We were not discussing audio for Ubuntu here, just the platform on which one can built Volumio and it is (unfortunately) difficult to do this on any other platform than debian jessie.
So please quit the ubuntu and audio thing, it has nothing to do with the discussion.
You quote something, then ask a totally unrelated question, you make statements about things that were not discussed. Please stop spamming this thread.

— Gé —