Adding Tidal Connect

sorry, did not know/ you did not refer to a payed account, in this case, please refer to "info at " for dedicated support.

The test version (v2.904) with the new alsa backend can be downloaded by enabling test mode on http://{your_volumio_address}/dev. Please do not update if you are not experiecing issues with the current stable version. Also, if you have enabled software mixer before as a workaround, please set it on hardware.

Random drop outs (which are solved by pressing next / previous) are mostly network / internet related. There also seem to be some capacity problems during peak hours on tidal infrastructure. We are talking to them about that.

Using a Rpi 3, Volumio ver. 2.907, through an Allo Boss Dac, controlled with an iPhone, Tidal connect has been working really well. To be honest, I feel like I’ve been neglecting the rest of the software in favor of it.

I can trip it Tidal Connect if I continuously switch from connect to a “Local” Volumio source like my library or Qobuz and back but usually a restart of the Tidal app clears that up and it doesn’t fail consistently enough for me to call it a bug. Mark that one as user error.

There is one slight bug that I have noticed though. The “play next” feature simply will not work. I generally listen to my whole favorites list on shuffle while looking up other songs. I use the play next feature to hear a song without disturbing the shuffled queue in Tidal. Through Connect, Play Next does nothing. I have no idea if this would be on Tidal’s end or on yours. It’s in no way a deal breaker, Tidal Connect gets the most use by far than any other Volumio Service currently, but it does annoy me a little bit.


I’m facing the same issue on v 2.907 on my futro:

No issues with volumio tidal integration, it happens only with tidal connect.

When it happens i need to skip the track that is currently stuck.

as per volumio web interface, the next song seems properly retrieved but the seek is already at its end ( sometimes at half )

Please let me know If any further detail is required



Edit: screenshots link

Was TC with Pi zero ever resolved? It’s not working for me.

There is a new version of tidal connect released in volumio 2.909. This should fix the crash some people were having on sample rate changes on certain devices.

If you were encountering these issues, please update to volumio 2.909 and let us know if it solved your issue.

1 Like

Hi Mervinio,

Unluckily still facing the issue on v 2.909 ( x86 - Futro S900 )

i just replicated it and extracted fresh logs: ( time stamp: 7:10 PM - 7:20 PM CEST 14/09/21 ).

Here a video:

When the MQA song by CSI ends, the player tries to play the “next song” but the seek is already started.

The Tidal app seems stuck:

If i press the “next” button and then the “back” back one, the track would be properly played but the playlist stops again when the track quality changes ( MQA → NO MQA o viceversa)


Please let me know if i can help with any additional info / data.

Really thanks for your efforts and your amazing work!


Hi Luca, it seems that the version of tidal connect you are using is not the latest. I know this because the logs have changed in the latest version. Please re-check if you are on 2.909. If you are on the latest version than something went wrong with the update. This can happen if files are changed in your filesystem, prior to the upgrade. Best solution is to do a factory reset.

Just to be sure i will check tomorrow if the x86 version of tidal connect was properly added to the latest image.

1 Like

Hi Mervinio,

Really thanks for your insights.

I wiped my usb drive and reinstalled the 2.909 and… wow, it finally works!

Probably something went wrong with the update. Quite strange as i edited only the triggerhappy conf file.

I tried this steps with the previous version with no luck in the past.

Thanks again;


Not aware that this has been looked at yet, AFAIK it isn’t yet working on Pi Zero.

Just updated to 2.909, and can confirm that what I call the “spinning circle of death” is still present for me.

This is when the Tidal app shows a spinning circle where the Play/Pause button in, and usually skipping forward or back a track fixes things. (And this is just within a regular album. So in my case has nothing to do with bitrate or MQA changes.)

Also, has anyone gotten accented characters to show up? I’m currently listening to Swedish band Night Crowned album Hädanfärd, and every other song has accented characters in the title. None of them show up on the hdmi out display, nor when accessing volumio.local from a PC, or from the android app.

1 Like

Hi there, I have run into problems with TC too.
It has worked, until recently. TC just didn’t start the track. endless waiting (spinning circle…)
I decided to upgrade to 2909.
No luck.
In the /dev/ log I read this:

info: Tunnel connection is inactive, restarting it
info: Starting Tunnel 1
info: Starting Tunnel Connection Checker
volumio : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/systemctl restart sshtunnel.service
pam_unix(sudo:session): session opened for user root by (uid=0)
Starting MyVolumio SSH Tunnel…
Started MyVolumio SSH Tunnel.
pam_unix(sudo:session): session closed for user root
port set to 0, monitoring disabled
starting ssh (count 1)
ssh child pid is 2984
info: Remote SSH Started
ssh: connect to host port 2222: Connection refused
ssh exited prematurely with status 255; autossh exiting
info: CoreCommandRouter::volumioGetState
sshtunnel.service holdoff time over, scheduling restart.
Stopping MyVolumio SSH Tunnel…
… this get repeated lots of times.

Any ideas on how to proceed?

btw, I did completely reinstalled Volumio. Even etched it as new on the SD card. Using Rpi3+ with Allo DigiOne.

OK. Fail…
Volumio somehow got assigned a new access profile by my router, which by default prevents internet access. That explains the connection refused message.

After that: Music!

Sorry for bothering you guys. I’ll leave my post here for archive purpose so other can be hinted when experiencing the same problems.

Aha! Can you tell us what router you have? this could be very useuful for other people with the same router

Sure. I have a fritzbox (5530, but most use the same FritzOS).
By default new wifi clients get full access but I have configured it otherwise so new clients only can surf and email, other protocols prohibited. Therefore, the SSH tunnel was not connecting…


Same situation: Some tracks hang (spinning/buffering circle). It can happen constantly (15 or 20 times an hour) or not at all. There seems to be no issue playing Tidal music through the Volumio app, just in the Tidal app using Tidal Connect. I’ve tried all the voodoo I can think, but it still happens.

Using a RPi 3B+, Allo Boss 1.2 DAC, Volumio 2.909

Thanks for the report guys. Please send logs so we can understand what happens in your case

Wow 2.909 works great, thanks for the update :+1:

How far are you with a fix for Tidal Connect on the Rpi0?

@Mikkel The Raspberry Pi Foundation have just released the RPi Zero 2, I’ve just ordered one which should arrive tomorrow, so I’ll give that a try. I’m not particularly technical, but it sounds like the Zero 2 has replaced the old SOC with a SIP (which combines the SOC from the Pi3 and the ram) so I’m hopeful that TC will run.

I’ll write back once I’ve given it a go.

1 Like

I still have this problem:
Volumio Virtuso (up to date)/TIDAL/RME Adi 2 dac/Android Tablet or Googlge Pix 6

TIDAL works and plays but in different intervals, it stops working and a “spinner” is shown in TIDAL. Sometimes it is possible to move to the next track. t

I have absolutely no problem to stream with M-Connect to Volumio.

What can I do?