Youtube plug-in playback button issue

I have been having problems with youtube plug-ins on volume 3 updated to the latest release for a few days. The problem is not related to the update because I hoped that the update would fix it.

The behavior is very strange, in addition to no longer having the original fluidity of when it worked well, when I press the play button from any Windows/apple/android device the playback does not start, if instead I go to the touchscreen of my PI4 and press the relative play button the song starts regularly…

Needless to reiterate that I have uninstalled and reinstalled the plug-ins several times, but the result does not change.
Do you have any ideas, does this happen to you too?


1 Like

@patrickkfkan can you take a look at this.

Updated the version to 3.502. Youtube plugins stopped working on two Raspberry Pi 4.

1 Like

@Wide, I cannot reproduce this on v3.449, so logs would be useful in this case.

@Andron66 , is v3.502 a beta release? If so, then I’d wait for a stable release before investigating any issues.

I can confirm the problem, Youtube2 does not work anymore on 3.502

:roll_eyes: Oh, no…


It is a regression in v3.502 caused by the following change in /app/plugins/music_service/mpd/lib/mpd.js:

MpdClient.prototype.sendCommand = function (command, callback) {
  var safeCommand = command.toString().replace(/\n|\r\n|\r/g, '');
  self.sendWithCallback(safeCommand, callback);

The change breaks sendCommands() in the same file:

MpdClient.prototype.sendCommands = function (commandList, callback) {
  var fullCmd = 'command_list_begin\n' + commandList.join('\n') + '\ncommand_list_end';
  this.sendCommand(fullCmd, callback || noop.bind(this));

So in sendCommands() you create a Command List for MPD, which is a string composed of commands separated by a newline character. The string is then passed to sendCommand() for execution by MPD, but here you remove the added newline characters, thus effectively breaking the Command List.

This not only affects the YouTube2 plugin, but also other plugins that send command arrays via the MPD plugin.

@volumio, please fix this regression.


Thak you…
Now we hope in a very quick reaction by Volumio.

Thank you again :slightly_smiling_face:

same problem on x86, I wonder when it will be solved

Thanks for reporting, we will fix this in the next stable release (3.502 is a beta…)

Thank you volume

Just a question. Does Volumio automatically update the release even if it’s not a stable version? Because, as I have already written, I did the update because I was trying to solve the problem, even before the last installation of 3.502.

the system will show you available beta updates only if you set “test mode” under dev page

Ver.3.505 plugin work


Great news! I tried and and now YouTube plug-ins work fine.

1 Like