Yet another Wifi help request

G’day guys and girls,

I’ve been reading through this forum and posts about Wifi being a major pain in the bum-bum to install, and, well, it is, so, I’m looking for some guidance.

I installed Volumio 2.latest on an SD card for a Pi3. Bootup and wired network work pretty well, but my main use is through a Wifi network in the main listening area. I don’t have access to a Wifi dongle at the moment, and, I know Wifi works because I’ve been using the “other” audio player for months without issues.

At the moment, my Pi3 is working with a wired network, all static addresses, and mounting an NFS share was a breeze. I’m still to connect the DAC (an Amanero USB based board), but first I need to solve the Wifi issue.

Volumio seems to recognize the Wifi network, and store the static IP address. Whenever I’m wired, I can ping both wired and wireless addresses. The moment I unplug the Ethernet cable, I get nothing on both networks. On reboot, I get the wired network interface, but never the wireless. I’ve tried changing /etc/network/interfaces to no avail. I’m running the latest Volumio image downloaded yesterday on a RPi3.

Any ideas? Has anyone managed to get it all working nice and easy (or at least nice) so far? Happy to provide more information or run a few experiments.



My issue was solved by downloading the latest version and flashing that again. I’m not sure whether there was a real update in between.

Well, I can definitively say that yes it does work with the RPi3 onboard wireless (in my case). I would avoid tinkering with the /etc/network/interfaces file & leave that as the default. I simply connected to the appropriate network ssid through the Volumio UI, and everything was ‘hunky dory.’ Having said all that, I am aware that others are experiencing problems … posted just to let you know that it can work… we need to know why it doesn’t in all cases.

If you are able to view the output of

sudo journalctl -b

and the contents of /var/log/volumio.log, either by logging in by ssh or directly through a keyboard and monitor, then you may find related error messages.

Thanks guys,

I have the latest version, and I haven’t planned tinkering with /etc/network/interfaces. Would love to make it work out of the box. I’ll see if I can get a HDMI monitor and do a mouse/keyboard session. At the moment it’s all through Ethernet / SSH.



Little update.

Did the factory reset and connected no problems through the hot spot. Changed the network settings of the wireless to connect to the home wifi, and it worked. Added static IP and it still worked.

Now, after a reboot, I can’t reach it. Will have to disconnect from here to see if the hotspot is available.



Alright, got it working, here my summary so far.

Raspberry Pi 3 with onboard wireless interface powered with an external power supply over GPIO pins.

Did a factory reset at some point. Went and connected through the Hotspot, and with that, I set volumio’s wifi interface to DHCP and connected it to the wifi router. At no point in time was the ethernet cable connected. The wireless interface was set up as DHCP, so I used the wifi router to get the assigned address. After a reboot, wifi worked fine… yeeey!

Set the IP to static. Reboot. Ping, it’s there… yeeey! Now, set up the NAS (NFS). Not reachable. SSH into volumio and ping the NAS. Nothing. Ping the wifi router, it’s there. At this point I’m SSH’ing into volumio from my laptop over the wireless interface which is still working. But volumio can’t reach the NAS. My laptop can.

So, what’s wrong? Tuns out that my NAS and desktop PC’s are connected over a wireless bridge to the main (internet router). That works fine, however, for some unexpected and unknown reason, volumio was not able to cross the wireless bridge to the other side, even though it’s the same subnet. I tried everything from NC to UDP to whatnot. I decided then to reboot volumio and leave the wifi interface as DHCP, with the main router/dhcp server assigning the same IP to volumio based on the MAC. Now, when using DHCP volumio is able to cross the wireless bridge and access the NAS. Connect with NFS and all worked. Final yeey! Download and setup the spotify client, yeeey!

So basically, wifi works out of the box with a few quirks and it’s not too straightforward, but the effort paid off. I’m still wondering why the wireless bridge could not be crossed on a static IP.

Thanks for all your support so far.



Glad you got it sorted :slight_smile: