Yet another problem with SMB shares

I’m having some problems to mount my SMB share of the NAS with volumio:

  • i’ve tried with the GUI, it shows me a green V near the shares but nothing appears in the “Browse - NAS”
  • i’ve tried with this tutorial: mounting-nas-outside-volumio-t2126.html but still nothing
  • i’ve tried to combine the second mode with a symbolic link in /var/lib/mpd/music/NAS/ pointing to the folder in the second step but still nothing…

Other ideas? yes, i’ve also tried to reboot few times :smiley:

Raspberry Pi model B
NAS Intel SS4000-E

this may help you: #p12876. Also check the Guides section. There you find more solutions if this one is not working for you.


i’m sorry but i cannot view the content of the link that you provided me, it shows the main page of the forum, i’m looking in the guides but at the moment i didn’t found a solution

you’'re right, it does not open the post I wrote before (?!?) This is the link to the guide: smb-cifs-shares-volumio-t1461.html
And this is what I wrote from my experience with my CIFS-shares:

"I ran into a problem with mounting a CIFS-mount: everytime I could not see the contents of the disk/partition after mounting it. The update process was finished within a second or so. No files to be seen (strangely I could do a search and then I found the name of a group or album or track, but I could not access any of them).

I checked the mount under /mnt/NAS and saw that the user/group of the mounted directory was “pi” and the permissions were “700” for all directories and “600” for all files. Via grep I saw that this was User ID 1000. I remembered that this is my local User ID on the system where I advertise the CIFS-mount from.
I went to the mount options in the Library settings and clicked on the “show advanced options”. In the options “Mount Flags” I added “,uid=106” at the end (106 is the User ID of mpd in Volumio). After clicking the Save Mount the mount succeeded and the Updating icon started to spin. Now all my music is visible !!! :smiley:"

I hope this may help you … ?