XMOS PCM5102 USB DAC 384k/32b

Hi. I just bought this DAC
When it’s connected to raspberry (I use USB Hub and DAC gets power from it) then it’s recognized (blue led on chassis moves from 44.1k to 384k) but no sound arrives…On Volumio playback page there are two audio output options: X20 and ALSA. I tried both but nothing. Any suggestion? thanks :confused:

…sorry, I made a mistake with amplifier setup. It works.
I tried to set max definition allowed by DAC 384k/32b but the sound is continuously interrupted…I also tried to increase ten time the buffer and its percentage but it’s not enough…is there a way to enjoy max DAC resolution os it a limit of raspberry capability? …thanks

Hi cla68!

Raspberry pi is to weak for tweaking it to the extreme. With PI I would stay at 16/44 and everything is alright.
Anyway I wonder why so many stick with Pi allthough having greater sound ambitions.
There are enough boards available that are much more powerful and have no problems with USB plugging- and they are not sooo expensive.
Look at cubietruck for example- volumio version is planned for it- it has all you need- for about 88 Euros.

Greetingz, robert

Hi Robert, I did not have perception about powerful cpu required to get a conversion 384k/32b. If I am not wrong it means to manage 32 bits, 384.000 times/seconds…11-12 mbps? it doesn’t look tremendous bitrate but probably is too much for raspberry.
I will have a look to cubietruck… thanks :slight_smile:

Hi, I have Udoo quad (so plenty of CPU power) with XMOS PCM5102. Works fine even up to 32bit 384K using X20 and hardware mixer but when turned of (any way) the SD card needs to be rewitten to get it play again or no sound, but all displays work normally. Really frustrating.

You have simply shutting down unplugging the socket, don’t use software ui for reboot or shutdown.

Inviato dal mio SM-N9005 utilizzando Tapatalk