Xduoo XD-05 Help

Hey community! First post, please be gentle :blush:

I really like Volumio thus far, allowing me to use my AVR how I want to use it instead of being limited by its slow speed and lack of an app/interface. Plus the library searching is amazing as well. The only downside is that it won’t work with my Xduoo XD-05, I’m getting a lot of noise out of my sound. Some setup specifics:

Proxmox Host
10 GB storage
1.5 GB RAM
4 Cores
USB port is forwarded in its entirety where I plug in the DAC/AMP

I’m using the line out on the XD-05. When this problem first presented I thought maybe the line out was bad, but I’m hearing the same noise on my headphones as well, so I’m convinced it’s something else.

Useful info:

I followed the guide at https://diyfuturism.com/index.php/2018/05/13/installing-volumio-proxmox-virtual-machine/ to install the Volumio IMG to my VM.

Here are the specifics about the DAC I’m using http://www.xduoo.com/xduoo/En/ProductView.Asp?ID=17

I haven’t the slightest idea as to what to do next. I see a lot of posts of people tweaking various config files, but I have no idea what those tweaks entail. I tried various searches; xmos usb noise volumio, usb dac noise volumio, debian usb dac noise, nothing. I also tried enabling software hardware control to no avail. Halp plox!

Just an update, I thought maybe it was the DAC acting up. Without changing the power source or audio circuit seriously, I popped the DAC onto my Win box and it worked just fine with no noise; that rules out bad hardware, at least as far as the DAC is concerned.

Ok guys, I’ll leave this here for future reference. I solved the problem. It wasn’t a Volumio + XD-05 issue, apparently Proxmox is notorious for having sound issues. Because I was using a USB DAC, I found using this https://pve.proxmox.com/wiki/Pci_passthrough helped me a lot; I found the ID for my USB controller port, inputted it into the vm conf file after enabling passthrough, rebooted the host, and voila! Despite the direct port passthrough, I’m guessing there was still something shady going on in the passthrough. So here we are! All done! I still have occasional “skips” when there’s a bit of network load, I’ll see if buffer options can help me there. So yeah, didn’t need a driver or anything!

BTW my onboard USB is split up as such that one or two ports are on one controller and the rest of the ports are on another, so this worked out to my advantage. Cheers!!