x86 - Installing wifi drivers

I’m trying to run the latest version of Volumio x86 on a Minix Z64 - it boots from the USB without any trouble but no networks are detected. This makes me think that the wifi chip isn’t supported. How would I go about installing the appropriate drivers if I could find them?

I believe this computer contains a Realtek RGN RTL8723BS chip…


On second thoughts, I’d be happy just to buy a known compatible USB adapter if anyone could point me in the right direction. The only one I have is the the official Raspberry Pi dongle, which does not appear to be Volumio compatible on the x86.

Hi James, have you tried the wifi dongle, it should work. Exactly what happens when you try to use it? Can you see any networks at all?

Maybe you can try this driver:
Not sure it will work…


I can’t see any networks.

When using the USB dongle I turn wifi on, click save and then I get a notification saying it has been successful, but if i browse to another page and return to the network settings the toggle will be back to ‘off’.

Weirdly I saw the Volumio hotspot on the list of networks on my Mac when trying to use the built in wifi (though I couldn’t connect to it). This makes no sense to me at all.

A couple of points that may matter - 1. I’m using the HDMI out + a monitor to view Volumio. 2. I’m booting Volumio directly from a USB drive, not the internal HD of the Minix.

Interesting, according to my configuration, the driver for the RTL8723 was selected CONFIG_RTL8723AE=m CONFIG_RTL8723BE=m
In case your chip is a different version, i’m curious to know which one it is.
Could you do upload a log after booting? Perhaps it will show us more detail.
For that you need to go to the dev page ( /dev) and use the upload function.
I need the url you get from the upload.

Yes, you have an rtl8723bs and the kernel does not support that out of the box.
Unless you compile and install the driver (see kkwete’s link), you would need a usb dongle for the time being.
Our new kernel (4.9.29, not released yet) does not have support either, though it seems 8723BS support is available upstream.
Perhaps it can be backported.

Edit: Actually, I’m checking the possibility to use 4.12
It has better support for the Atom SoC, perhaps audio support has been improved as well.

This is an odd development.

I connected the minix to my router via ethernet in order to get the log, but it would not connect (no sign of it in my router’s device list, multiple ethernet cables used). This makes me think that somehow networking is disabled entirely, especially since the official RPi dongle should work out of the box right?

Normally I would ssh to Volumio to try and solve this, but this is obviously not an option. Is there any way to access a terminal when working with Volumio locally?

I think compiling drivers is probably beyond me, to be honest. I’m happy using a USB dongle for now.

crtl-alt-F1 should get you a terminal

1 Like

How do I list the network interfaces from the terminal? I thought lspci -v would do it but I get ‘command not found’

Edit: I entered “ip link show” and it returned the following…
(excuse any typos as this was typed manually)

1: lo: <LOOPBACK.UP.LOWER_UP> ntu 65536 qdisc noqueue state UNKNOWN node DEFAULT group default
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0 <NO-CARRIER.BROADCAST.MULTICAST.UP> ntu 1500 qdisc pfifo_fast state DOWN node DEFAULT group default qlen 1000

Is there anything there to go on?

1 Like

I found an old Sitecom wifi dongle and it seems to work out of the box. It’s possible that my Pi adapter was a dud (though it was in use until quite recently).

Is it worth me keeping an eye on future compatibility with the RTL8723BS or is this unlikely to happen?

Thanks for your help.

you probably have to use

sudo lspci -v 

As for rtl8723bs, I’m working on it…

1 Like

does it not say "link/ether " as a second line for eth0?

Also do:

lsmod dmesg | grep eth0
and check if it shows you what module was used

If you want I can help you to compile the driver, you’ll see, it’s easy!
I’ve near the same driver (rtl8821ae) on my laptop with xubuntu 64 and it’s really easy to install.

1 Like

Unfortunately it’s not that easy, believe me.
Copying an r8732bs.ko from the net (as suggested at some sites), not knowing for which kernel it was compiled for, is a waste of time.
The driver cannot work on 3.18.25 (as it is using interfaces which 3.18 does not support).
I tried compiling it with kernel 4.9.29 and did not work there for the same reasons.
The good news: I’m building an x86 version with kernel 4.12.8 at the moment, which has rtl8732bs integrated and seems to be ok.
When testing Volumio appears to be successful, then we will drop 4.9.29 for 4.12.8

Hi, I jumped in while I was trying to compile the driver for my thunderbolt3-ethernet adapter (owc t3 10g)
It uses ethernet controller Aquantia AQC-107S.
I am not able to successfully build the driver.
It says like
" make -j4 -C /lib/modules/5.10.95-volumio/build M="/home/volumio/Marvell_Linux_2.4.15/Linux" modules
make[1]: Entering directory ‘/lib/modules/5.10.95-volumio/build’
make[1]: *** No rule to make target ‘modules’. Stop.
make[1]: Leaving directory ‘/lib/modules/5.10.95-volumio/build’
make: *** [Makefile:36: all] Error 2"

What can I do for this situation?.. Should I wait for the driver added to volumio x86 release in future?

Obviously you are following some sort of script, but don’t really know what you are doing. Always a bad idea :wink:
Open a new topic in X86 Hardware issues (WiFi, DAC, Disks, Boot etc.) because your request has nothing to do with wireless drivers.
Mention that you need an x86 kernel module for the aQuantia AQtion NIC driver, which is currently unselected in the configuration file. Hopefully someone will pick this up, but it will take a while as there is no x86 kernel support at the moment.