X86 Hardware issues (WiFi, DAC, Disks, Boot etc.)

Just format the SSD, connect it back to the Dell, boot from USB and flash the SSD via the side menu => System.

I will try. Thank you.

But …

Is it because target drive is smaller than img ??

I will try start Volumio with smaller USB and after that try one more time.

Another post outside the x86 topics, I wonder why members like @eMCZe think they get anywhere without searching the forum.

Suggest: read the first post in X86 Hardware issues (WiFi, DAC, Disks, Boot etc.)

and supply the info from there.
No log, no support.

I will tell you. I start to build this streamer on DELL workstation and started thread. My question was “by the way”. I didn’t create this topic to seek help. I intended to solve this problem using a home server.

But I would like to inform you that I will not ask any more questions “by the way” topic, I will only ask them where they are necessary so that you can rest assured that everything is in order.

I’m sorry if you took this as a form of mess or lack of good will from my side,

I don’t understand why you close my DIY topic in time when in my workshop I started to build wooden case for this Volumio. It is the reason why I put it in DIY.

Now I need help and write it here:

Network menu show Wired LAN connection and Wireless Volumio Hotspot but I can’t find any Wirless Network to connect
I started from 3.569, now checked on 3.576

here is log file.

http://logs.volumio.org/volumio/vwNG53L.html

problem is with Dell OptiPlex FX160.

Simple: some wireless devices cannot scan for networks while in hotspot mode. Has been reported a few times already, the forum has a search function in case you don’t know.
Solution: switch off the hotspot, wait till the network has restarted and the network menu screen been redrawn, then you will see the SSIDs.

I think the solution would be entering the BIOS/UEFi settings with a keyboard, and select the USB drive with Volumio as the first boot option

As @Wheaten mentioned, it’s even better if you install Volumio on the internal drive, if it’s too small (less than 4GB) maybe you could find a bigger one, even second hand, and install Volumio on it.

And you can add a cheap SSD to it. (Page 14-15)

Thank you. I know about it. I have service manual and read it.

This type of drive was max. 2GB, Probably I will started from USB and use SSD drive with one of my home router like a server. It will be the best because I can use audio files on both Volumio.

Yes, I know but I turned off Hotspot yesterday and still don’t have any Networks. In this case I check WiFi antenna.

This is only to prevent typical x86 issues being scattered all over the forum.
We have this existing thread for x86 with a topic index in the first post.

Which wifi device does the Optiplex have? The log URL you submitted seems to be faulty, I could not access it.

Hi Gkkpch,

Thank you for your help with this!

http://logs.volumio.org/volumio/IDk4qWO.html - This is a log from a boot to a 3.569 USB then an install to the internal 64GB M.2 sata drive.

The install completes successfully and I reboot removing the USB but then the internal drive does not show as a boot option in the bios. The data is definitely on the drive and I can make it boot able with efibootmgr but it does not seem to persist.

This problem has also been noted on the Futro with both Home assistant and PfSense.

If I install Ubuntu or Windows to the drive then the install is recognised fine as bootable and shows up as a boot option.

Any help greatly appreciated,

Alex

I think i remember that i had the same issue on the futro 740 thin client. After writing the volumio image to the local sata device, it was not recognized as a boot device by the bios, while a current ubuntu install worked fine to boot before. So ubuntu (which is afaik based on debian) did not have such an issue. The s740 does not offer any legacy boot, so it forces uefi without any alternative.

My overall feeling was that the s740 is a kind of picky with uefi boot, and that the debian version which volumio is based on is not the actual version. In fact it is based on a bit older debian version. And maybe therefore it did not work to boot on that picky s740.

However, I did not spend much more time on this and switched to a different thin client instead.

Maybe if some day volumio changes to a newer debian release the issue will disappear.

Please note that my conclusions are just some feeling and i dont know the real root cause.

Edit: if my understanding is correct, the current volumio is based on debian 10, while the latest debian version is 12.

If you want to investigate more, you could check if you can boot the s740 with a debian 10 install or not. If it boots with a normal debian 10, then the volumio customization is the issue. If it not boots with debian 10, then debian 10 itself is the issue. However, apparently the s740 itself might be the main issue as it must be very picky on uefi boot.

1 Like

I agree with @madx1701, that there are better alternatives as a thin client I did some research today.

Without this boot issue (where honestly I cannot add much), the device mayworks, but will have limitations nevertheless.
When the device has a Dell True Wireless 1397 PCIe card, even when you get it to work, it will be “slow as a turtle”, you would be better off to find the Intel 5100N series as a 300Mbps half card alternative.
Also, the graphics driver SIS Mirage 3 is not supported with Volumio, as there is no official 64-bit driver for it (and I’m not going to add out-of-tree sources from the internet as this doesn not fit with our build mechanism).
You can try it yourself, but it will get overwritten/ removed when you do a Volumio OTA update, possibly you can’t use OTA at all.

Maybe this is not what you wanted to hear, we can’t support all thousands of different x86 devices in the field, Volumio is not staffed like Debian or Canonical.
I’m not sure if you can get this working, however I won’t be able to assist you with that (off for a looooong Christmas leave).

Solved, problem was in antenne connector but I connected Volumio Optiplex by wire for better transfer.

I decided to boot from USB and use shared local files. I have problem with UPNP servers ( not showing metadata of song, I found solvation with search engine :slight_smile: ) and before I will configure samba server I shared USB disk from Volumio Pi as a NAS for Volumio Optiplex. Works perfectly.

Volumio on Atom230 is very stable, boot few minutes but after start works smooth without any problems.

1 Like

I think this might get mixed up. My reply was for the futro s740 and not the dell. Overall my experience is that thin clients can be a very good solution, but of course it depends on the model.

The futro s740 has a 4 core celeron J4105 which is quite powerful for just music playback.

I am currently running volumio on a futro s920, which has an even less powerful AMD GX-415GA SOC, but has a pcie slot, where i can use a quite good quality pcie sound card (thanks @gkkpch for helping with this asus card to get it to work). However, the s920 thin client is doing very well regards to performance.

As there are too many different models of thin clients, the volumio team cannot test them all and not ensure compatibility for each of them. Linux itself can be a trouble when it comes to uefi boot… I remember very well that just some years ago some intel atom cpu based Laptops had still big trouble to boot Linux via uefi, while they worked well with windows. The issue was not with the cpu but with the bios or chipset.

Im fact, linux is great overall but is always a bit behind the drivers and wide hardware support when it comes to new standards. As linux is open source, while windows is commercial, the driver support is mostly concentrated on windows first and Linux comes with a delay.

The big benefit however is that Linux supports very well lot of old hardware where Windows kicks it out.

So for the futro s740… It would be very time consuming to find a solution. Maybe the easier way is to just use another thin client model, or re-try once volumio uses debian 11 or 12.

Debian 11 or 12 won’t make a difference, it is the kernel and firmware which count.
Newer kernels and firmware seldom (if ever) do anything for old hardware, they focus on existing and new.
Volumio will have kernel 6.6 LTS and the latest firmware with the upcoming version, but the Futro won’t profit from it in any way.

Ok looks like I will have to buy different hardware, its a shame because performance is great when it works and only draws 4w when running and only cost £40!!

Thanks for your help, I still love Volumio :slight_smile:

Alex

Or you just boot it from an usb stick or attach the sata disk via usb case. If i remember correctly, for some strange reason the boot from usb worked on the futro.

You could then use the internal m2 sata just for your music files.

maybe this workaround is worth a try.