X86 Hardware issues (WiFi, DAC, Disks, Boot etc.)

same x86 image, different x86 machines, weird.
On the other hand, an Odroid armv7 also fails, which makes me believe that it is not an x86-specific thing.

I have the same problem as you! I have a Laxton thin client and the wifi worked fine until the last update, not since. It turned out that the wifi itself was broken, so I bought a recommended model. It works until I turn it off. Not after that. I can only start it manually. But I solved it, and I recommend this to everyone: You need a router that can work in AccessPoint mode. The router providing the Internet must be connected to it, in Wi-Fi mode. And Volumio is connected to this second router with a LAN cable. All problems disappear at once, in fact!!! Until now there was an annoying noise when the wifi was working. Now there is silence. And the sound of the streamer got better with… classics. It is worth using this method, because so far I have only benefited from it. I see that Wi-Fi is one of the weak points of Volumio, but with this solution all such problems are a thing of the past. Last time when reporting the error, I wrote very impolitely, so I apologize to everyone.

That is your opinion and I dare to disagree :wink:

Fact: A cabled connection is always preferred over Wireless connection.

But there are so many things that can affect your wireless connectivity:

  • placement of the Wifi access point, like horizontal/vertical
  • Placement of Wifi enabled products
  • Neighborhood access points, streaming over the same channels
  • Walls
  • Electrical equipment
  • European regulations on max emitted power

The strange thing is the manual restart of the adapter, as I have the same and it just works. Maybe there are some issues with certain revision of this module.

I understand you! Then I will be more specific, maybe that way you will understand what I mean. The weak point is not in transmission and functionality, but in the driver programs that operate the amazing variety of Wi-Fi keys. I understand that they cannot write drivers for every imaginable and unimaginable chipset and adapter. When I ran Linux on my machine, I also had trouble getting wifi that worked under Linux. Maybe someone who understands it can write or port a driver, I’m not like that. So the weak point is not the wifi functionality, but the lack of drivers? And I don’t want to hurt anyone. But if it’s Wi-Fi: I was surprised to find that when I updated the running volume of the MacMini (2006), the previously inactive Wi-Fi came to life and it worked, it works. It’s true that it can only do 10Mb/s, but it works. So Dear Sir: I don’t want to attack Volumio, stay away from me, in fact… But for me, and as I read others, Volumio on PC system often causes white hair to users, and I also used a style that is not allowed, and for that I am ashamed .


Megnyitás a

Hi Guys,

Newbie non-audiophile question,

I got Volumio 3 (latest updates) on X86 connected to USB DAC Topping D10S , steam hi-res FLAC files from my home network NAS.

Although my lossless file is encoded in high sample rate, the topping cannot go beyond 44.1 kHz, 16Bit.

Is there some settings are driver that I miss to fully have higher sample rate?

Log: http://logs.volumio.org/volumio/YDHWjEe.html

Please post a log, so we have some more information.

Did you set any sampling in Volumio?

log : http://logs.volumio.org/volumio/YDHWjEe.html

didn’t change the default setting , no Audio resampling.
Thanks in advance

The log was cut off to quick, can’t see any information when you play a track.
moved your topic to the correct topic, so it gets better support.

Hello Gé

USB is enabled in bios. The T3U works fine once I execute after boot: “systemctl restart wireless”

Here is lsusb, directly after boot, prior to “systemctl restart wireless”. At this time in the UI, Wireless networking is on, but the wireless network does not work or appear in the active networks at the top of the Network page.

volumio@volumio:~$ lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 13fe:4200 Kingston Technology Company Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 08bb:2902 Texas Instruments PCM2902 Audio Codec
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 002: ID 2357:012d TP-Link
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Hi, did it again while playing a song,
hope it helps
Thanks in advance for your support

and this happens every few days, the game works normally, suddenly loses the library of recordings and does not look anywhere, neither on the internal memory nor on the connected NAS, there are no songs, not a singlevolumio.txt (30.2 KB)

and again I have to do the installation again, because restarting doesn’t help, and I can’t do anything in linux

A few things we’ve found in the past with library problems are

Sort all files by size and delete all zero size
Run MP3Tag sort by time and delete all zero time files
Run a MP3 or FLAC file checker to see if there’s any corrupted files fix or delete
where-ever your files are stored clear the recycle bin

Hope this helps

there are no zero files, the log shows a problem with mpd, after doing a new volumio, it searches instantly and finds all files, works 3-4 days and again. I don’t have mp3, only flac 192kHz/24bit and DSD 64 and 128 - what basket? in widows? there is no basket for volumio on the NAS, probably not - I don’t know - how is it where? - as far as the cover cache is concerned, I did this.
If it’s good and I tell it to look for files - it prints it out and “such arrows are spinning” - and when it’s broken it doesn’t display anything - no reaction, sometimes I hear it looking for the NAS disk but nothing is displayed. Browsing SMB on win10 - I can see the entire library from the NAS on volumio - I can browse it from win10 on the volumio folder, but I can’t play and it doesn’t display

this is the log after doing volumio again - it’s okdobry po reinstalacji.txt (52.6 KB)

and one more thing - I didn’t write about it, if the system is turned on, it’s good. This happens when I turn it off, e.g. for the night and turn it on the next day - then the library is empty, or when I restart it

try this command:

sudo systemctl restart mpd

does not help, the system does not respond to it
I am using x86 Lenovo ThinkCentre

1 Like

logs, logs, logs…

it is good after a fresh installdobry po reinstalacji.txt (52.6 KB)