X86 Hardware issues (Graphics, WiFi, Onboard Sound, external DACs, Disks, BIOS/UEFI Boot problems etc.)

thanks for the log, it shows you have TL-WN725N revision 2 with an RTL8188EUS chipset.
I already tried to find a driver for it, as there isn’t one supported by the current kernel. I located a DKMS version on the internet: GitHub - aircrack-ng/rtl8188eus: RealTek RTL8188eus WiFi driver with monitor mode & frame injection support.
It will take some time to integrate this into our kernel tree (as was done with a few others) but feel free to compile as a DKMS package and test it.

Hi - thanks for looking into it, the driver search and the advice. I’ll have a bash at it…

Just updating mu post here. I believe I got the DKMS package driver for the TL-WN725N revision 2 built and installed, but it’s still not working actually (same error as before).

Just for the record, this is what I’ve tried. Once I worked out the right cmds, I got success messages all the way along.

sudo apt-get update

sudo apt-get install dkms

git clone https://github.com/aircrack-ng/rtl8188eus

sudo mv /home/volumio/rtl8188eus /usr/src/realtek-rtl8188eus-5.3.9~20221105

sudo dkms add -m realtek-rtl8188eus -v 5.3.9~20221105

Then also installed the header files thus:

git clone https://github.com/volumio/x86-kernel-headers

sudo apt install /home/volumio/x86-kernel-headers/linux-headers-5.10.139-volumio_5.10.139-volumio-1_amd64.deb

And finally:

sudo dkms build -m realtek-rtl8188eus -v 5.3.9~20221105
Building module:
cleaning build area...
'make' -j2 KVER=5.10.139-volumio KSRC=/lib/modules/5.10.139-volumio/build.......................................................
DKMS: build completed.

sudo dkms install -m realtek-rtl8188eus -v 5.3.9~20221105
DKMS: install completed.

sudo dkms status | grep realtek-rtl8188eus
realtek-rtl8188eus, 5.3.9~20221105, 5.10.139-volumio, x86_64: installed

I am probably missing some final step to activate the driver? I don’t fully understand the notes on the Github page about blacklisting another driver, or if they are relevant to Volumio.

I think they are not relevant. Do a reboot and then check with lsmod whether the module was loaded.
If not, you may have to do a modprobe.

I started the integration in a new Volumio release with kernel 6.1.5 as we speak, there is a beta running for it.
Not sure if I can get this done today, I’ll let you know when it is ready and give a link to a beta test image with the rtl8188eus driver in it.

Thank-you, that’s amazing. I’ll pick this up tomorrow with some more investigations.

It does not compile with kernel 6.1 at the moment, I need to fix this (known errors, I already have patches for them).
So not today after all :wink:

For your issue, could you blacklist r8188eu please, it might cause issues otherwise

OK, I tried 2 different sources for the RTL8188EU/EUS driver, both fail for different reasons (AP-Mode not working, scanning OK but can’t connect).
With old devices like the TL-W722N/ TL-W725N I would like to quit and save my efforts for more important things.

A working and well performing alternative is the TL-LINK T3U, which several members, including me, are currently using for Volumio x86.

I don’t really know what you are asking, what you need. I have 0 computer skills. I can’t rummage through the system. I checked one thing, about the network card type, Windows 11 wrote: Atheros L1 Gigabit Ethernet 10/100/1000 Base-T Controller
What I know: This wifi key worked without problems for 2 years. It doesn’t work since their last update!!! I want one: I turn on the streamer, it connects to the network, I select the music and listen as before. Not rummaging through log files or carrying a monitor. I don’t know how to send a log file, I don’t know where it is, I don’t know how to download it. And it’s not my duty to know. I am a user, not an IT specialist. Out of about 15 wifi keys, I found this one that worked so far. I can not now. I subscribed to Tiadal, Volumio Premium, and it’s a complete disaster. I don’t understand what’s good, why do they have to spoil it?

Even with zero computer skills you should be able to get a log file with the instructions on the link Sending logs for troubleshooting - Volumio Documentation

I want to listen to music, not search log files. I don’t know how to do it, if I could do it. Don’t be clever. When you turn 65, you also see the world differently. What is obvious to you is not to me.

Hello Gé

Thank-you for taking the time to look into that, I appreciate it. I agree, it seems a fait accompli with the TL-W722N. Mine will go back to my Lenovo T430 hackintosh whence it came. I will acquire a TL-LINK T3U as recommended. Still, I enjoyed working out how to compile the dkms package, with a glass of nice shiraz :smiley:

Another annoyance! I wanted to reinstall my system, and what was going smoothly until now is definitely not working. I inserted the USB key as before. Before that, I put the latest Volumio on it, I chose the boot device as before, and this is the first time I received this image. I have nothing to do with this. I don’t understand this! But I shouldn’t understand. Shouldn’t I insert the pedriv, the system starts, and that’s it? Why don’t you do that now? What do I need to do to make it do this? Screenshot attached.

mikldesign, this sounds like a torture to you, I can’t help wonder if Volumio is the right choice for you. Have you considered a proprietary commercial product, as opposed to an open source OS in active development?

Or, you could (I like I am planning to) acquire a TL-LINK T3U. Or, pay someone to install a cable ethernet solution in your location and never have to deal with wifi on Volumio again.

1 Like

I chose Volumio because it worked smoothly on the MiniPC on my first try. You didn’t need any university knowledge, it worked. He said it nicely. There was no problem with him for two years. I updated when an update came. It continued to work. I have an annual subscription to this system and to TIDAL. Why would I think about an expensive streamer? To my utter astonishment, I wrote the new img file to a pen drive in the usual way to reinstall the system, but instead of a settlement, it wrote a bunch of things that I don’t understand. As for the cable: I can solve such a task myself. But in this case, it’s not an option for me. It’s not a workable solution. I had a working system that was hammered with the update by disreputable system wreckers, and now I’m looking at how to proceed. Why can’t what’s good stay that way?

Well, you could at least take the effort to tell us what PC you are talking about, instead you continue your rant. Yes, it is annoying when things don’t work the way they should. Please remember a PC is not a Raspberry, which comes in one configuration per model. Do you know how many thousands of different PC configurations are out there in the field?
Getting them to work properly does need the help of users, if you are not willing to give that, than do not bother to ask for help.

I do understand your annoyance, if things don’t go as you have planned. I have, however no understanding in the way you’re acting on a community forum.
People are willing to help and sort out what is going wrong and only ask you for some very basic information that is well documented how to do it, .
We have to build 1 image to support thousands of different configurations. If you have configuration 1001 we need the requested info. (Keep in mind this is much a DYI project)
For example your last screen shot indicates a bad flashed image that for this reason fails to boot.
Either you help us to help you or look for a different solution. But I have to warn you, Volumio is one on the most user friendly software to get up and running.

I understand the frustration working with things that are not familiar, but saying the developers destroyed something probably isn’t the best path to get assistance in your situation.

My first Volumio installation had been on a Tinkerboard S that was found second hand, and has worked hands free for years.

This might be a better solution than the X86, if less fiddling is desired.

I am patiently awaiting the arrival of a T3U adapter here myself, for my separate, X86 system.

In most cases this does not apply, it is usually the very old and the very new hardware that sometimes give issues. Otherwise the x86 platform is rock steady, no tinkering necessary at all.

I am glad to report that the T3U unit works well with the 3.396 on my X86 system here.

Again, many thanks.

T3U nano or mini edition, anyone?