X86 Hardware issues (Graphics, WiFi, Onboard Sound, external DACs, Disks, BIOS/UEFI Boot problems etc.)

Depends on the file system of the 4TB. how to label it
NTFS => ntfslabel
exFAT => exfatlabel

I expect the drive you see in system to install volumio is most likely the M2.

As you said, with Roon Core it was “ext4” formatted, the correct command would be

sudo e2label /dev/sda1 issd

where /dev/sda1 is just an example.
Better start an SSH terminal first after booting Volumio and then do

sudo fdisk -l

to determine which is the proper disk to re-label.
No mounting needed, just re-boot afterwards.

Drop the output from fdisk here in case you are not sure.

1 Like

Output of sudo e2label usw.:

e2label: Bad magic number in super-block while trying to open /dev/sdb
Found a gpt partition in /dev/sdb


Why the :face_with_raised_eyebrow:?
Realise we, as a community, only try to help.
Instead, show what you got from fdisk, helps a lot more :grinning:

Hello Helpful Forum,

I have some new hardware the Fujitsu Futro S740 Thin Client, its a Intel Celeron J4105 x64 machine.

The issue is the unit only boots pure UEFI and does not support legacy boot. I burn volumio to a USB then boot off that USB on the Futro, it boots and allows me to install to internal drive no problems however when I come to boot from the internal drive the computer doesn’t recognise the drive as a bootable drive.

I can temporarily fix the issue by booting a Linux live usb and using efibootmgr to add BOOTX64.EFI to the EFI boot list. The problem is that doesn’t seem to persist after power loss(Time and date are retained fine by CMOS battery).

Is there some way to modify volumio so it is recognised as a boot device please? Windows and Ubuntu installations are recognised fine as bootable and automatically added to efi boot list.

Thanks in advance,


Edit: I heard the Futro needs GPT partitions, i tried converting the ssd to GPT but still not recognised. one time I could get grub to be recognised with GPT but it then didn’t boot volumio.

Good afternoon I tried several times to use Volumio on a mini PC based on an Intel Celeron N100 processor. Problem is that in the audio output settings Volumio does not see DACs connected via USB (I tried different ones - SMSL, VIIM, KEF active acoustics), and it also does not see connections via HDMI. Another problem is that no plugins are displayed in the plugin settings.What could be the problem?

Not sure about the USB and HDMI issue but plugins won’t show unless you log in to MyVolumio on the device. Are you logged in?


Yes, I’m logged in.

1 Like

The problem is that you did not read the very first post in this thread :wink:

But rest assured, many don’t, so please read the post and supply the information as mentioned.
In your case, you can start with submitting a log file.
Any other hardware info is appreciated, but not mandatory at this point.

First, there is no need to convert the SSD’s partitions. That will not work and is not necessary either as Volumio already uses GPT partitions.
The image is a “hybrid”, it will boot with SYSLINUX, when supported OR with UEFI, but I guess, once installed on the SSD, UEFI has priority.
You are the very first one reporting a UEFI bootmanager issue (since it’s introduction mid 2017), so likely something else is the problem.
There appear to be other forum members successfully using the Fujitsu Futro S740, so it is unlikely a hw issue.

With just “does not recognize the drive as a bootable drive” I can’t do much.
Could you please supply it bit more info regarding your hardware and especially the SSD?
For the hardware part, please submit a log while booted from usb.

1 Like


I have Volumio on my main system and I decide to make one for my son to his room upstair. When I was looking for another RPi, I found this…

workstation from DELL, old OPTIPLEX FX160. I remember that I bought it for 10 eur.

Inside is Celeron 1600 Ghz and 3GB memory. SSD disk is 2GB but probably is not to use with Volumio.

Is it possible to run Volumio on this piece of electro-scrap ?? Why not try ??

I prepared Volumio USB copy for x86 but how it start ?? I don’t have any old keybord and DELL all time started from SSD drive. I removed SSD and workstation started from USB !!! Hurra.

I configured it first time and after restart on phone I have two devices:

I’m in shock what Volumio started on old Intel Atom.

Only temp is missing and avarage load is 130 to 200% but Volumio works fast, without lags and jams. It seems to respond faster than the RPi3B+ !

Last hour I checked it with phones and is ok:


@Darmur, one question.

If I started Volumio from USB I can connect USB disk or USB sticker. If I started with 2 USB connected… Volumio not start.

I understood that it is because of DELL mainboard architecture and I should live with this ??

1 Like

Tip of the day, the X86 thread

Just format the SSD, connect it back to the Dell, boot from USB and flash the SSD via the side menu => System.

I will try. Thank you.

But …

Is it because target drive is smaller than img ??

I will try start Volumio with smaller USB and after that try one more time.

Another post outside the x86 topics, I wonder why members like @eMCZe think they get anywhere without searching the forum.

Suggest: read the first post in X86 Hardware issues (WiFi, DAC, Disks, Boot etc.)

and supply the info from there.
No log, no support.

I will tell you. I start to build this streamer on DELL workstation and started thread. My question was “by the way”. I didn’t create this topic to seek help. I intended to solve this problem using a home server.

But I would like to inform you that I will not ask any more questions “by the way” topic, I will only ask them where they are necessary so that you can rest assured that everything is in order.

I’m sorry if you took this as a form of mess or lack of good will from my side,

I don’t understand why you close my DIY topic in time when in my workshop I started to build wooden case for this Volumio. It is the reason why I put it in DIY.

Now I need help and write it here:

Network menu show Wired LAN connection and Wireless Volumio Hotspot but I can’t find any Wirless Network to connect
I started from 3.569, now checked on 3.576

here is log file.


problem is with Dell OptiPlex FX160.

Simple: some wireless devices cannot scan for networks while in hotspot mode. Has been reported a few times already, the forum has a search function in case you don’t know.
Solution: switch off the hotspot, wait till the network has restarted and the network menu screen been redrawn, then you will see the SSIDs.