X86 Hardware issues (Graphics, WiFi, Onboard Sound, external DACs, Disks, BIOS/UEFI Boot problems etc.)


Did you read my reply to your post, please follow the instructions under reporting, in the start of this topic. Just random copy some lines is not getting you closer to a solution.

Just for your understanding, we don’t have crystal balls and/or tarot cards, we do need this information to help you.


TL-Link T3U works perfectly.

Difficult, TL-WN725N has several revisions. TP-Link is known for changing to different chipsets, they keep the dongle name, but give it a new revision number :man_shrugging:
We need the bootlog, to be created from the dev page, see OP.

My apologies that my entire log hadn’t displayed on this forum using a copy/paste.

My time is worth money, as I am sure yours is as well. I have kids and choose to not ignore my family by working on things like this for hours on end.

Now if someone had a known wifi solution, for 3.396/X86, I wouldn’t be wasting any more of anyone’s time on this $10 wifi dongle. That information would be useful, and likely far more efficient.

If not, I will probably choose another solution, life is too short.

I’ve given you the solution just one post above your latest, but you’re free to ignore it.
My time is not valued in money, there are more important things in life than worrying about that :grinning:

1 Like

Many thanks for your help, really like the Volumio platform.

Sorry, is early here…

I am extremely disappointed with Volumio. When I started using it, everything was absolutely perfect, about two years ago. But over time, each update gets worse. I use it with a miniPC, not RaspBerry. Now what totally pissed me off is the wifi anomaly. I cannot use the Volume with a LAN cable because the router is in the next room. But so far it hasn’t been necessary. I turned on the Volume and the wifi connected automatically. So far. However, since the latest update, I’m just struggling. When I turn on the streamer, there is no connection, but I have to bring a monitor there, connect with HDMI, and then manually connect to the wifi. When connected. But sometimes it doesn’t connect, or when it does, the NET is so slow that TIDAL only stutters. If I connect to TIDAL with something else, the client program, it works without problems, but not with Volumio. Then Volumió thinks for a moment, and the normal Wi-Fi signal arrives, it works fine, then suddenly the speed drops again. It will be fine again. In the meantime, measuring the wifi speed with another machine, everything is fine. Sometimes there is no problem for days if I don’t turn it off, then it goes wrong again. I tried with a different wifi key, but it’s the same. If I turn it off and turn it on the next day, the Wi-Fi problem starts all over again. When I updated, it was able to update in 18 hours. I tried reinstalling, no results. So I just congratulate Volumio because they were able to make a lot of crap out of a great system, I mean in my case. Again: I’m not using it with a RaspBerryPi, but with a minipc. I am a subscriber, but I didn’t subscribe to this, but to a working system!!!


Sorry to hear things are not going well. Please see the first post in this topic and provide the details mention under reporting.
It might be possible that something is wrong with the driver, signal quality, WiFi antenna, but we need to have more info.

Greetings sage guru’s of Volumio!

I have a similar issue to the last. I purchased a HP 620 thin client that was supposed to have a wifi card (but it doesn’t!!). I have a TP-Link TL-WN725N N150 sitting around (purchase link here).

It has the same failure as Janky describes “Command failed: sudo /bin/systemctl restart wireless.service Job for wireless.service failed because the control process exited with error code.”. It actually see’s my AP but then fails.

I’m on Volumio 3.396, x86/x64 on the HP 620 thin client.

My log file is hosted… (Link removed).

I’m happy to roll up my sleeves and compile a driver for the TP if someone can assist with how-to! Alternately, I could purchase a TP-Link Archer T3U AC1300 locally with some delay and another NZD 65 outlay. Finally, if wifi is denied me, I will get under the house and install a cable solution - you should see it under there though - big spiders everywhere!! :joy:

Any steps to install a x86/x64 driver for TL-WN725N gratefully received.


thanks for the log, it shows you have TL-WN725N revision 2 with an RTL8188EUS chipset.
I already tried to find a driver for it, as there isn’t one supported by the current kernel. I located a DKMS version on the internet: GitHub - aircrack-ng/rtl8188eus: RealTek RTL8188eus WiFi driver with monitor mode & frame injection support.
It will take some time to integrate this into our kernel tree (as was done with a few others) but feel free to compile as a DKMS package and test it.

Hi - thanks for looking into it, the driver search and the advice. I’ll have a bash at it…

Just updating mu post here. I believe I got the DKMS package driver for the TL-WN725N revision 2 built and installed, but it’s still not working actually (same error as before).

Just for the record, this is what I’ve tried. Once I worked out the right cmds, I got success messages all the way along.

sudo apt-get update

sudo apt-get install dkms

git clone https://github.com/aircrack-ng/rtl8188eus

sudo mv /home/volumio/rtl8188eus /usr/src/realtek-rtl8188eus-5.3.9~20221105

sudo dkms add -m realtek-rtl8188eus -v 5.3.9~20221105

Then also installed the header files thus:

git clone https://github.com/volumio/x86-kernel-headers

sudo apt install /home/volumio/x86-kernel-headers/linux-headers-5.10.139-volumio_5.10.139-volumio-1_amd64.deb

And finally:

sudo dkms build -m realtek-rtl8188eus -v 5.3.9~20221105
Building module:
cleaning build area...
'make' -j2 KVER=5.10.139-volumio KSRC=/lib/modules/5.10.139-volumio/build.......................................................
DKMS: build completed.

sudo dkms install -m realtek-rtl8188eus -v 5.3.9~20221105
DKMS: install completed.

sudo dkms status | grep realtek-rtl8188eus
realtek-rtl8188eus, 5.3.9~20221105, 5.10.139-volumio, x86_64: installed

I am probably missing some final step to activate the driver? I don’t fully understand the notes on the Github page about blacklisting another driver, or if they are relevant to Volumio.

I think they are not relevant. Do a reboot and then check with lsmod whether the module was loaded.
If not, you may have to do a modprobe.

I started the integration in a new Volumio release with kernel 6.1.5 as we speak, there is a beta running for it.
Not sure if I can get this done today, I’ll let you know when it is ready and give a link to a beta test image with the rtl8188eus driver in it.

Thank-you, that’s amazing. I’ll pick this up tomorrow with some more investigations.

It does not compile with kernel 6.1 at the moment, I need to fix this (known errors, I already have patches for them).
So not today after all :wink:

For your issue, could you blacklist r8188eu please, it might cause issues otherwise

OK, I tried 2 different sources for the RTL8188EU/EUS driver, both fail for different reasons (AP-Mode not working, scanning OK but can’t connect).
With old devices like the TL-W722N/ TL-W725N I would like to quit and save my efforts for more important things.

A working and well performing alternative is the TL-LINK T3U, which several members, including me, are currently using for Volumio x86.

I don’t really know what you are asking, what you need. I have 0 computer skills. I can’t rummage through the system. I checked one thing, about the network card type, Windows 11 wrote: Atheros L1 Gigabit Ethernet 10/100/1000 Base-T Controller
What I know: This wifi key worked without problems for 2 years. It doesn’t work since their last update!!! I want one: I turn on the streamer, it connects to the network, I select the music and listen as before. Not rummaging through log files or carrying a monitor. I don’t know how to send a log file, I don’t know where it is, I don’t know how to download it. And it’s not my duty to know. I am a user, not an IT specialist. Out of about 15 wifi keys, I found this one that worked so far. I can not now. I subscribed to Tiadal, Volumio Premium, and it’s a complete disaster. I don’t understand what’s good, why do they have to spoil it?

Even with zero computer skills you should be able to get a log file with the instructions on the link Sending logs for troubleshooting - Volumio Documentation

I want to listen to music, not search log files. I don’t know how to do it, if I could do it. Don’t be clever. When you turn 65, you also see the world differently. What is obvious to you is not to me.

Hello Gé

Thank-you for taking the time to look into that, I appreciate it. I agree, it seems a fait accompli with the TL-W722N. Mine will go back to my Lenovo T430 hackintosh whence it came. I will acquire a TL-LINK T3U as recommended. Still, I enjoyed working out how to compile the dkms package, with a glass of nice shiraz :smiley:

Another annoyance! I wanted to reinstall my system, and what was going smoothly until now is definitely not working. I inserted the USB key as before. Before that, I put the latest Volumio on it, I chose the boot device as before, and this is the first time I received this image. I have nothing to do with this. I don’t understand this! But I shouldn’t understand. Shouldn’t I insert the pedriv, the system starts, and that’s it? Why don’t you do that now? What do I need to do to make it do this? Screenshot attached.