Wlan0/Volumio won't connect after leaving the house

So I have read other posts saying there was support for talking to your phones hotspot. I am trying to use Volumio in my car, for some reason when I disconnect my phone from my main home network all of a sudden Volumio stops working. Why? I have version 2.9, my android is version 12. I know enough about networking, I saw my IP in Volumio was set to 192.168.113… (not the volumio fallback) and my home network starts with 10. I don’t really know a lot about hotspots, but I’m pretty sure the volumio can and does get an IP from my phone, but it won’t even talk unless I have my home network connected too.
Am I supposed to edit the wpa_supplicant.conf file? because I do have my home network and my hotspot saved in that file, so I commented out the home network, and that also didn’t allow it to connect, but it still got an IP from my phone I believe.

Have you tried to connect via myvolumio.org?

Yes I tried and the volumio.local address and neither work. Oh and I don’t have an account yet, I thought you meant the Web UI

1 Like

You can’t connect from WAN to your LAN, as your LAN is protected by a firewall, unless you setup port-forwarding and access it through your ISP given public IP, which i won’t recommend.
If you open myvolumio.org, you can access your Volumio from Volumio’s webpage, clicking on the play knob in the overview.

If this is what you’re trying and fails, something in your router is blocking access.

I’m confused. Does volumio not work w/o internet? I am trying to drive off with just my Pi and phone so they should talk together right? My phone has no firewall, and I’m not trying to use this at home.

Have you tried not starting Volumio until out of WiFi range?

if your rPi in the car has wifi, then the phone should be connected to the hotspot of the rPi in the car. I am not aware that that shouldn’t be working. (completely overread the car part, my bad)

So in this case as Old_Duffer mention, your prob. starting the rPi in front of your home, so it will try to connect to your home network. If you’re out of reach of the home network and start the rPi, there should be a hotspot visible like Volumio_xxxx.

@Joni_Salminen I seem to remember that you use Volumio in the car, maybe you can give some hints?

1 Like

Yes i use volumio in car as mediaplayer.

I do use my tablet as wifi hotspot, and the volumio device connects to that network so i get all the networking features.

The most easiest way to setup that is by doing the initial setup indoor, connect the volumio device to your home wifi network. Then configure your phone hotspot to use same ssid and password as your home network, now when you move the volumio device to your car it will automatically connect to your phone hotspot, since the credentials for the network are same.

1 Like

Ok I tried that, I edited the supplicant file so it would have the same SSID and password. Still getting the same thing, once I turn off my phones connection to the home the app disconnects. I also had to turn off the fallback option because it would get stuck in the fallback hotspot.

I was able to see my phones IP address change after turning my home network connection off, and then I added the new IP to the settings option on the first page in the app, and it still gives me that “you must connect to a wifi to connect to your devices” error (I mean I have my phones hotspot IP pre saved because I can’t even edit IP’s once I disconnect the home network). There must be something volumio is looking for with my home network. It’s like volumio has a file somewhere stopping it from working, because it still shows my .113 address that it gets from my hotspot, and my phone shows 1 device connected. I read the journalctl -f log and during the time the app wasn’t connected, but getting my hotspot IP it said something like “session closed” and “using port 7777” I think. To me it seems volumio is shutting down the wifi, just because it doesn’t see my home network. I guess I could connect everything, use journalctl -f then shut down the home network and see what the log says?

I have an RPI zero in my car. It is connected to the AUX-Entry of my radio. Music is stored on a 32GB USB-Stick (that’s about 50 hours music FLAC-Files) and ist works perfect.
When I start the car and there is no WIFI-Network the RPI is alllowed to connect to, it creates its own WIFI-Hotspot with the the fix IP as documented in the Volumio Manual.
All I have to do is to connect my phone to this RPI-WIFI-Hotspot.
So I search WIFI, see all the available Hotspots and select the one of Volumio.
That’s all.

@rolf47 Ok, so i’ve only got the web UI to work once I think but that was under a different build. So I’ll try messing with that too. Other then that I’m not sure the OS sees my phone hotspot as a true network? (it gets an IP though) because everything should work, I’ve never really needed to work with hotspots before. The only 2 files i’m used to messing with now are the supplicant.conf file and the /etc/network/interfaces file.

I’m going to also try setting up from scratch under a friends home network, because I don’t trust my home router, it was MAC blocking my mom’s laptop but never had any block’s listed in it’s MAC table settings.(and I wouldn’t say it’s completely my router yet, because it still works just in some ways right now)

Use Volumio at home.
Use Plex / Plexamp out of home.
Using Volumio ooh is just too complicated.

1 Like

I bet you that the Birch and Swinnerton-Dyer conjecture is also complicated :rofl:

@jhscann Ok thanks! that gives me another work around to finish my project. The only other software I knew of was Rune audio and I couldn’t get it to work with that either. I’ll still try to use my friends wifi for initial setup to rule out my own, and then check the journalclt log when swapping networks to see what happens, after that, I’d have to assume it doesn’t really work. I read somewhere that web UI wasn’t supported at first with Android, so I don’t know what work has been done to make it compatible.

Ok I tried to log what I could while testing it, I found a couple of weird things, but the first that seems out of place is:
When I connect to my phone hotspot, I see it goes through the handshake steps, checks for the proper key, it says “connected to: Pixel 5”, “key negotiation completed”, “send eapol packet, recv eapol packet”,
Once it gets to association it says " association success", Then: “rtw_cfg80211_indicates_connect(wlan0) BSS not found !!”
then it has another association success, with it basically looking like it fails saying “Trying to associate with (instert my AP MAC ADDR)”
I wanted to use Wireshark from the beginning for this problem because then I could have seen if association was failing. Is that what this looks like? I’ve never had an association issue before.
Another weird thing is when I command “sudo iwconfig” it says “security mode: open” not sure if that is supposed to show my wifi encryption method instead?

I think I’m really close, I’m going to borrow a friends phone and see if I have some sort of compatibility issue.

1 Like

OKAY! BIG HAPPY MONDAY UDATE! I just took another stab and it went down like this: Last time I typed in “sudo wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -i -wlan0” It said basically “iface exists and is in use, delete ‘/var/run/wpa_supplicant/wlan0’ …you will need to manually remove this file before starting before starting wpa_supplicant again” so I did that, then did it again because I wasn’t sure if it would auto update and take in current network information. I disconnected from my home wifi, delete, then rebooted, with my phone hotspot already on. Then I basically typed: “sudo iwconfig” again and noticed it was connected, pinged google and I got pings! Took another 30 mins because I kept trying to use the app to connect, and was scratching my head. I have tried using volumio.local and it’s given Volumio system name.local and never got it to work…well that’s because only once did I type in the actual IP my phone gives it. So I put in 192. …etc. and there it is! it’s working! Ok well I haven’t made sure it will play music this way but the networking side is fixed! Awesome!

A big confusion must have been trying to do an initial test setup with my home network, I think this info was saved in that file, and never really used my hotspot. I should have just started a fresh wifi config with only my hotspot, and the supplicant file, because that’s basically what I just did. Glad it’s working now though. :slight_smile: instructables link to come, I should probably get back to homework now. lol.

Just curious about 2 more things: Since I seem to only access Volumio through it’s hotspot address 192…etc. Is there any way I can still use the app on my phone or am I restricted to only a web interface at this point? It’s not a big deal but I was getting attached to the app.

Also during my troubleshooting, I must have entered some command that was duplicating my wpa_supplicant networks. When I go into the file with “sudo nano” it shows the last set up or connected network 4 times, same name, same key, just repeated, it’s not a big deal but the programmer in me wants to clean that file up. I’m pretty sure if I just manually delete them and save and reboot it will put 4 copies back in. Anyone know what command did that?

@jhscann would you happen to know? ^^