wlan0 is not restored after Wifi is lost

My Volumio 2 RPi3 connects to my home Wifi. After a Wifi outage, the Wifi AP is back on. My Windows laptop got its Wifi IP after about a minute. I ssh into my RPi via eth0 and find that after several minutes, my wlan0 is showing: (self-assigned IP instead of assigned from Wifi equipment)
Obviously I can’t ping RPi from my laptop via Wifi.
I tried the following:

sudo iwlist wlan0 scan

It shows my home’s Wifi is the strongest signal of all Wifi networks it sees.

sudo ifdown --force wlan0
sudo ifup --force wlan0

After waiting a couple minutes, still have wlan0 IP instead of
I reboot the RPi and all is well.

How can this be fixed without resorting to rebooting the RPI?

This needs to be investigated, I’m not sure if this has been taken into account.

– Gé –

Yes it is captured as issue #926.

In fact, the problem does not come from wifi, it comes from network. I own a wifi/eth router. If I restart it, all Volumio devices eth/wlan lose their connectionof course but never reconnect when the router in up. Other device (laptop, smartphone reconnect without problem. It’s becasue I did that https://github.com/balbuze/volumio-plugins/raw/master/plugins/system_controller/wifireconnect/wifireconnect.zip wiating a better solution.

I have the same problem. My router turns wifi off over night. Then the Volumio hotspot starts. When the router turns wifi on again, Volumio doesn’t reconnect. It stays in hotspot mode. I then have to connect to the hotspot and use shutdown the turn the RPI off. Then I can power it up again and it connects to the router

When I disable the hotspot function the only chance is a cold reboot to reconnect.

I tried the wifireconnect plugin, but it didn’t help on those longterm wifi dropouts.

We are fixing this problem, and we’ll keep into account the needs of long-wifi disconnection

I am also facing this issue, for example using microwave its create interferences and the Wifi often does not reconnect after that.
I also have a mobile internet, so when I go out the connection is lost and Volumio does not reconnect.

A reboot solves the issue.
Thank you,