Wireless Networking always turned off after restart

Hi there,
still fighting with my wifi connection…

I can connect over ethernet and turn on wireless networking. Then I can disconnect the wired connection and I can access the webinterface with the wireless connection.
But when I do a reboot I can’t get a wireless connection any more. The webinterface (connected over ethernet): Wireless networking = OFF

-> Wireless networking = OFF after every reboot!

System: Pi 2 Model B, HifiBerry DAC+, Wifi: TP-Link TL-WN725N, Volumio 2.041, router: FritzBox 7272

Appreciate any help. Greetings!

OK, we’re about to release new PI versions which will allow us, after you use the new upload facility, to have a look at the system log.
The behavior you described looks like what we know from another platform (Sparky), so far nobody reported this for a PI 2.
Luckiliy I have one and a similar nano dongle with an 8188eu chipset and promise to have a look at it tomorrow.

– Gé –

Could you please test this pre-release? link to v2.06 Edited

May I test the last pre-release as well, please? I tried the above link but it is not active anymore. (I cannot anyway use my DAC+ Pro with Volumio, because I cannot conveniently use a cable and Wi-Fi doesn’t work with Volumio)

I edited my post above, take version 2.06 please

Thanks a lot for your fast reaction and the pre-release.

I flashed 2.06 and configured the wifi-settings. I did about 5 shutdowns and restarts and the wifi connection always came back stable!

Seems either the improvements in 2.06 or the new installation helped on my problem.

By the way: I didn’t install a driver for the TP-Link TL-WN725N wireless adapter, but it seems to work good without.

But: I can’t choose my HifiBerry as output device.

Is the pre-release not a full version yet?


System: Pi 2 Model B, HifiBerry DAC+, Wifi: TP-Link TL-WN725N, Volumio 2.041, router: FritzBox 7272

You’re welcome

The driver is standard for a PI, there are quite a few dongles being supported out-of-the-box

Yes, it is but you might want to search the forum for the HifiBerry issue.
It was mentioned a couple of times before.

– Gé –

Thanks for the image! I flashed the card and then tried to connect only via Hotspot (no cable). Did not work. Is the password the same (volumio2)?

Then I tried with a cable. Successfully connected to WiFi and then restarted without a cable. Did not connect back to the set WiFi network.

What is the recommended sequence so that at the end

  1. only a WiFi connection is used (no cable)
  2. and WiFi reconnects automatically when rebooting the device?

Can you see the hotspot on your device? Yes the password is ‘volumio2’

Yes, I was able to see it and was using the volumio2 password. After I connected the cable I was able to connect to my WiFi router.

I don’t mind connecting initially with a cable to set the WiFi, but then I need to remove the cable at some point in time. I am not sure though what the recommended steps are to reach the “only WiFi” state.

These are the steps that I did to solve the problem for me:

  1. Flashed the pre-release (2.06) from the link above to my sd card
  2. powered my pi up with the wifi-dongle and the sd card attached and connected with a ethernet cable to my router
  3. used the Ethernet ip from Volumio to connect to the Volumio web interface
  4. Diabled the wifi Hotspot (menu: network / enable hotspot = OFF)
  5. Enabled the wifi network (menu: network / wireless networking = ON / DHCP = ON)
  6. Connected to my network from the list (menu: network / connect / password)
  7. Reloaded the web interface to check if wifi is activated (menu: network / network status / wireless)
  8. Shutdown the system (menu: shutdown / power off)
  9. Disconnected power cable from pi
  10. Disconnected Ethernet cable from pi
  11. Reconnected power cable to pi
  12. Used the wifi from Volumio to connect to the Volumio web interface
    -> pi and volumio connected to wifi after reboot, web interface reachable after several shutdown/reboot tests.

(But I still have a problem with my wifi connection if the router is switched off. After switching back on then wifi does not reconnect to the router. I have to disconnect power cable, wait a while, plug it back in and then it reconnects. I am not a fan of cold reboots… :frowning: Will do some research on this in the forum and maybe post an extra thread to this)


I had a problem with one of my devices losing its connection to my router after a certain time (perhaps something to do with IP address leasing). I installed a plugin from balbuze https://github.com/balbuze/volumio-plugins/tree/master/plugins ‘wifireconnect’ that checks internet connection every so often, and if it loses that connection (pinging google’s DNS servers I think) then the wireless service is restarted. It’s not gone offline for at least a week now.

Thanks for the tip chsims1. I read about that plugin, too.
But I am not quite sure if that is the right solution for me.
My wifi is disabled over night by the router. In that case the wlan would be restarted over and over again by the plugin. Not sure if that’s he best solution.
I’ll give it a try…

I have been experiencing the same problem. I downloaded the image mentioned on this post and installed it on my pi2 (with a Edimax EW-7811 usb wifi stick). I can install it and setup everything up fine (i.e. disable the hotspot and connect to my wifi network) but as soon as I unplug the the ethernet cable and reboot, I cannot find my pi2 on the network.

It would would be really good to get this working as, like others have mentioned on this post, it is not very convenient to have to connect with an ethernet cable.

If you need any logs etc., please let me know; I am happy to help in any way I can.

Many Thanks,


Well, I reported that my problem was solved with v2.06. It isn’t.

It worked for a few trys. Now, once again after every shutdown (power off / on) I can not connect wireless. When I connect wired, wifi is turned off (menu / network / wireless networking = OFF).

At the beginning v2.06 seemed to work fine. But then I noticed that wifi doesn’t reconnect when the router has turned wifi off over night. I installed the wifireconnect plugin, but that did’t solve my reconnect problem. Since I installed the plugin something changed with my wifi adapter. Without the plugin the LED blinked quite fast (transmit) . Since I installed the plugin the LED is constant on.

Now it seems to be corrupt and throws me back to the start of my problem.

Something is very weird here…

Tomorrow I will do a fresh install of v2.06 (again)…

Any tips for log files etc. to debug for those wifi issues??

System: Pi 2 Model B, HifiBerry DAC+, Wifi: TP-Link TL-WN725N, Volumio 2.041, router: FritzBox 7272

Thanks, RamsesVD. I reached step 5. but I could never enable the WiFi network after I disabled the Hotspot. So now I am with a disabled Hotspot, but also with a dead WiFi…

Update - Now, although the Volumio WiFi network was down (I changed the Settings menu pages several times to be sure I am getting an updated state) I tried to connect to my WiFi router. To my surprise V established a WiFi connection to my router, although the WiFi network showed it was down. Weird.

Then I did shutdown, unplugged the Ethernet cable and started V again. I waited for a good amount of time, but unfortunately V never connected via WiFi to my WiFi router.

I have also tried pure Raspbian with hard-coded WiFi settings in wpa_supplicant.conf and also LibreELEC/Kodi with settings from the UI (hdmi). With multiple restarts both always successfully connected to my WiFi router (a hidden WiFi network) automatically.
So the tech base to have that also with Volumio (and RPi/HiFiBerry DAC+ Pro) is in place. I read that the team is working on the WiFi topic and hopefully with the next release we will have the WiFi working and usable.

Yes, after some stability fixes we need to do, WIFI will be our major focus

Why not nail your IP address instead of DHCP?
Or possible extend the lease time for the DHCP, maybe less problems.

Hi all,

I also lost the Wifi connection on my volumio. After double checking a second instance of volumio running in my network, I realized that on this machine, the Wifi connection was also gone.

I’m using a fritz.box too. The problem is, that my fritz.box is configured to automatically search for the best channel. And I configured it to use channel 12 and 13 too.

BUT volumio / raspberry pi doesn’t seem to support that out of the box. If found this article: raspberrypi.stackexchange.com/qu … berry-pi-3

If I don’t allow channel 12 and 13 in my fritz.box, both machines instantly find my router, if I again enable to use channel 12 and 13 is fails. Volumio shows, that Wireless Networking is OFF, my Network isn’t shown in the list above and I’m unable to turn Wireless Networking on.

This seems to be the problem in my network.