wifi working but not....

wired, i can get into my network setting and log into my wifi ssid.
i can see it connected to both wired and wireless, but disconnecting the ethernet and i can’t connect via weUi.

cant see the ip on my fing app either.

sudo ifconfig -a
shows wlan0 and IP address i see in the webUi.

why is this so complicated??? urgg. this is night 2, so thought i’d ask for help.

hardware is a canakit wifi dongle, ralink RT5370 chip


any ideas what to check here this is driving me nuts!

tried a new wi-pi dongle with same results.

also tried a powered usb hub. no help.

why the hell is the status “connected” under network setting. dont get this.

Are you sure you are trying to connect to the right IP? Switching from LAN to WIFI connection usually results in a new IP address, maybe you should check your router for connected devices…

with ethernet connected and i go into volumio network settings, i see both wired and wlan connected with each their own IP. can access the wired ip but not wlan ip using browser.

disconnect the ethernet and i can see my wlan ip on my fing app (on phone), but can’t see it in my router settings.
still can’t access this ip address.

the blue led on the wipi is on too and occasionally blinking.

not sure what to check next.

searching around a bit and found the wireless adapter compatibility thread…

guess i was under the assumption that wireless adapters were “plug and play”… they are not.

i didn’t see that anyone has successfully ran a canakit or wipi with pi b+ and v1.55. so maybe i am not going crazy after all.

next step is figuring out how to find and load the driver/firmware. i think???

I had this problem as well with a wifi dongle (comfast). I follow the steps to load the driver and it still didn’t work. Happen to be I had a 10 years old Linksys wifi dongle, I connect to it and boot it works even without any driver install. Possibly because of the compatibility of the wifi dongle.